summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-11-30 12:02:54 +0000
committerBioArchLinuxBot2023-11-30 12:02:54 +0000
commitc55e72a42e3da9f439d4c65dd6dac1e6b83f83a3 (patch)
tree0d55e70e108154382369c5391569dc3daaaa3860
parentf5034e34942f2767a02ec9f15327307e3b084649 (diff)
downloadaur-c55e72a42e3da9f439d4c65dd6dac1e6b83f83a3.tar.gz
[lilac] updated to 0.12.0-2
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD34
2 files changed, 17 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6eb72a5ab005..12900250cc5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,13 @@
pkgbase = r-ggformula
pkgdesc = Formula Interface to the Grammar of Graphics
pkgver = 0.12.0
- pkgrel = 1
+ pkgrel = 2
url = https://cran.r-project.org/package=ggformula
arch = any
license = MIT
- depends = r
- depends = r-ggforce
depends = r-ggplot2
depends = r-ggridges
- depends = r-ggstance
depends = r-labelled
- depends = r-magrittr
depends = r-mosaiccore
depends = r-rlang
depends = r-scales
@@ -24,23 +20,20 @@ pkgbase = r-ggformula
optdepends = r-ggthemes
optdepends = r-interp
optdepends = r-knitr
- optdepends = r-lattice
optdepends = r-lubridate
optdepends = r-maps
- optdepends = r-maptools
optdepends = r-mosaic
optdepends = r-mosaicdata
optdepends = r-palmerpenguins
optdepends = r-purrr
optdepends = r-quantreg
- optdepends = r-rgeos
optdepends = r-rmarkdown
optdepends = r-sf
- optdepends = r-survival
optdepends = r-testthat
optdepends = r-tidyr
optdepends = r-vdiffr
source = https://cran.r-project.org/src/contrib/ggformula_0.12.0.tar.gz
+ md5sums = 8eee6fba1dc5081b680ecd4ae73c42b4
sha256sums = d569f83e059f9e4836bd513f92706fb8a614300f744dcc47bf86e8dafd8e776d
pkgname = r-ggformula
diff --git a/PKGBUILD b/PKGBUILD
index 8fe990d5ad64..7b7fb26ec84d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,19 @@
-# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=ggformula
_pkgver=0.12.0
pkgname=r-${_pkgname,,}
-pkgver=0.12.0
-pkgrel=1
-pkgdesc='Formula Interface to the Grammar of Graphics'
-arch=('any')
+pkgver=${_pkgver//-/.}
+pkgrel=2
+pkgdesc="Formula Interface to the Grammar of Graphics"
+arch=(any)
url="https://cran.r-project.org/package=${_pkgname}"
-license=('MIT')
+license=(MIT)
depends=(
- r
- r-ggforce
r-ggplot2
r-ggridges
- r-ggstance
r-labelled
- r-magrittr
r-mosaiccore
r-rlang
r-scales
@@ -31,33 +28,32 @@ optdepends=(
r-ggthemes
r-interp
r-knitr
- r-lattice
r-lubridate
r-maps
- r-maptools
r-mosaic
r-mosaicdata
r-palmerpenguins
r-purrr
r-quantreg
- r-rgeos
r-rmarkdown
r-sf
- r-survival
r-testthat
r-tidyr
r-vdiffr
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('8eee6fba1dc5081b680ecd4ae73c42b4')
sha256sums=('d569f83e059f9e4836bd513f92706fb8a614300f744dcc47bf86e8dafd8e776d')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
- install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "/usr/lib/R/library/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
}
-# vim:set ts=2 sw=2 et: