summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNg Oon-Ee2015-06-09 12:16:06 +0800
committerNg Oon-Ee2015-06-09 12:16:06 +0800
commitc564fef2dd707d3076d7ca6aa45786ebd404df9f (patch)
tree8abac53cfafe17e9063e776e2a4f66f81378dd39
downloadaur-c564fef2dd707d3076d7ca6aa45786ebd404df9f.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a3694ab9c86
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-docx
+ pkgdesc = A Python library for creating and updating Microsoft Word (.docx) files
+ pkgver = 0.7.6
+ pkgrel = 1
+ url = https://github.com/python-openxml/python-docx
+ arch = any
+ license = MIT
+ depends = python>=3.3
+ depends = python-lxml>=2.3.2
+ options = !emptydirs
+ source = https://github.com/python-openxml/python-docx/archive/v0.7.6.tar.gz
+ md5sums = 943405abb23caeb7163ca1529163787a
+
+pkgname = python-docx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84f1ca5e6f0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Ng Oon-Ee <n g o o n e e DOT t a l k AT gmail DOT com>
+_python=python
+_distname=docx
+pkgname=$_python-$_distname
+pkgver=0.7.6
+pkgrel=1
+pkgdesc="A Python library for creating and updating Microsoft Word (.docx) files"
+arch=(any)
+url="https://github.com/python-openxml/python-docx"
+license=('MIT')
+depends=('python>=3.3' 'python-lxml>=2.3.2')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("https://github.com/python-openxml/${pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=('943405abb23caeb7163ca1529163787a')
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ $_python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 || exit 1
+}