summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAner Andros2016-12-31 21:14:37 +0000
committerAner Andros2016-12-31 21:14:37 +0000
commitc572d30d4b132dfa5beebf5e7545c74575f0b7e5 (patch)
tree57db1ee3df050a1fcf6ff4a230ffdcf678931b7c
downloadaur-c572d30d4b132dfa5beebf5e7545c74575f0b7e5.tar.gz
first version. tested locally and working
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
-rw-r--r--git-it.desktop10
-rw-r--r--git-it.pngbin0 -> 12807 bytes
4 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c12c0f2a680e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = git-it
+ pkgdesc = Git-it is a desktop app that teaches you how to use Git and GitHub on the command line.
+ pkgver = 4.2.2
+ pkgrel = 1
+ url = https://github.com/jlord/git-it-electron
+ arch = x86_64
+ license = BSD
+ depends = electron
+ depends = git
+ depends = atom
+ provides = git-it
+ source = https://github.com/jlord/git-it-electron/releases/download/4.2.2/Git-it-Linux-x64.zip
+ source = git-it.desktop
+ source = git-it.png
+ md5sums = 206f8fbf6a4fe9e5fb1bd93a08735e4a
+ md5sums = d3591aa0a045fc1569eb00a4f6ebb26d
+ md5sums = 3fc4074dd6efa11246481d57dae86cf1
+
+pkgname = git-it
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bb3acbaca3f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Aner Andros <code@anerandros.info>
+
+pkgbase=git-it
+pkgname=git-it
+pkgrel=1
+pkgver=4.2.2
+pkgdesc="Git-it is a desktop app that teaches you how to use Git and GitHub on the command line."
+url="https://github.com/jlord/git-it-electron"
+provides=('git-it')
+arch=('x86_64')
+license=('BSD')
+depends=('electron' 'git' 'atom')
+makedepends=()
+backup=()
+install=''
+source=(
+ "https://github.com/jlord/git-it-electron/releases/download/${pkgver}/Git-it-Linux-x64.zip"
+ "${pkgname}.desktop"
+ "${pkgname}.png"
+)
+md5sums=('206f8fbf6a4fe9e5fb1bd93a08735e4a'
+ 'd3591aa0a045fc1569eb00a4f6ebb26d'
+ '3fc4074dd6efa11246481d57dae86cf1')
+
+package() {
+ install -d "$pkgdir"/opt
+
+ cp -R "$srcdir"/Git-it-linux-x64 "$pkgdir"/opt/Git-it-Linux-x64
+
+ install -d "$pkgdir"/usr/bin
+ ln -sf ../../opt/Git-it-Linux-x64/Git-it "$pkgdir"/usr/bin/git-it
+
+ install -D -m644 "./${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -D -m644 "./${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+}
diff --git a/git-it.desktop b/git-it.desktop
new file mode 100644
index 000000000000..9795e149a78e
--- /dev/null
+++ b/git-it.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=git-it
+Comment=Electron app to learn the git command line
+Exec="git-it"
+Icon=git-it
+Terminal=false
+Type=Application
+StartupNotify=true
+Categories=GNOME;GTK;Development;Documentation;
+MimeType=text/plain;
diff --git a/git-it.png b/git-it.png
new file mode 100644
index 000000000000..e3df500dbcdc
--- /dev/null
+++ b/git-it.png
Binary files differ