summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorle34n2021-02-28 17:56:18 +1100
committerle34n2021-02-28 17:56:18 +1100
commitc578050bc60b18e3fcb556044ebe958c76ffb639 (patch)
tree4fb89e595db64fac28a74b8e6d75c457dfe86e61
downloadaur-c578050bc60b18e3fcb556044ebe958c76ffb639.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD52
-rw-r--r--ponomar.desktop9
-rw-r--r--ponomar.install23
-rw-r--r--ponomar.pngbin0 -> 264 bytes
-rw-r--r--ponomar.sh9
6 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12561369d0fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = ponomar-git
+ pkgdesc = Ponomar is a fully-functional program suite for the Orthodox Church
+ pkgver = r918.59c46fd3c
+ pkgrel = 1
+ url = https://github.com/typiconman/ponomar.git
+ install = ponomar.install
+ arch = any
+ license = GPL-3.0
+ depends = java-runtime
+ depends = texinfo
+ provides = ponomar
+ conflicts = ponomar
+ replaces = ponomar
+ source = ponomar::git+https://github.com/typiconman/ponomar.git
+ source = ponomar.desktop
+ source = ponomar.sh
+ source = ponomar.png
+ md5sums = SKIP
+ md5sums = e45995e6c6cb6122bb36ca9cf53c6641
+ md5sums = 47b1fb0d4be2af9f867a52747bb7b703
+ md5sums = d8b4f7dd400cd7240ec63c8bcaddaec6
+
+pkgname = ponomar-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e02d4fe60932
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Aleksandr <contact at via dot aur>
+
+pkgname=ponomar-git
+pkgver=r918.59c46fd3c
+pkgrel=1
+pkgdesc="Ponomar is a fully-functional program suite for the Orthodox Church"
+arch=('any')
+url="https://github.com/typiconman/ponomar.git"
+license=('GPL-3.0')
+depends=('java-runtime' 'texinfo')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=("${pkgname%-git}")
+install="${pkgname%-git}.install"
+source=("ponomar::git+$url"
+ "${pkgname%-git}.desktop"
+ "${pkgname%-git}.sh"
+ "${pkgname%-git}.png")
+md5sums=('SKIP'
+ 'e45995e6c6cb6122bb36ca9cf53c6641'
+ '47b1fb0d4be2af9f867a52747bb7b703'
+ 'd8b4f7dd400cd7240ec63c8bcaddaec6')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make
+}
+package() {
+ cd "$srcdir/${pkgname%-git}"
+
+ install -dm0755 "$pkgdir/opt/${pkgname%-git}"
+ cp -r Ponomar "$pkgdir/opt/${pkgname%-git}/"
+ install -dm0755 "$pkgdir/usr/bin"
+
+ install -D -m644 ../${pkgname%-git}.desktop "$pkgdir/usr/share/applications/${pkgname%-git}.desktop"
+ install -D -m644 ../${pkgname%-git}.png "$pkgdir/usr/share/pixmaps/${pkgname%-git}.png"
+ install -D -m755 ../${pkgname%-git}.sh "$pkgdir/opt/${pkgname%-git}/ponomar.sh"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
+ install -D -m644 README.md "$pkgdir/usr/share/doc/${pkgname%-git}/README.md"
+
+ ln -s /opt/ponomar/ponomar.sh "$pkgdir/usr/bin/ponomar"
+
+ # Fix permissions
+ chmod 666 "$pkgdir/opt/${pkgname%-git}/Ponomar/languages/xml/${pkgname%-git}.config"
+}
+
+# vim: set ts=2 sw=2 ft=sh noet:
diff --git a/ponomar.desktop b/ponomar.desktop
new file mode 100644
index 000000000000..51b987a2c7a1
--- /dev/null
+++ b/ponomar.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Ponomar Project
+Comment=Ponomar Project
+Exec=ponomar
+Icon=ponomar.png
+Type=Application
+Terminal=false
+Categories=Office;
diff --git a/ponomar.install b/ponomar.install
new file mode 100644
index 000000000000..158005015ba6
--- /dev/null
+++ b/ponomar.install
@@ -0,0 +1,23 @@
+# Colors
+note() {
+ printf "${BLUE}==>${ALL_OFF}${BOLD} NOTE:${ALL_OFF} ${1}\n"
+}
+
+ALL_OFF="$(tput sgr0)"
+BOLD="$(tput bold)"
+BLUE="${BOLD}$(tput setaf 4)"
+GREEN="${BOLD}$(tput setaf 2)"
+
+
+post_install() {
+ echo ""
+ note "You can find more information on the following resources:"
+ note " https://ponomar.net"
+ note " https://github.com/typiconman/ponomar/"
+ echo ""
+}
+
+post_upgrade() {
+ post_install
+}
+
diff --git a/ponomar.png b/ponomar.png
new file mode 100644
index 000000000000..16a0ff1d3b38
--- /dev/null
+++ b/ponomar.png
Binary files differ
diff --git a/ponomar.sh b/ponomar.sh
new file mode 100644
index 000000000000..dbcc75942985
--- /dev/null
+++ b/ponomar.sh
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+PONOMAR_DIR=/opt/ponomar
+CLASSPATH=${PONOMAR_DIR}:${PONOMAR_DIR}/Ponomar/*
+
+cd ${PONOMAR_DIR}
+
+java -Dawt.useSystemAAFontSettings=on -Dsun.java2d.xrender=true -cp ${CLASSPATH} Ponomar.Main&
+