summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:16:18 +0100
committerDaniel Peukert2024-01-28 00:16:18 +0100
commitc5a8ae61c6dcd216e5f4d7df98cb241412109285 (patch)
tree237d8f8e9af8b9a37aeab31ab6e14a8eb7fe2438
parent2730a706a42e2d91b6ee037a2bae1f79d6231910 (diff)
downloadaur-c5a8ae61c6dcd216e5f4d7df98cb241412109285.tar.gz
Sync pkgbuilds repo with AUR
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD8
3 files changed, 18 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b06357794a4c..9c8286751c14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,14 +5,14 @@ pkgbase = ocaml-visitors
url = https://gitlab.inria.fr/fpottier/visitors
arch = x86_64
arch = aarch64
- license = LGPL2.1
+ license = LGPL-2.1-only
makedepends = dune>=2.0.0
depends = ocaml>=4.05.0
depends = ocaml-ppx_deriving>=5.0
depends = ocaml-ppxlib>=0.22.0
depends = ocaml-result
options = !strip
- source = ocaml-visitors-20210608-5.tar.gz::https://gitlab.inria.fr/fpottier/visitors/-/archive/20210608/visitors-20210608.tar.gz
+ source = ocaml-visitors-20210608.tar.gz::https://gitlab.inria.fr/fpottier/visitors/-/archive/20210608/visitors-20210608.tar.gz
sha512sums = 3abecb822dd37511421264d98868c937b7e81f209391e70cc66b7a4663aa059848a3f0ffe9de15408cb0b2112828118ef477a8b2ebf78d6323a4775eff31c055
pkgname = ocaml-visitors
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index 8fa4205f2cef..6889a52fd613 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,13 @@ pkgname="ocaml-$_projectname"
pkgver='20210608'
pkgrel='5'
pkgdesc='An OCaml syntax extension for generating visitor classes'
-# If you're running on aarch64, you have to add it to the arch array of the cppo, ocaml-biniou, ocaml-easy-format and ocaml-yojson AUR dependencies
arch=('x86_64' 'aarch64')
url="https://gitlab.inria.fr/fpottier/$_projectname"
-license=('LGPL2.1')
+license=('LGPL-2.1-only')
depends=('ocaml>=4.05.0' 'ocaml-ppx_deriving>=5.0' 'ocaml-ppxlib>=0.22.0' 'ocaml-result')
makedepends=('dune>=2.0.0')
options=('!strip')
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/-/archive/$pkgver/$_projectname-$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::$url/-/archive/$pkgver/$_projectname-$pkgver.tar.gz")
sha512sums=('3abecb822dd37511421264d98868c937b7e81f209391e70cc66b7a4663aa059848a3f0ffe9de15408cb0b2112828118ef477a8b2ebf78d6323a4775eff31c055')
_sourcedirectory="$_projectname-$pkgver"
@@ -25,7 +24,4 @@ build() {
package() {
cd "$srcdir/$_sourcedirectory/"
DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir '/usr/lib/ocaml' --docdir '/usr/share/doc' --mandir '/usr/share/man' --release --verbose
-
- install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
- ln -sf "/usr/share/doc/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}