summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Amanakis2019-05-22 16:32:04 -0400
committerGeorge Amanakis2019-05-22 16:32:04 -0400
commitc5b3955d2a1f90b5dfbcf0cc13600a753cfaa408 (patch)
treec4507f970e56b9d96fdc0436a2591b451cf5c7cb
parentc39a34b7442d841e1979df6991bfd1ae377cfc88 (diff)
downloadaur-c5b3955d2a1f90b5dfbcf0cc13600a753cfaa408.tar.gz
Remove exclusivity to allow shield to run
Signed-off-by: George Amanakis <gamanakis@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--0001-remove-exclusivity.patch11
-rw-r--r--PKGBUILD4
3 files changed, 15 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b769b450dcf..eb357fa3c060 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cpuset-git
pkgdesc = Cpuset is a Python application to make using the cpusets facilities in the Linux kernel easier.
- pkgver = r59.02ef9e0
+ pkgver = r76.b5a70c1
pkgrel = 1
url = https://github.com/lpechacek/cpuset/
arch = any
@@ -13,7 +13,7 @@ pkgbase = cpuset-git
source = git+https://github.com/lpechacek/cpuset
source = 0001-remove-exclusivity.patch
md5sums = SKIP
- md5sums = f944918002bde0e949a694741309fda8
+ md5sums = f3dc8cdca7977027c5683ce51462b6fa
pkgname = cpuset-git
diff --git a/0001-remove-exclusivity.patch b/0001-remove-exclusivity.patch
index 4f32866a54a7..3dfb947fb2e5 100644
--- a/0001-remove-exclusivity.patch
+++ b/0001-remove-exclusivity.patch
@@ -11,3 +11,14 @@
log.info('--> shielding modified with:')
# move root tasks into system set
root_tasks = cset.unique_set('/').tasks
+
+--- a/cpuset/commands/set.py 2019-05-22 16:16:08.518318722 -0400
++++ b/cpuset/commands/set.py 2019-05-22 16:23:06.243819897 -0400
+@@ -413,8 +413,8 @@ def modify(name, cpuspec=None, memspec=N
+ log.debug('modifying cpuset "%s"', nset.name)
+ if cpuspec: nset.cpus = cpuspec
+ if memspec: nset.mems = memspec
+- if cx: nset.cpu_exclusive = cx
+- if mx: nset.mem_exclusive = mx
++ # if cx: nset.cpu_exclusive = cx
++ # if mx: nset.mem_exclusive = mx
diff --git a/PKGBUILD b/PKGBUILD
index edb764961799..1c3e914c67ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jon Gjengset <jon@thesquareplanet.com>, Saren Arterius <saren@wtako.net>
# Maintainer: George Amanakis<gamanakis@gmail.com>
pkgname=cpuset-git
-pkgver=r59.02ef9e0
+pkgver=r76.b5a70c1
pkgver() {
cd "${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
@@ -20,7 +20,7 @@ conflicts=('cpuset')
source=('git+https://github.com/lpechacek/cpuset'
'0001-remove-exclusivity.patch')
md5sums=('SKIP'
- 'f944918002bde0e949a694741309fda8')
+ 'f3dc8cdca7977027c5683ce51462b6fa')
package() {
cd "$srcdir/${pkgname%-git}"