summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVasiliy Stelmachenok2021-10-11 10:06:37 +0300
committerVasiliy Stelmachenok2021-10-11 10:06:37 +0300
commitc5cf4cc14b8ab712ea9c968eb1bb6126a1c1bbf7 (patch)
treecfc01aef5e24a804bd5de42578949b3e034fb536
parentd4a10b589e00f7ab666e2b144b4b20d5f4352f1a (diff)
downloadaur-c5cf4cc14b8ab712ea9c968eb1bb6126a1c1bbf7.tar.gz
Hotfix
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5b05fc755d64..02fd8ee3f6e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -64,7 +64,7 @@ else
pkgname=(nvidia-dkms-performance nvidia-settings-performance nvidia-utils-performance opencl-nvidia-performance)
fi
pkgver=470.74
-pkgrel=7
+pkgrel=8
arch=('x86_64' 'aarch64')
url='https://www.nvidia.com/'
license=('custom')
@@ -159,11 +159,11 @@ prepare() {
echo "If you don't like it in time you can change it with the Xorg "RegistryDwords" option (in the bit value)"
echo "or rebuild it with the new value."
if [ "$_powermizer_scheme" = "1" ]; then
- registrydwords+=';PowerMizerEnable=0x1;PerfLevelSrc=0x2222;PowerMizerDefault=0x3;PowerMizerDefaultAC=0x1"'
+ registrydwords+=';PowerMizerEnable=0x1;PerfLevelSrc=0x2222;PowerMizerDefault=0x3;PowerMizerDefaultAC=0x1'
elif [ "$_powermizer_scheme" = "2" ]; then
- registrydwords+=';PowerMizerEnable=0x1;PerfLevelSrc=0x2233;PowerMizerDefault=0x3"'
+ registrydwords+=';PowerMizerEnable=0x1;PerfLevelSrc=0x2233;PowerMizerDefault=0x3'
elif [ "$_powermizer_scheme" = "3" ]; then
- registrydwords+=';PowerMizerEnable=0x1;PerfLevelSrc=0x2233;PowerMizerDefault=0x3"'
+ registrydwords+=';PowerMizerEnable=0x1;PerfLevelSrc=0x2233;PowerMizerDefault=0x3'
else
echo "You have selected the wrong powermizer scheme, please reread the option description in PKGBUILD."
fi
@@ -174,15 +174,15 @@ prepare() {
echo "If you don't like it in time you can change it with the Xorg "OverrideMaxPerf" option (in the bit value)"
echo "or rebuild it with the new value."
if [ "$_override_max_perf" = "1" ]; then
- registrydwords+=';OverrideMaxPerf=0x2"'
+ registrydwords+=';OverrideMaxPerf=0x2'
elif [ "$_override_max_perf" = "2" ]; then
- registrydwords+=';OverrideMaxPerf=0x3"'
+ registrydwords+=';OverrideMaxPerf=0x3'
else
echo "You selected the wrong value for the performance level forcing. Please reread the option description in PKGBUILD."
fi
fi
- sed -i "s/__NV_REGISTRY_DWORDS, NULL/__NV_REGISTRY_DWORDS, ${registrydwords}/" \
+ sed -i "s/__NV_REGISTRY_DWORDS, NULL/__NV_REGISTRY_DWORDS, ${registrydwords}\"/" \
kernel/nvidia/nv-reg.h
# workaround for dkms+clang