summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2021-02-28 22:50:33 +0100
committerGianluca Boiano2021-02-28 22:50:33 +0100
commitc5dda581802c9249f898711f2d297f64409227be (patch)
treeee3a4f0bf9607ff3c6c82e1c15c6a9e3bb7d4098
parenta654b7c9acd4ee3a0ec663590f83455b61231f6d (diff)
downloadaur-c5dda581802c9249f898711f2d297f64409227be.tar.gz
ocaml-bjack: 0.1.6
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD26
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f535678cdb40..b3ebec879127 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
-# Generated by mksrcinfo v8
-# Tue Jun 6 09:04:43 UTC 2017
pkgbase = ocaml-bjack
pkgdesc = OCaml blocking JACK API
- pkgver = 0.1.5
+ pkgver = 0.1.6
pkgrel = 1
url = https://github.com/savonet/ocaml-bjack
arch = i686
arch = x86_64
license = LGPL2.1
makedepends = ocaml-findlib
+ makedepends = dune
depends = ocaml
depends = jack
options = !strip
- source = https://github.com/savonet/ocaml-bjack/releases/download/0.1.5/ocaml-bjack-0.1.5.tar.gz
- md5sums = 684b2bac4b55d7ef35c72d42f32eee3f
+ source = https://github.com/savonet/ocaml-bjack/archive/v0.1.6.tar.gz
+ sha256sums = 92302504ee2124e82e6ace3e4f07c8b9f16db384ae70b4c1245f9e2b6a7301ed
pkgname = ocaml-bjack
diff --git a/PKGBUILD b/PKGBUILD
index b20f13e5b0bd..d6371ad26cfa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,31 @@
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Maintainer: robertfoster
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-bjack
-pkgver=0.1.5
+pkgver=0.1.6
pkgrel=1
pkgdesc="OCaml blocking JACK API"
url="https://github.com/savonet/ocaml-bjack"
arch=('i686' 'x86_64')
license=('LGPL2.1')
depends=('ocaml' 'jack')
-makedepends=('ocaml-findlib')
+makedepends=('ocaml-findlib' 'dune')
options=('!strip')
-source=("https://github.com/savonet/ocaml-bjack/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-md5sums=('684b2bac4b55d7ef35c72d42f32eee3f')
+source=("${url}/archive/v${pkgver}.tar.gz")
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure
- make
+ dune build
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
- export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
- make install
+ DESTDIR="${pkgdir}" dune install --prefix "/usr" --libdir "lib/ocaml"
+
+ install -dm755 "${pkgdir}/usr/share/"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}
+
+sha256sums=('92302504ee2124e82e6ace3e4f07c8b9f16db384ae70b4c1245f9e2b6a7301ed')