summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhayao2021-03-16 17:48:40 +0900
committerhayao2021-03-16 17:48:40 +0900
commitc6309d84bacdfdab01b5a58d076a5d873c7e9d75 (patch)
treeea220727ac554692fc640e1aadd326a6c111defe
parent58d84f9b13cb318db9ca5bedf466950e50b321ac (diff)
downloadaur-c6309d84bacdfdab01b5a58d076a5d873c7e9d75.tar.gz
[add] : Added unstable version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD8
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06a976fa1b08..641985de4eeb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = filezilla-bin
+pkgbase = filezilla-unstable-bin
pkgdesc = Free, open source FTP, FTPS and SFTP client (Pre-built binary)
- pkgver = 3.53.0
+ pkgver = 3.53.0_rc1
pkgrel = 1
url = https://filezilla-project.org
arch = i686
@@ -19,10 +19,10 @@ pkgbase = filezilla-bin
conflicts = filezilla
conflicts = filezilla-git
conflicts = libfilezilla
- source_i686 = FileZilla_3.53.0_i686-linux-gnu.tar.bz2::https://download.filezilla-project.org/client/FileZilla_3.53.0_i686-linux-gnu.tar.bz2
- sha512sums_i686 = 33e277e9b704e2bc53d9bc519bbae691430d99f9d3053bf2667f4a5791d8533abffef97334e60e649a37a7153c23c206513758e5c1ce23741c87a022b330871b
- source_x86_64 = FileZilla_3.53.0_x86_64-linux-gnu.tar.bz2::https://download.filezilla-project.org/client/FileZilla_3.53.0_x86_64-linux-gnu.tar.bz2
- sha512sums_x86_64 = c559215b425b732e6293daa70c0d59727f3d9d6cc22afd5f1e08365d162e300cd0ba1a054df71780ee147cce8578ac7d525382abfc83da79f6318561599912f9
+ source_i686 = FileZilla_3.53.0_rc1_i686-linux-gnu.tar.bz2::https://download.filezilla-project.org/client/FileZilla_3.53.0-rc1_i686-linux-gnu.tar.bz2
+ sha512sums_i686 = SKIP
+ source_x86_64 = FileZilla_3.53.0_rc1_x86_64-linux-gnu.tar.bz2::https://download.filezilla-project.org/client/FileZilla_3.53.0-rc1_x86_64-linux-gnu.tar.bz2
+ sha512sums_x86_64 = SKIP
-pkgname = filezilla-bin
+pkgname = filezilla-unstable-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1788a93de611..e09b135cf78d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Yamada Hayao <hayao@fascode.net>
_pkgname=filezilla
-pkgname="$_pkgname-bin"
-pkgver=3.53.0
+pkgname="${_pkgname}-unstable-bin"
+pkgver=3.53.0_rc1
pkgrel=1
pkgdesc='Free, open source FTP, FTPS and SFTP client (Pre-built binary)'
arch=('i686' 'x86_64')
@@ -15,10 +15,10 @@ conflicts=("${_pkgname}" "${_pkgname}-git" "libfilezilla")
machine_arch="${CARCH}"
for _arch in ${arch[@]}; do
- eval "source_${_arch}=(FileZilla_${pkgver}_${_arch}-linux-gnu.tar.bz2::https://download.filezilla-project.org/client/FileZilla_${pkgver}_${_arch}-linux-gnu.tar.bz2)"
+ eval "source_${_arch}=(FileZilla_${pkgver}_${_arch}-linux-gnu.tar.bz2::https://download.filezilla-project.org/client/FileZilla_${pkgver//_/-}_${_arch}-linux-gnu.tar.bz2)"
eval "sha512sums_${_arch}=(
'$(
- _url="https://download.filezilla-project.org/client/FileZilla_${pkgver}.sha512"
+ _url="https://download.filezilla-project.org/client/FileZilla_${pkgver//_/-}.sha512"
_sum="$(curl --silent -L "${_url}" | grep "FileZilla_${pkgver}_${_arch}-linux-gnu.tar.bz2")"
if [[ ! "${?}" = 0 ]] || [[ ! -v "_sum" ]] || [[ -z "${_sum}" ]]; then
echo -n "SKIP"