summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Witschel2020-08-06 17:52:46 +0200
committerJonas Witschel2020-08-06 17:52:46 +0200
commitc636f18fb309d917561217d3368a118ed85fce83 (patch)
tree22e67e79123273270bae28150efce3cbe958987b
parent677864a3d70c631a426abbc039811fde57e6f35d (diff)
downloadaur-c636f18fb309d917561217d3368a118ed85fce83.tar.gz
upgpkg: tpm2-tss-git 3.0.0.r16.76be63d6-1: sync with [community] PKGBUILD
Use swtpm instead of ibm-sw-tpm2 and improve reproducibility.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3911a702cea9..3302ace7a8c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = tpm2-tss-git
pkgdesc = Implementation of the TCG Trusted Platform Module 2.0 Software Stack (TSS2)
- pkgver = 2.4.0.r81.15073cc3
+ pkgver = 3.0.0.r16.76be63d6
pkgrel = 1
url = https://github.com/tpm2-software/tpm2-tss
arch = x86_64
license = BSD
- checkdepends = cmocka
- checkdepends = ibm-sw-tpm2
checkdepends = iproute2
+ checkdepends = swtpm
checkdepends = uthash
makedepends = git
makedepends = autoconf-archive
+ makedepends = cmocka
makedepends = doxygen
depends = curl
depends = json-c
@@ -24,6 +24,7 @@ pkgbase = tpm2-tss-git
provides = libtss2-sys.so
provides = libtss2-tctildr.so
conflicts = tpm2-tss
+ options = !emptydirs
backup = etc/tpm2-tss/fapi-config.json
backup = etc/tpm2-tss/fapi-profiles/P_ECCP256SHA256.json
backup = etc/tpm2-tss/fapi-profiles/P_RSA2048SHA256.json
diff --git a/PKGBUILD b/PKGBUILD
index a45ad79f783c..79692f4ca83d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
# Maintainer: Jonas Witschel <diabonas@archlinux.org>
# Contributor: Hexchain Tong <i at hexchain dot org>
pkgname=tpm2-tss-git
-pkgver=2.4.0.r81.15073cc3
+pkgver=3.0.0.r16.76be63d6
pkgrel=1
pkgdesc='Implementation of the TCG Trusted Platform Module 2.0 Software Stack (TSS2)'
arch=('x86_64')
url='https://github.com/tpm2-software/tpm2-tss'
license=('BSD')
depends=('curl' 'json-c' 'openssl' 'libjson-c.so')
-makedepends=('git' 'autoconf-archive' 'doxygen')
-checkdepends=('cmocka' 'ibm-sw-tpm2' 'iproute2' 'uthash')
+makedepends=('git' 'autoconf-archive' 'cmocka' 'doxygen')
+checkdepends=('iproute2' 'swtpm' 'uthash')
provides=("${pkgname%-git}" 'libtss2-esys.so' 'libtss2-fapi.so' 'libtss2-mu.so' 'libtss2-rc.so'
'libtss2-sys.so' 'libtss2-tctildr.so')
conflicts=("${pkgname%-git}")
backup=('etc/tpm2-tss/fapi-config.json'
'etc/tpm2-tss/fapi-profiles/P_ECCP256SHA256.json'
'etc/tpm2-tss/fapi-profiles/P_RSA2048SHA256.json')
+options=('!emptydirs')
source=("git+$url.git")
sha512sums=('SKIP')
@@ -34,7 +35,7 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
--with-runstatedir=/run --with-sysusersdir=/usr/lib/sysusers.d \
--with-tmpfilesdir=/usr/lib/tmpfiles.d --with-udevrulesprefix=60- \
- $( ((CHECKFUNC)) && echo --enable-unit --enable-integration)
+ --enable-unit $( ((CHECKFUNC)) && echo --enable-integration)
make
}