summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarvin Delgado2019-09-12 22:42:33 -0400
committerDarvin Delgado2019-09-12 22:42:33 -0400
commitc64267e328e455173b4149bd40770094564e9da5 (patch)
tree8f02b7c88f5f8eecb31b14c395eed714d8c07b07
downloadaur-c64267e328e455173b4149bd40770094564e9da5.tar.gz
first commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5aa75140c9d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = candy-icons-git
+ pkgdesc = Sweet gradient icons.
+ pkgver = r91.a3e3067
+ pkgrel = 1
+ url = https://github.com/EliverLara/candy-icons
+ arch = any
+ license = unknown
+ makedepends = git
+ provides = candy-icons
+ conflicts = candy-icons
+ options = !strip
+ source = git+https://github.com/EliverLara/candy-icons.git
+ sha256sums = SKIP
+
+pkgname = candy-icons-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b14db358f574
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Darvin Delgado <dnmodder@gmail.com>
+
+_gitname=candy-icons
+_autor=EliverLara
+pkgname=candy-icons-git
+pkgver=r91.a3e3067
+pkgrel=1
+pkgdesc="Sweet gradient icons."
+arch=('any')
+url="https://github.com/${_autor}/${_gitname}"
+license=('unknown')
+makedepends=('git')
+options=('!strip')
+provides=("candy-icons")
+conflicts=("candy-icons")
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -d ${pkgdir}/usr/share/icons
+ cp -r ${_gitname} ${pkgdir}/usr/share/icons/
+ find ${pkgdir}/usr -type f -exec chmod 644 {} \;
+ find ${pkgdir}/usr -type d -exec chmod 755 {} \;
+}