summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2020-02-06 11:28:23 +1030
committerWill Handley2020-02-06 11:28:23 +1030
commitc662b4a0d2efe699327822ffeebfd0e3e700caee (patch)
tree9fff201f61bf4cacd5359fcd0470f18af5898910
downloadaur-c662b4a0d2efe699327822ffeebfd0e3e700caee.tar.gz
version 0.1.1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13c040f7b930
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-persim
+ pkgdesc = Distances and representations of persistence diagrams
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/scikit-tda/persim
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-scikit-learn
+ depends = python-numpy
+ depends = python-matplotlib
+ depends = python-scipy
+ depends = python-hopcroftkarp-git
+ options = !emptydirs
+ source = https://github.com/scikit-tda/persim/archive/v0.1.1.tar.gz
+ sha256sums = b845d42f07d256d7004c12a767d55b540b0fc28c0ff719d2a4ccaa6d79b7d155
+
+pkgname = python-persim
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a51205ff45d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+_modulename=persim
+pkgname=python-$_modulename
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Distances and representations of persistence diagrams"
+arch=(any)
+url="https://github.com/scikit-tda/persim"
+license=('MIT')
+groups=()
+depends=('python-scikit-learn' 'python-numpy' 'python-matplotlib' 'python-scipy' 'python-hopcroftkarp-git')
+makedepends=('python-setuptools')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('b845d42f07d256d7004c12a767d55b540b0fc28c0ff719d2a4ccaa6d79b7d155')
+package() {
+ cd "$srcdir/$_modulename-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}