summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHanabishi2023-06-27 11:45:27 +0000
committerHanabishi2023-06-27 11:46:11 +0000
commitc679d4eed05170227aa1e557b21c454d17b7f2ce (patch)
tree04bf6e2e2df07b3bdcb35aa7842df86cf696b573
parent8a186776852fa373742d549c714f0fc7a650cd88 (diff)
downloadaur-c679d4eed05170227aa1e557b21c454d17b7f2ce.tar.gz
New version (0.3.18)
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD35
2 files changed, 30 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c940f12052f3..3741dd463664 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = torrent-file-editor
- pkgdesc = Cross-platform application intended to create and edit .torrent and uTorrent .dat files.
- pkgver = 0.3.17
- pkgrel = 3
+ pkgdesc = Qt based GUI tool designed to create and edit .torrent files
+ pkgver = 0.3.18
+ pkgrel = 1
url = https://torrent-file-editor.github.io/
arch = x86_64
license = GPL3
makedepends = cmake
makedepends = qt5-tools
depends = qt5-base
- source = torrent-file-editor-0.3.17-1ae5f71.tar.gz::https://github.com/torrent-file-editor/torrent-file-editor/archive/1ae5f71c3d52fae924efa71b0d8e5893a9ceb2c5.tar.gz
- sha256sums = a0fcfd43f7fb641e64a32919921761df84e06d78531ad45070f367a1f01e7e6e
+ source = https://github.com/torrent-file-editor/torrent-file-editor/releases/download/v0.3.18/torrent-file-editor-0.3.18.tar.gz
+ sha256sums = 29977de90102242eb3136031f167a8614efb852519bdc515393191b9088e171c
pkgname = torrent-file-editor
diff --git a/PKGBUILD b/PKGBUILD
index ec0d81157077..b1f31a704933 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,37 @@
+# To use Qt6 build, set QT6_BUILD environment variable. Example:
+# QT6_BUILD=1 makepkg -si
+
pkgname=torrent-file-editor
-pkgver=0.3.17
-pkgrel=3
-pkgdesc='Cross-platform application intended to create and edit .torrent and uTorrent .dat files.'
+pkgver=0.3.18
+pkgrel=1
+pkgdesc='Qt based GUI tool designed to create and edit .torrent files'
arch=('x86_64')
url="https://${pkgname}.github.io/"
license=('GPL3')
-depends=('qt5-base')
-makedepends=('cmake' 'qt5-tools')
-_commit='1ae5f71c3d52fae924efa71b0d8e5893a9ceb2c5'
-_snapshot="${pkgname}-${_commit}"
+if [ "${QT6_BUILD}" ]; then
+ depends=('qt6-base')
+ makedepends=('cmake' 'qt6-tools' 'qt6-5compat')
+ _buildflag='QT6_BUILD=1'
+else
+ depends=('qt5-base')
+ makedepends=('cmake' 'qt5-tools')
+ _buildflag='QT5_BUILD=1'
+fi
+
+_snapshot="${pkgname}-${pkgver}"
+source=("https://github.com/${pkgname}/${pkgname}/releases/download/v${pkgver}/${_snapshot}.tar.gz")
+sha256sums=('29977de90102242eb3136031f167a8614efb852519bdc515393191b9088e171c')
-source=("${pkgname}-${pkgver}-${_commit:0:7}.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/${_commit}.tar.gz")
-sha256sums=('a0fcfd43f7fb641e64a32919921761df84e06d78531ad45070f367a1f01e7e6e')
+prepare() {
+ # Fix wrong app version in the source
+ sed -i "s/set(APP_VERSION .*)/set(APP_VERSION \"${pkgver}\")/;" "${_snapshot}/CMakeLists.txt"
+}
build() {
cmake -B "build" -S "${_snapshot}" \
- -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ "-D${_buildflag}"
cmake --build "build"
}