aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorb08x2024-02-13 12:59:58 -0500
committerb08x2024-02-13 12:59:58 -0500
commitc681131d30c268cd1d788727ca95028b0059ea70 (patch)
tree3689a46fdc116c2b07f158ef479cc65d4ce9aebf
parent449159ab9be346db5bdfe8c048a1c3cb916f17ba (diff)
downloadaur-c681131d30c268cd1d788727ca95028b0059ea70.tar.gz
bumped to version 0.19
added patch to include cstdint in bipbuffer.h
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
-rw-r--r--bipscript-v0.4.patch11
-rw-r--r--bipscript-v0.5.patch11
-rw-r--r--bipscript-v0.6.patch11
-rw-r--r--bipscript-v0.7.patch24
-rw-r--r--bipscript-v0.9.patch11
-rw-r--r--bipscript-v19.patch12
8 files changed, 28 insertions, 73 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7cccddbfc031..7da7ea5f01c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = bipscript
pkgdesc = A scripting language for interactive music
- pkgver = 0.17
+ pkgver = 0.19
pkgrel = 1
url = http://www.bipscript.org
arch = i686
arch = x86_64
+ arch = x86_64_v3
groups = pro-audio
license = GPL
makedepends = cmake
@@ -21,6 +22,8 @@ pkgbase = bipscript
provides = bipscript
conflicts = bipscript
source = bipscript::git+https://gitlab.domainepublic.net/bipscript/bipscript.git
+ source = bipscript-v19.patch
sha256sums = SKIP
+ sha256sums = 5e0794a2d00ad631e76ac3921058681c0e1df31a61dcdd3574b3097d0ed11cea
pkgname = bipscript
diff --git a/PKGBUILD b/PKGBUILD
index c1fbf77cf4d5..6eb6d27a7798 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Robert Pannick <rwpannick@gmail.com>
# Contributor: Colean <colean@colean.cc>
pkgname=bipscript
-pkgver=0.17
+pkgver=0.19
pkgrel=1
pkgdesc="A scripting language for interactive music"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'x86_64_v3')
url="http://www.bipscript.org"
license=('GPL')
groups=('pro-audio')
@@ -12,8 +12,16 @@ depends=('boost-libs' 'fftw' 'lilv' 'liblo' 'libsndfile' 'portsmf')
makedepends=('cmake' 'boost' 'lv2' 'jack2' 'git')
provides=("bipscript")
conflicts=("bipscript")
-source=("$pkgname"::"git+https://gitlab.domainepublic.net/bipscript/bipscript.git")
-sha256sums=('SKIP')
+source=("$pkgname"::"git+https://gitlab.domainepublic.net/bipscript/bipscript.git"
+ "${pkgname}-v19.patch"
+ )
+sha256sums=('SKIP'
+ '5e0794a2d00ad631e76ac3921058681c0e1df31a61dcdd3574b3097d0ed11cea')
+
+prepare() {
+ cd "${pkgname}"
+ patch -Np1 -i "../${pkgname}-v19.patch"
+}
build() {
cd "$pkgname"
diff --git a/bipscript-v0.4.patch b/bipscript-v0.4.patch
deleted file mode 100644
index bd3b3c3aeeee..000000000000
--- a/bipscript-v0.4.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/bipscript-0.4/src/midifile.cpp 2018-12-11 08:50:57.000000000 -0800
-+++ ../bipscript/src/midifile.cpp 2019-02-02 16:46:39.819996298 -0800
-@@ -2,7 +2,7 @@
- #include <cstring>
- #include <iostream>
- #include <fstream>
--#include <portSMF/allegro.h>
-+#include <portsmf/allegro.h>
-
- namespace bipscript {
- namespace midi {
diff --git a/bipscript-v0.5.patch b/bipscript-v0.5.patch
deleted file mode 100644
index bd3b3c3aeeee..000000000000
--- a/bipscript-v0.5.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/bipscript-0.4/src/midifile.cpp 2018-12-11 08:50:57.000000000 -0800
-+++ ../bipscript/src/midifile.cpp 2019-02-02 16:46:39.819996298 -0800
-@@ -2,7 +2,7 @@
- #include <cstring>
- #include <iostream>
- #include <fstream>
--#include <portSMF/allegro.h>
-+#include <portsmf/allegro.h>
-
- namespace bipscript {
- namespace midi {
diff --git a/bipscript-v0.6.patch b/bipscript-v0.6.patch
deleted file mode 100644
index bd3b3c3aeeee..000000000000
--- a/bipscript-v0.6.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/bipscript-0.4/src/midifile.cpp 2018-12-11 08:50:57.000000000 -0800
-+++ ../bipscript/src/midifile.cpp 2019-02-02 16:46:39.819996298 -0800
-@@ -2,7 +2,7 @@
- #include <cstring>
- #include <iostream>
- #include <fstream>
--#include <portSMF/allegro.h>
-+#include <portsmf/allegro.h>
-
- namespace bipscript {
- namespace midi {
diff --git a/bipscript-v0.7.patch b/bipscript-v0.7.patch
deleted file mode 100644
index ae77282ae1f3..000000000000
--- a/bipscript-v0.7.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- ./src/bipscript-0.7/src/midifile.cpp 2018-12-11 08:50:57.000000000 -0800
-+++ ../bipscript/src/midifile.cpp 2019-02-02 16:46:39.819996298 -0800
-@@ -2,7 +2,7 @@
- #include <cstring>
- #include <iostream>
- #include <fstream>
--#include <portSMF/allegro.h>
-+#include <portsmf/allegro.h>
-
- namespace bipscript {
- namespace midi {
---- ./src/bipscript-0.7/CMakeLists.txt 2019-04-24 14:43:21.803333329 -0700
-+++ ../bipscript/CMakeLists.txt 2019-04-22 16:55:17.000000000 -0700
-@@ -10,8 +10,8 @@
- set(VERSION_COMMAND "git")
- set(VERSION_ARG "describe")
- else()
-- set(VERSION_COMMAND "cat")
-- set(VERSION_ARG "version")
-+ set(VERSION_COMMAND "echo")
-+ set(VERSION_ARG "${BIPSCRIPT_VERSION}")
- endif()
- message(STATUS "create version.h from ${VERSION_COMMAND} ${VERSION_ARG}")
- execute_process(COMMAND ${VERSION_COMMAND} ${VERSION_ARG}
diff --git a/bipscript-v0.9.patch b/bipscript-v0.9.patch
deleted file mode 100644
index da57b5cee687..000000000000
--- a/bipscript-v0.9.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/bipscript-v0.9/src/midifile.cpp 2020-08-31 17:56:43.000000000 +0100
-+++ ../bipscript/src/midifile.cpp 2020-10-03 10:52:19.479979296 +0100
-@@ -18,7 +18,7 @@
- #include <cstring>
- #include <fstream>
- #include <iostream>
--#include <portSMF/allegro.h>
-+#include <portsmf/allegro.h>
-
- #include "midifile.h"
- #include "miditune.h"
diff --git a/bipscript-v19.patch b/bipscript-v19.patch
new file mode 100644
index 000000000000..02d12095ae4c
--- /dev/null
+++ b/bipscript-v19.patch
@@ -0,0 +1,12 @@
+diff --git a/ext/lufsmeter/bipbuffer.h b/ext/lufsmeter/bipbuffer.h
+index a7f44f1..daf6005 100644
+--- a/ext/lufsmeter/bipbuffer.h
++++ b/ext/lufsmeter/bipbuffer.h
+@@ -20,6 +20,7 @@
+ #include <algorithm>
+ #include <assert.h>
+ #include <math.h>
++#include <cstdint>
+ #include <string.h>
+ #include <string>
+