summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author=2020-01-29 16:32:48 +0100
committer=2020-01-29 16:32:48 +0100
commitc6cc9c88dff5fa06ae871cea796b7872fe82c027 (patch)
treebe85356e822b143c84ae38d07b09ac7489fbaec2
parentb1559bcd849663f37fcdc4f44dc1406263534ee0 (diff)
downloadaur-c6cc9c88dff5fa06ae871cea796b7872fe82c027.tar.gz
fixed build, cleaned up git repo, added optdepends
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD13
4 files changed, 10 insertions, 24 deletions
diff --git a/.AURINFO b/.AURINFO
deleted file mode 100644
index 28d36ff30943..000000000000
--- a/.AURINFO
+++ /dev/null
@@ -1,14 +0,0 @@
-pkgbase = python-pweave
- pkgdesc = A scientific report generator and literate programming tool for Python.
- pkgver = 0.23
- pkgrel = 1
- url = http://mpastell.com/pweave/
- install =
- arch = any
- license = GPL
- depends = python
- source = http://pypi.python.org/packages/source/P/Pweave/Pweave-0.23.tar.gz
- options = !emptydirs
-
-pkgname = python-pweave
-
diff --git a/.SRCINFO b/.SRCINFO
index 7a2d5cb608b3..95d908012fab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pweave
pkgdesc = scientific report generator and literate programming tool for Python
pkgver = 0.30.3
- pkgrel = 1
+ pkgrel = 2
url = http://mpastell.com/pweave/
arch = any
license = BSD
@@ -14,6 +14,7 @@ pkgbase = python-pweave
depends = python-markdown
depends = python-pygments
depends = python
+ optdepends = pygmentize: for linted output
source = https://files.pythonhosted.org/packages/source/P/Pweave/Pweave-0.30.3.tar.gz
sha256sums = 5e5298d90e06414a01f48e0d6aa4c36a70c5f223d929f2a9c7e2d388451c7357
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index c230193ac7b8..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-src
-pkg
-*.tar.gz
-*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index bdcc3e035dd2..4da04519055c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,4 @@
+# Maintainer: solnce <echo c29sbmNlQHJhdGFqY3phay5vbmU= | base64 -d>
# Contributor: Lex Black <autumn-wind@web.de>
# Contributor: Tarn Burton <twburton at gmail dot com>
# Contributor: Milo Mirate <mmirate at gmx.com>
@@ -5,7 +6,7 @@
_pkgname=Pweave
pkgname=python-pweave
pkgver=0.30.3
-pkgrel=1
+pkgrel=2
pkgdesc="scientific report generator and literate programming tool for Python"
arch=(any)
url="http://mpastell.com/pweave/"
@@ -14,16 +15,18 @@ depends=('ipython' 'jupyter-nbconvert' 'jupyter-nbformat'
'python-ipykernel' 'python-jupyter_client'
'python-markdown' 'python-pygments' 'python')
makedepends=('python-setuptools')
+optdepends=('pygmentize: for linted output')
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
sha256sums=('5e5298d90e06414a01f48e0d6aa4c36a70c5f223d929f2a9c7e2d388451c7357')
build() {
- python setup.py build
+ cd "${_pkgname}-${pkgver}"
+ python setup.py build
}
package() {
- cd "$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}