summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTechnion2015-06-12 06:22:45 +0000
committerTechnion2015-06-12 06:22:45 +0000
commitc6d13b0fde2bc5d42dfe171b253fe8994f030c0b (patch)
tree422e26a205f3dc1b6a6e4ea94d12a9219282b1ac
downloadaur-c6d13b0fde2bc5d42dfe171b253fe8994f030c0b.tar.gz
Nginx 1.8.0 with LibreSSL 2.1.7
-rw-r--r--.SRCINFO47
-rw-r--r--PKGBUILD110
-rw-r--r--nginx.conf1
-rw-r--r--nginx.logrotate8
-rw-r--r--nginx.service18
5 files changed, 184 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..867676a4d29c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,47 @@
+pkgbase = nginx-libressl
+ pkgdesc = lightweight HTTP server and IMAP/POP3 proxy server with standard, additional and 3d party modules
+ pkgver = 1.8.0
+ pkgrel = 2
+ url = http://nginx.org
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = libxslt
+ makedepends = gd
+ makedepends = git
+ depends = pcre
+ depends = zlib
+ depends = pam
+ depends = gd
+ depends = hardening-wrapper
+ depends = libxslt
+ provides = nginx
+ conflicts = nginx
+ conflicts = nginx-unstable
+ conflicts = nginx-svn
+ conflicts = nginx-devel
+ conflicts = nginx-custom-dev
+ conflicts = nginx-full
+ backup = etc/nginx/nginx.conf
+ backup = etc/nginx/koi-win
+ backup = etc/nginx/koi-utf
+ backup = etc/nginx/win-utf
+ backup = etc/nginx/mime.types
+ backup = etc/nginx/fastcgi.conf
+ backup = etc/nginx/fastcgi_params
+ backup = etc/nginx/scgi_params
+ backup = etc/nginx/uwsgi_params
+ backup = etc/logrotate.d/nginx
+ source = nginx.conf
+ source = nginx.logrotate
+ source = nginx.service
+ source = http://nginx.org/download/nginx-1.8.0.tar.gz
+ source = http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.1.7.tar.gz
+ sha256sums = 8d8e314da10411b29157066ea313fc080a145d2075df0c99a1d500ffc7e8b7d1
+ sha256sums = 1504db3de81d0d01c9c9965b7029939e3bb7ab36745afaa4df425e9d680a4fd7
+ sha256sums = 225228970d779e1403ba4314e3cd8d0d7d16f8c6d48d7a22f8384db040eb0bdf
+ sha256sums = 23cca1239990c818d8f6da118320c4979aadf5386deda691b1b7c2c96b9df3d5
+ sha256sums = 1dc4bfc03fbe14732704291d6d9cb7a3cc70575957c958a7e2d686908e9cdb8f
+
+pkgname = nginx-libressl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff0c895148c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,110 @@
+# Maintainer: Joshua Small <technion@lolware.net>
+
+_pkgname="nginx"
+_user="http"
+_group="http"
+_doc_root="/usr/share/${_pkgname}/http"
+_sysconf_path="etc"
+_conf_path="${_sysconf_path}/${_pkgname}"
+_tmp_path="/var/spool/${_pkgname}"
+_pid_path="/run"
+_lock_path="/var/lock"
+_log_path="/var/log/${_pkgname}"
+
+
+pkgname=nginx-libressl
+pkgver=1.8.0
+pkgrel=2
+librever=2.1.7
+pkgdesc="lightweight HTTP server and IMAP/POP3 proxy server with standard, additional and 3d party modules"
+arch=('i686' 'x86_64')
+
+depends=('pcre' 'zlib' 'pam' 'gd' 'hardening-wrapper' 'libxslt')
+makedepends=(
+ 'libxslt'
+ 'gd'
+ 'git'
+)
+
+url="http://nginx.org"
+license=('custom')
+conflicts=('nginx' 'nginx-unstable' 'nginx-svn' 'nginx-devel' 'nginx-custom-dev' 'nginx-full')
+provides=('nginx')
+backup=("${_conf_path}/nginx.conf"
+ "${_conf_path}/koi-win"
+ "${_conf_path}/koi-utf"
+ "${_conf_path}/win-utf"
+ "${_conf_path}/mime.types"
+ "${_conf_path}/fastcgi.conf"
+ "${_conf_path}/fastcgi_params"
+ "${_conf_path}/scgi_params"
+ "${_conf_path}/uwsgi_params"
+ "etc/logrotate.d/nginx")
+
+source=( "nginx.conf"
+ "nginx.logrotate"
+ "nginx.service"
+ "http://nginx.org/download/nginx-$pkgver.tar.gz"
+ "http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-$librever.tar.gz"
+)
+
+
+build() {
+ local _src_dir="${srcdir}/${_pkgname}-${pkgver}"
+
+
+ cd $_src_dir
+ tar zxvf ../libressl-$librever.tar.gz
+
+ ./configure \
+ --prefix="/${_conf_path}" \
+ --conf-path="/${_conf_path}/nginx.conf" \
+ --sbin-path="/usr/bin/${_pkgname}" \
+ --pid-path="${_pid_path}/${_pkgname}.pid" \
+ --lock-path=${_pid_path}/${_pkgname}.lock \
+ --http-client-body-temp-path=${_tmp_path}/client_body_temp \
+ --http-proxy-temp-path=${_tmp_path}/proxy_temp \
+ --http-fastcgi-temp-path=${_tmp_path}/fastcgi_temp \
+ --http-uwsgi-temp-path=${_tmp_path}/uwsgi_temp \
+ --http-scgi-temp-path=${_tmp_path}scgi_temp \
+ --http-log-path=${_log_path}/access.log \
+ --error-log-path=${_log_path}/error.log \
+ --user=${_user} \
+ --group=${_group} \
+ --with-ipv6 \
+ --with-openssl=./libressl-$librever \
+ --with-imap \
+ --with-http_ssl_module \
+ --with-http_gzip_static_module \
+ --with-http_realip_module \
+ --with-http_spdy_module \
+ --with-file-aio
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir/" install
+
+ sed -i -e "s/\<user\s\+\w\+;/user $_user;/g" ${pkgdir}/$_conf_path/nginx.conf
+ mkdir -p ${pkgdir}/$_conf_path/sites-available/
+
+ install -d "${pkgdir}/${_tmp_path}"
+ install -d "${pkgdir}/${_doc_root}"
+
+ mv "${pkgdir}/${_conf_path}/html/"* "${pkgdir}/${_doc_root}"
+ rm -rf "${pkgdir}/${_conf_path}/html"
+
+ install -D -m644 "${srcdir}/nginx.logrotate" "${pkgdir}/etc/logrotate.d/${_pkgname}"
+ install -D -m644 "${srcdir}/nginx.conf" "${pkgdir}/etc/conf.d/${_pkgname}"
+ install -D -m644 "${srcdir}/nginx.service" "${pkgdir}/usr/lib/systemd/system/nginx.service"
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -D -m644 "man/nginx.8" "${pkgdir}/usr/share/man/man8/nginx.8"
+}
+
+sha256sums=('8d8e314da10411b29157066ea313fc080a145d2075df0c99a1d500ffc7e8b7d1'
+ '1504db3de81d0d01c9c9965b7029939e3bb7ab36745afaa4df425e9d680a4fd7'
+ '225228970d779e1403ba4314e3cd8d0d7d16f8c6d48d7a22f8384db040eb0bdf'
+ '23cca1239990c818d8f6da118320c4979aadf5386deda691b1b7c2c96b9df3d5'
+ '1dc4bfc03fbe14732704291d6d9cb7a3cc70575957c958a7e2d686908e9cdb8f')
diff --git a/nginx.conf b/nginx.conf
new file mode 100644
index 000000000000..1b748a007e17
--- /dev/null
+++ b/nginx.conf
@@ -0,0 +1 @@
+NGINX_CONFIG=/etc/nginx/nginx.conf
diff --git a/nginx.logrotate b/nginx.logrotate
new file mode 100644
index 000000000000..610444d5a3cd
--- /dev/null
+++ b/nginx.logrotate
@@ -0,0 +1,8 @@
+ /var/log/nginx/*log /var/log/nginx/*/*log {
+ daily
+ create 640 http log
+ compress
+ postrotate
+ [ ! -f /run/nginx.pid ] || kill -USR1 `cat /run/nginx.pid`
+ endscript
+ }
diff --git a/nginx.service b/nginx.service
new file mode 100644
index 000000000000..c237fd3051da
--- /dev/null
+++ b/nginx.service
@@ -0,0 +1,18 @@
+[Unit]
+Description=A high performance web server and a reverse proxy server
+After=network.target
+
+[Service]
+Type=forking
+PIDFile=/run/nginx.pid
+PrivateDevices=yes
+SyslogLevel=err
+
+ExecStartPre=/usr/bin/nginx -t -q -g 'pid /run/nginx.pid; error_log stderr;'
+ExecStart=/usr/bin/nginx -g 'pid /run/nginx.pid; error_log stderr;'
+ExecReload=/usr/bin/kill -HUP $MAINPID
+KillSignal=SIGQUIT
+KillMode=mixed
+
+[Install]
+WantedBy=multi-user.target