summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2017-01-08 05:03:15 +0100
committeranthraxx2017-01-08 05:03:15 +0100
commitc6fa759eb95913ba7beaf56378b1ba9153be9303 (patch)
tree19d6339d293252d141a0f498aa08601b0a2b9fdd
parent52a4b38cafc7a877a1103885f9f92e057882c4eb (diff)
downloadaur-c6fa759eb95913ba7beaf56378b1ba9153be9303.tar.gz
upgpkg: hashcat-git 3.30.3042.bb5663e4-1 (remove insecure rpath)
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
-rw-r--r--makefile.patch41
3 files changed, 7 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c66d70680c76..d6c29826899c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hashcat-git
pkgdesc = Multithreaded advanced password recovery utility
- pkgver = 3.20.2954.fa598a4
+ pkgver = 3.30.3042.bb5663e4
pkgrel = 1
url = https://hashcat.net/hashcat
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 182afd644b89..ab9d59470957 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Sam Stuewe <halosghost at archlinux dot info>
pkgname=hashcat-git
-pkgver=3.20.2954.fa598a4
+pkgver=3.30.3042.bb5663e4
pkgrel=1
pkgdesc='Multithreaded advanced password recovery utility'
url='https://hashcat.net/hashcat'
@@ -24,6 +24,11 @@ pkgver() {
"$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd ${pkgname}
+ sed 's|-Wl,-rpath .||g' -i src/Makefile
+}
+
build() {
cd ${pkgname}
make PREFIX=/usr
diff --git a/makefile.patch b/makefile.patch
deleted file mode 100644
index 7e1730d4734d..000000000000
--- a/makefile.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 7f8aaf74302816d03fbff62dab5c987d498acdde Mon Sep 17 00:00:00 2001
-From: anthraxx <levente@leventepolyak.net>
-Date: Mon, 4 Jul 2016 21:01:51 +0200
-Subject: [PATCH] extend global CFLAGS and LDFLAGS to aid distro packaging
-
-This preserves globally defined CFLAGS and LDFLAGS and simply
-extends those variables to aid distro based packaging toolchains
-and predefined distro wide defaults like SSP, relro etc.
----
- src/Makefile | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/src/Makefile b/src/Makefile
-index 9f11325..cf44590 100644
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -90,7 +90,7 @@ VERSION_TAG := $(shell test -d .git && git describe --tags --dirty=
- ## Compiler flags
- ##
-
--CFLAGS := -pipe -W -Wall -std=c99 -Iinclude/ -IOpenCL/ -I$(OPENCL_HEADERS_KHRONOS)/
-+CFLAGS += -pipe -W -Wall -std=c99 -Iinclude/ -IOpenCL/ -I$(OPENCL_HEADERS_KHRONOS)/
-
- ifndef DEBUG
- CFLAGS += -O2
-@@ -112,6 +112,7 @@ export MACOSX_DEPLOYMENT_TARGET=10.9
- CFLAGS_NATIVE := -D_POSIX -DDARWIN
- CFLAGS_NATIVE += $(CFLAGS)
- LFLAGS_NATIVE := -lpthread
-+LFLAGS_NATIVE += $(LDFLAGS)
- endif # darwin
-
- ifeq ($(UNAME),Linux)
-@@ -122,6 +123,7 @@ endif
- CFLAGS_NATIVE += $(CFLAGS)
- LFLAGS_NATIVE := -lpthread -ldl
- CFLAGS_NATIVE += -DHAVE_HWMON
-+LFLAGS_NATIVE += $(LDFLAGS)
- endif # linux
-
- ##