summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Bazley2019-01-06 01:15:09 +0000
committerSam Bazley2019-01-06 01:15:09 +0000
commitc6ffa2c53ab0a16b948978bb2632ee2be983b639 (patch)
treea0a6633b6cda5c954c5d9c4ab07d92a18f9d90f5
downloadaur-c6ffa2c53ab0a16b948978bb2632ee2be983b639.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c4413013279
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ujson-git
+ pkgdesc = Json library written in C
+ pkgver = 20181227185838
+ pkgrel = 1
+ url = https://gitlab.com/Niflheimr/ujson
+ arch = i686
+ arch = x86_64
+ license = ZLIB
+ makedepends = cmake
+ source = git+https://gitlab.com/Niflheimr/ujson.git
+ md5sums = SKIP
+
+pkgname = ujson-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..495f9fcb86c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+#Maintainer: Sam Bazley <sambazley@protonmail.com>
+pkgname=ujson-git
+pkgver=20181227185838
+pkgrel=1
+pkgdesc="Json library written in C"
+arch=("i686" "x86_64")
+url="https://gitlab.com/Niflheimr/ujson"
+license=("ZLIB")
+makedepends=("cmake")
+depends=()
+source=("git+https://gitlab.com/Niflheimr/ujson.git")
+md5sums=("SKIP")
+
+pkgver() {
+ cd ujson
+ git show -s --format=%ci HEAD | cut -d' ' -f1-2 | sed -r 's/[^0-9]//g'
+}
+
+prepare() {
+ cd "$srcdir/ujson"
+ git submodule init
+ git submodule update
+}
+
+build() {
+ cd "$srcdir/ujson"
+ cmake -DCMAKE_INSTALL_PREFIX="$pkgdir/usr" .
+ make
+}
+
+package() {
+ cd ujson
+ make install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}