summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDennis Hamester2015-09-09 20:48:45 +0200
committerDennis Hamester2015-09-09 20:48:45 +0200
commitc716e05f65becc08aa70e7ba4bf9bee1952dbbeb (patch)
treeb8fdae4c6e3a9976d023845e03bd61197d024476
downloadaur-c716e05f65becc08aa70e7ba4bf9bee1952dbbeb.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
-rw-r--r--vifm-git.install11
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..607e85862ab5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = vifm-git
+ pkgdesc = Ncurses based file manager with vi like keybindings
+ pkgver = 0.8.r272.g12c7c4f
+ pkgrel = 1
+ url = http://vifm.info/
+ install = vifm-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = ncurses
+ depends = desktop-file-utils
+ depends = file
+ optdepends = perl: vifm-convert-dircolors
+ provides = vifm
+ conflicts = vifm
+ source = git+https://github.com/vifm/vifm.git
+ sha256sums = SKIP
+
+pkgname = vifm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0a39ec4eb65
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Dennis Hamester <dennis.hamester@startmail.com>
+
+_pkgname=vifm
+pkgname=$_pkgname-git
+pkgver=0.8.r272.g12c7c4f
+pkgrel=1
+pkgdesc="Ncurses based file manager with vi like keybindings"
+arch=('i686' 'x86_64')
+url="http://vifm.info/"
+license=('GPL')
+depends=('ncurses' 'desktop-file-utils' 'file')
+optdepends=('perl: vifm-convert-dircolors')
+install=$pkgname.install
+conflicts=('vifm')
+provides=('vifm')
+source=("git+https://github.com/vifm/vifm.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}"/$_pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/v//g'
+}
+
+build() {
+ cd "${srcdir}"/$_pkgname
+ ./configure --prefix=/usr \
+ --without-gtk \
+ --without-X11
+ make
+}
+
+package() {
+ cd "${srcdir}"/$_pkgname
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/vifm-git.install b/vifm-git.install
new file mode 100644
index 000000000000..e111ef946053
--- /dev/null
+++ b/vifm-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}