summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblacksky32023-06-30 18:29:00 -0400
committerblacksky32023-06-30 18:29:00 -0400
commitc77070107bf157525319c45e4142dfdd19dee72f (patch)
tree3558111762004b71fb42d9cc0919dfa070b71924
parent489274e675493fc2a4725b8c73ec1a77e68b5199 (diff)
downloadaur-c77070107bf157525319c45e4142dfdd19dee72f.tar.gz
rework
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD16
2 files changed, 22 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f789eed73df4..ec2d9ad5370d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,4 @@
pkgbase = linux-pds
- pkgdesc = The Linux kernel and modules with Alfred Chen PDS/BMQ CPU scheduler with Arch and other improvement patches - PDS enabled
pkgver = 6.4.0
pkgrel = 1
url = https://www.kernel.org/
@@ -98,5 +97,19 @@ pkgbase = linux-pds
sha256sums = 7352643e67f651d322b2443e25f7b6ab30a667e3dde6fc2688cb75c24ef0ae84
pkgname = linux-pds
+ pkgdesc = The Linux kernel and modules with Alfred Chen PDS/BMQ CPU scheduler with Arch and other improvement patches - PDS enabled
+ depends = coreutils
+ depends = initramfs
+ depends = kmod
+ optdepends = wireless-regdb: to set the correct wireless channels of your country
+ optdepends = linux-firmware: firmware images needed for some devices
+ provides = VIRTUALBOX-GUEST-MODULES
+ provides = WIREGUARD-MODULE
+ provides = KSMBD-MODULE
+ replaces = virtualbox-guest-modules-arch
+ replaces = wireguard-arch
pkgname = linux-pds-headers
+ pkgdesc = Headers and scripts for building modules for the linux-pds package
+ depends = linux-pds
+ depends = pahole
diff --git a/PKGBUILD b/PKGBUILD
index f328fa5512c0..c77c85eb9c92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -41,20 +41,12 @@ fi
###################################################################################
pkgbase=linux-pds
-pkgname=("$pkgbase" "$pkgbase-headers")
-for _p in "${pkgname[@]}"; do
- eval "package_$_p() {
- $(declare -f "_package${_p#$pkgbase}")
- _package${_p#$pkgbase}
- }"
-done
pkgver=6.4.0
_pkgver=6.4
pkgrel=1
major=6.4
commit=1b45fa8cd58990bf455b429c598b6d4bad155172
arch=(x86_64)
-pkgdesc='The Linux kernel and modules with Alfred Chen PDS/BMQ CPU scheduler with Arch and other improvement patches - PDS enabled'
url='https://www.kernel.org/'
license=(GPL2)
makedepends=(bc cpio gettext git libelf pahole perl tar xz kmod xmlto)
@@ -508,4 +500,12 @@ sha256sums=('8fa0588f0c2ceca44cac77a0e39ba48c9f00a6b9dc69761c02a5d3efac8da7f3'
'8b7be40de00645ca42ee5c7079bf7d7531de75ecdff97a30914d5d604d7efb58'
'7352643e67f651d322b2443e25f7b6ab30a667e3dde6fc2688cb75c24ef0ae84')
+pkgname=($pkgbase $pkgbase-headers)
+for _p in "${pkgname[@]}"; do
+ eval "package_$_p() {
+ $(declare -f "_package${_p#$pkgbase}")
+ _package${_p#$pkgbase}
+ }"
+done
+
# vim:set ts=8 sts=2 sw=2 et: