summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2016-06-21 18:58:19 +0100
committerGrey Christoforo2016-06-21 18:58:19 +0100
commitc7824282f8466dcee05520661ba93a2fe537c9b0 (patch)
treea3875f3e2d48859cb5c703ec84ab54f74d82362c
downloadaur-c7824282f8466dcee05520661ba93a2fe537c9b0.tar.gz
initial commit
-rw-r--r--.SRCINFO35
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD50
-rw-r--r--apache.example.conf15
-rw-r--r--nextcloud-daily.install10
-rwxr-xr-xset-nc-perms.sh57
6 files changed, 175 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9700a1afb643
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+# Generated by mksrcinfo v8
+# Tue Jun 21 17:54:26 UTC 2016
+pkgbase = nextcloud-daily
+ pkgdesc = Daily build -- A safe home for all your data. Secure, under your control and developed in an open, transparent and trustworthy way
+ pkgver = 1
+ pkgrel = 1
+ url = https://nextcloud.com
+ install = nextcloud-daily.install
+ arch = any
+ license = AGPL
+ depends = php
+ depends = php-gd
+ optdepends = php-apache: to use the Apache web server
+ optdepends = php-sqlite: to use the SQLite database backend
+ optdepends = php-pgsql: to use the PostgreSQL database backend
+ optdepends = php-ldap: LDAP authentication
+ optdepends = php-intl
+ optdepends = php-apcu
+ optdepends = mariadb: to use the MySQL database backend
+ optdepends = smbclient: to mount SAMBA shares
+ optdepends = php-mcrypt
+ optdepends = imagemagick: file preview
+ optdepends = ffmpeg: file preview
+ optdepends = libreoffice: file preview
+ options = !strip
+ options = emptydirs
+ source = apache.example.conf
+ source = https://download.nextcloud.com/server/daily/latest.tar.bz2
+ source = set-nc-perms.sh
+ md5sums = bc2b02b0562b7a58e660e33acd4202bc
+ md5sums = SKIP
+ md5sums = 0c996a76cf39b2bccde8d74ac062895e
+
+pkgname = nextcloud-daily
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..41c065c69192
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*.tar.bz2
+*.asc
+*.pkg.tar.xz
+*.patch
+*.pkg.tar
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f9c9bf355877
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+
+pkgname=nextcloud-daily
+pkgver=1
+pkgrel=1
+pkgdesc="Daily build -- A safe home for all your data. Secure, under your control and developed in an open, transparent and trustworthy way"
+url="https://nextcloud.com"
+arch=('any')
+license=('AGPL')
+depends=('php' 'php-gd')
+optdepends=('php-apache: to use the Apache web server'
+ 'php-sqlite: to use the SQLite database backend'
+ 'php-pgsql: to use the PostgreSQL database backend'
+ 'php-ldap: LDAP authentication'
+ 'php-intl'
+ 'php-apcu'
+ 'mariadb: to use the MySQL database backend'
+ 'smbclient: to mount SAMBA shares'
+ 'php-mcrypt'
+ 'imagemagick: file preview'
+ 'ffmpeg: file preview'
+ 'libreoffice: file preview')
+options=('!strip')
+install=${pkgname}.install
+source=(apache.example.conf
+ https://download.nextcloud.com/server/daily/latest.tar.bz2
+ set-nc-perms.sh)
+md5sums=('bc2b02b0562b7a58e660e33acd4202bc'
+ 'SKIP'
+ '0c996a76cf39b2bccde8d74ac062895e')
+
+options=(!strip emptydirs)
+
+#prepare() {
+# cd nextcloud-${pkgver}
+#}
+
+package() {
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ cp "${srcdir}/nextcloud/COPYING-AGPL" "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ mkdir -p "${pkgdir}/usr/share/webapps"
+ cp -a nextcloud "${pkgdir}/usr/share/webapps/."
+
+ install -D -m755 "${srcdir}/set-nc-perms.sh" "${pkgdir}/usr/bin/set-nc-perms"
+ install -m644 -D "${srcdir}/apache.example.conf" -t "${pkgdir}/etc/webapps/nextcloud"
+ ln -s /usr/share/webapps/nextcloud/occ "${pkgdir}/usr/bin/occ"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/apache.example.conf b/apache.example.conf
new file mode 100644
index 000000000000..84f452ac274c
--- /dev/null
+++ b/apache.example.conf
@@ -0,0 +1,15 @@
+Alias /nextcloud "/usr/share/webapps/nextcloud"
+
+<Directory /usr/share/webapps/nextcloud/>
+ Options +FollowSymlinks
+ AllowOverride All
+ Require all granted
+
+ <IfModule mod_dav.c>
+ Dav off
+ </IfModule>
+
+ SetEnv HOME /usr/share/webapps/nextcloud
+ SetEnv HTTP_HOME /usr/share/webapps/nextcloud
+
+</Directory>
diff --git a/nextcloud-daily.install b/nextcloud-daily.install
new file mode 100644
index 000000000000..5a46de13a0d5
--- /dev/null
+++ b/nextcloud-daily.install
@@ -0,0 +1,10 @@
+# arg 1: the new package version
+# arg 2: the old package version
+
+post_install () {
+ set-nc-perms runtime
+}
+
+post_upgrade() {
+ set-nc-perms runtime
+}
diff --git a/set-nc-perms.sh b/set-nc-perms.sh
new file mode 100755
index 000000000000..19ddef43466f
--- /dev/null
+++ b/set-nc-perms.sh
@@ -0,0 +1,57 @@
+#!/usr/bin/env bash
+# from https://docs.nextcloud.org/server/9/admin_manual/installation/installation_wizard.html#strong-perms-label
+# run with the argument "runtime" to set the proper runtime permissions
+# run with the argument "upgrade" to set the proper upgrade permissions
+
+ncpath='/usr/share/webapps/nextcloud'
+htuser='http'
+htgroup='http'
+rootuser='root'
+
+runtime() {
+ printf "Creating possible missing Directories\n"
+ mkdir -p $ncpath/data
+ mkdir -p $ncpath/assets
+ mkdir -p $ncpath/updater
+
+ printf "chmod Files and Directories\n"
+ find ${ncpath}/ -type f -print0 | xargs -0 chmod 0640
+ find ${ncpath}/ -type d -print0 | xargs -0 chmod 0750
+
+ printf "chown Directories\n"
+ chown -R ${rootuser}:${htgroup} ${ncpath}/
+ chown -R ${htuser}:${htgroup} ${ncpath}/apps/
+ chown -R ${htuser}:${htgroup} ${ncpath}/assets/
+ chown -R ${htuser}:${htgroup} ${ncpath}/config/
+ chown -R ${htuser}:${htgroup} ${ncpath}/data/
+ chown -R ${htuser}:${htgroup} ${ncpath}/themes/
+ chown -R ${htuser}:${htgroup} ${ncpath}/updater/
+
+ chmod +x ${ncpath}/occ
+
+ printf "chmod/chown .htaccess\n"
+ if [ -f ${ncpath}/.htaccess ]
+ then
+ chmod 0664 ${ncpath}/.htaccess
+ chown ${rootuser}:${htgroup} ${ncpath}/.htaccess
+ fi
+ if [ -f ${ncpath}/data/.htaccess ]
+ then
+ chmod 0664 ${ncpath}/data/.htaccess
+ chown ${rootuser}:${htgroup} ${ncpath}/data/.htaccess
+ fi
+
+ printf "chmod/chown .user.ini\n"
+ if [ -f ${ncpath}/.user.ini ]
+ then
+ chmod 0664 ${ncpath}/.user.ini
+ chown ${rootuser}:${htgroup} ${ncpath}/.htaccess
+ fi
+}
+
+upgrade() {
+ printf "Setting upgrade permissions\n"
+ chown -R ${htuser}:${htgroup} ${ncpath}
+}
+
+$1