summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoey Darwish Dror2019-10-06 08:53:49 +0300
committerRoey Darwish Dror2019-10-06 08:53:49 +0300
commitc78e77e0bb4720a57ac9e0ea83327053e1b245b2 (patch)
tree79e5d831735f95657c7ae76709884fac037b905f
parentc504467c14130a3b60fc21c839b0eb3f8ff0cee5 (diff)
downloadaur-c78e77e0bb4720a57ac9e0ea83327053e1b245b2.tar.gz
v3.1.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rwxr-xr-xupdate.fish3
3 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f32d080deb51..afe5809d3606 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = topgrade
pkgdesc = Invoke the upgrade proceadure of multiple package managers
- pkgver = 3.0.2
+ pkgver = 3.1.0
pkgrel = 1
url = https://github.com/r-darwish/topgrade
arch = x86_64
arch = armv7
license = GPL3
makedepends = rust
- source = topgrade-3.0.2.tar.gz::https://github.com/r-darwish/topgrade/archive/v3.0.2.tar.gz
- sha256sums = f0b6e3f4cff2040f62ffba6dfadaf4f62a652d018967c7184a8abaa9004121f2
+ source = topgrade-3.1.0.tar.gz::https://github.com/r-darwish/topgrade/archive/v3.1.0.tar.gz
+ sha256sums = 801bec18bf3b9fd3dfa9f8343864e10dd47edae8a1d86a186d9c33a77af2608c
pkgname = topgrade
diff --git a/PKGBUILD b/PKGBUILD
index c3ed207c76ce..f288a46f6755 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Roey Darwish Dror <roey.ghost@gmail.com>
pkgname=topgrade
-pkgver=3.0.2
+pkgver=3.1.0
pkgrel=1
pkgdesc='Invoke the upgrade proceadure of multiple package managers'
arch=('x86_64' 'armv7')
@@ -9,7 +9,7 @@ url='https://github.com/r-darwish/topgrade'
license=('GPL3')
makedepends=('rust')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('f0b6e3f4cff2040f62ffba6dfadaf4f62a652d018967c7184a8abaa9004121f2')
+sha256sums=('801bec18bf3b9fd3dfa9f8343864e10dd47edae8a1d86a186d9c33a77af2608c')
build() {
cd "$pkgname-$pkgver"
diff --git a/update.fish b/update.fish
index efd6d24bf4c9..6a44a8f4f633 100755
--- a/update.fish
+++ b/update.fish
@@ -1,9 +1,8 @@
#!/usr/bin/env fish
set -l package_version $argv[1]
-set -l hash (string sub -l 64 (curl -L https://github.com/r-darwish/topgrade/archive/v$package_version.tar.gz ^/dev/null | sha256sum))
-sed -E "s/sha256sums=.*\$/sha256sums=\('$hash'\)/g" -i PKGBUILD
sed -E "s/pkgver=.*\$/pkgver=$package_version/g" -i PKGBUILD
+updpkgsums
makepkg --printsrcinfo > .SRCINFO
makepkg