summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJordan Day2019-10-27 13:42:06 -0500
committerJordan Day2019-10-27 13:42:06 -0500
commitc78f69e1b6b08e23e386f3edf1149c368c49fc54 (patch)
tree67165647fa9a6c7c4dbde5a61206f47d391c99ab
parentdd6ffe285b483cfc5fc175bec83bc270afe57074 (diff)
downloadaur-c78f69e1b6b08e23e386f3edf1149c368c49fc54.tar.gz
Update source
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 13 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8078f30a4c53..9d0724e612f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = dasm
pkgdesc = A versatile macro assembler with support for several 8-bit microprocessors including 6502, 6507, 6803, HD6303, 68HC11, 68705, and F8
pkgver = 2.20.11
- pkgrel = 3
- url = http://dasm-dillon.sourceforge.net/
+ pkgrel = 4
+ url = https://dasm-assembler.github.io/
arch = x86_64
license = GPL2
makedepends = gcc
depends = glibc
provides = dasm
provides = ftohex
- source = https://downloads.sourceforge.net/project/dasm-dillon/dasm-dillon/2.20.11/dasm-2.20.11-2014.03.04-source.tar.gz
- sha256sums = a9330adae534aeffbfdb8b3ba838322b92e1e0bb24f24f05b0ffb0a656312f36
+ source = https://github.com/dasm-assembler/dasm/archive/2.20.11.tar.gz
+ sha256sums = c69bbe192159dcf75677ca13bba65c3318dc443f2df45fccd3c060b2e092c7f5
pkgname = dasm
diff --git a/PKGBUILD b/PKGBUILD
index 7c531a4befa9..a853a47ea398 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,36 +2,33 @@
pkgname=dasm
pkgver=2.20.11
-pkgrel=3
-_relyear=2014
-_relmonth=03
-_relday=04
+pkgrel=4
pkgdesc="A versatile macro assembler with support for several 8-bit microprocessors including 6502, 6507, 6803, HD6303, 68HC11, 68705, and F8"
arch=('x86_64')
-url="http://dasm-dillon.sourceforge.net/"
-source=(https://downloads.sourceforge.net/project/dasm-dillon/dasm-dillon/${pkgver}/${pkgname}-${pkgver}-${_relyear}.${_relmonth}.${_relday}-source.tar.gz)
-sha256sums=('a9330adae534aeffbfdb8b3ba838322b92e1e0bb24f24f05b0ffb0a656312f36')
+url="https://dasm-assembler.github.io/"
+source=(https://github.com/dasm-assembler/dasm/archive/${pkgver}.tar.gz)
+sha256sums=('c69bbe192159dcf75677ca13bba65c3318dc443f2df45fccd3c060b2e092c7f5')
license=('GPL2')
provides=('dasm' 'ftohex')
depends=('glibc')
makedepends=('gcc')
build() {
- cd "$srcdir/${pkgname}-${pkgver}-${_relyear}${_relmonth}${_relday}"
+ cd "$srcdir/${pkgname}-${pkgver}"
make
}
package() {
- cd "$srcdir/dasm-${pkgver}-${_relyear}${_relmonth}${_relday}"
+ cd "$srcdir/dasm-${pkgver}"
install -dm755 "$pkgdir/usr/bin"
install -Dm755 bin/dasm bin/ftohex "$pkgdir/usr/bin"
install -dm755 "$pkgdir/usr/share/man/man1" "$pkgdir/usr/share/doc/dasm"
install -Dm644 doc/dasm.1 "$pkgdir/usr/share/man/man1"
- install -Dm644 doc/dasm.txt doc/ftohex.txt "$pkgdir/usr/share/doc/dasm"
+ install -Dm644 doc/DASM.TXT doc/FTOHEX.TXT "$pkgdir/usr/share/doc/dasm"
install -dm755 "$pkgdir/usr/include/dasm/atari2600" "$pkgdir/usr/include/dasm/channel-f"
- install -Dm644 machines/atari2600/* "$pkgdir/usr/include/dasm/atari2600"
- install -Dm644 machines/channel-f/* "$pkgdir/usr/include/dasm/channel-f"
+ install -Dm644 Machines/ATARI2600/* "$pkgdir/usr/include/dasm/atari2600"
+ install -Dm644 Machines/CHANNEL-F/* "$pkgdir/usr/include/dasm/channel-f"
}