summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChee Sing Lee2016-01-12 15:39:25 -0800
committerChee Sing Lee2016-01-12 15:39:25 -0800
commitc79302f10bb6516f5ca3ad6e314fba104d43a918 (patch)
treefc06ed2e705956d1a9b23e39adc51b2f3e17f83e
downloadaur-c79302f10bb6516f5ca3ad6e314fba104d43a918.tar.gz
initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD55
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68fcefd21057
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Tue Jan 12 23:39:20 UTC 2016
+pkgbase = tableau-sdk
+ pkgdesc = C/C++/Java SDK for creating and publishing extracts to a Tableau Server
+ pkgver = 9_2_0
+ pkgrel = 1
+ url = http://tableau.com/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = curl
+ depends = qt5-base
+ depends = java-environment
+ depends = gcc-libs-multilib
+ depends = expat
+ depends = boost-libs
+ noextract = libcurl.so
+ noextract = libcurl.so.4
+ noextract = libcurl.so.4.4.0
+ source_i686 = http://downloads.tableau.com/tssoftware/Tableau-SDK-Linux-32Bit-9-2-0.tar.gz
+ md5sums_i686 = 47c620440759ad2a5c80fff0a0258974
+ source_x86_64 = http://downloads.tableau.com/tssoftware/Tableau-SDK-Linux-64Bit-9-2-0.tar.gz
+ md5sums_x86_64 = 3816a83ea5e0c4b3a2e8d96d4b62fb57
+
+pkgname = tableau-sdk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9e8e1d7b782
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Chee Sing Lee <cheesinglee@gmail.com>
+pkgname=tableau-sdk
+pkgver=9_2_0
+pkgrel=1
+pkgdesc="C/C++/Java SDK for creating and publishing extracts to a Tableau Server"
+arch=('i686' 'x86_64')
+url="http://tableau.com/"
+license=('custom')
+groups=()
+depends=('curl' 'qt5-base' 'java-environment' 'gcc-libs-multilib' 'expat' \
+ 'boost-libs')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source_i686=("http://downloads.tableau.com/tssoftware/Tableau-SDK-Linux-32Bit-${pkgver//_/-}.tar.gz")
+source_x86_64=("http://downloads.tableau.com/tssoftware/Tableau-SDK-Linux-64Bit-${pkgver//_/-}.tar.gz")
+noextract=('libcurl.so' 'libcurl.so.4' 'libcurl.so.4.4.0')
+md5sums_i686=('47c620440759ad2a5c80fff0a0258974')
+md5sums_x86_64=('3816a83ea5e0c4b3a2e8d96d4b62fb57')
+validpgpkeys=()
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ mkdir $pkgdir/usr/include
+ mkdir $pkgdir/usr/lib
+ mkdir -p $pkgdir/usr/share/licenses/$pkgname
+ if [ $CARCH == i686 ]; then
+ cd tableausdk-linux32-9200.15.1201.0018
+ cp -r bin/* $pkgdir/usr/bin/
+ cp -r include/* $pkgdir/usr/include/
+ cp -r lib/* $pkgdir/usr/lib/
+ cp -r share/* $pkgdir/usr/share/
+ else
+ cd tableausdk-linux64-9200.15.1201.0018
+ cp -r bin/* $pkgdir/usr/bin/
+ cp -r include/* $pkgdir/usr/include/
+ cp -r lib64/* $pkgdir/usr/lib/
+ cp -r share/* $pkgdir/usr/share/
+ fi
+ cp share/tableausdk-9200.15.1201.0018/LICENSE.txt \
+ $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ echo "/usr/lib/tableausdk" > $pkgdir/etc/ld.so.conf.d/tableau-sdk.conf
+}