summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Harrison2019-07-02 09:26:29 -0400
committerMatt Harrison2019-07-02 09:26:29 -0400
commitc7a7289a6fd8c352424ebf918c3d4a78f0a1ffba (patch)
treea82e6cf5998aef9f42f1aefb045a8d1b78f8dd0c
downloadaur-c7a7289a6fd8c352424ebf918c3d4a78f0a1ffba.tar.gz
Initial upload: robotstxt 0.0.0.7-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e08db551928c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = robotstxt
+ pkgdesc = Google's robots.txt parser and matcher as a C++ library (compliant to C++11).
+ pkgver = 0.0.0.7
+ pkgrel = 1
+ url = https://github.com/google/robotstxt
+ arch = x86_64
+ license = Apache
+ makedepends = bazel
+ depends = gcc-libs
+ source = robotstxt-0.0.0.7.tar.gz::https://github.com/google/robotstxt/archive/59f3643d3a3ac88f613326dd4dfc8c9b9a545e45.tar.gz
+ sha256sums = ecee5d08e73d1e4afc888ce0ba77541bf8b00a14407ca473ecf8229f6cd80033
+
+pkgname = robotstxt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e4319459406
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Matt Harrison <matt@harrison.us.com>
+# Maintained at: https://github.com/matt-h/aur-pkgbuilds
+
+pkgname=robotstxt
+# No released version yet, so versioned based on the number of commits.
+# Zeros to preserve numbering for any future version available.
+pkgver=0.0.0.7
+pkgrel=1
+pkgdesc="Google's robots.txt parser and matcher as a C++ library (compliant to C++11)."
+arch=('x86_64')
+url="https://github.com/google/robotstxt"
+license=('Apache')
+depends=('gcc-libs')
+makedepends=('bazel')
+_git_commit='59f3643d3a3ac88f613326dd4dfc8c9b9a545e45'
+source=("$pkgname-$pkgver.tar.gz::https://github.com/google/robotstxt/archive/$_git_commit.tar.gz")
+sha256sums=('ecee5d08e73d1e4afc888ce0ba77541bf8b00a14407ca473ecf8229f6cd80033')
+
+build() {
+ cd "$srcdir/robotstxt-$_git_commit"
+ bazel build :robots_main
+}
+
+package() {
+ install -dm0755 "$pkgdir/usr/bin"
+
+ install -m0755 "$srcdir/robotstxt-$_git_commit/bazel-bin/robots_main" "$pkgdir/usr/bin/robots_main"
+}
+
+check() {
+ cd "$srcdir/robotstxt-$_git_commit"
+ bazel test :robots_test
+}