summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Marc Lenoir2023-10-21 15:47:11 +0200
committerJean-Marc Lenoir2023-10-21 15:47:11 +0200
commitc7cb1c99948de29c10395ae127927b3425fbb030 (patch)
tree3236254e9371967b85606d51df3922afbbbdc960
parent86d1d0623e4d06db0548658ce566226327e0faaf (diff)
downloadaur-c7cb1c99948de29c10395ae127927b3425fbb030.tar.gz
Sync with vmware-workstation 17.5.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--vmmon.patch18
-rw-r--r--vmnet.patch133
4 files changed, 66 insertions, 99 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21ed54b6eec7..3ef653eb34d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vmware-workstation11
pkgdesc = The industry standard for running multiple operating systems as virtual machines on a single Linux PC.
pkgver = 11.1.4
- pkgrel = 27
+ pkgrel = 28
url = https://www.vmware.com/products/workstation-for-linux.html
install = vmware-workstation.install
arch = x86_64
@@ -84,7 +84,7 @@ pkgbase = vmware-workstation11
sha256sums = fe1b1be8297f4170406f97dd1f8b385d911faf45afe19cbc0c26b8092b3ddf8d
sha256sums = 10562d11d50edab9abc2b29c8948714edcb9b084f99b3766d07ddd21259e372e
sha256sums = 273d4357599a3e54259c78cc49054fef8ecfd2c2eda35cbcde3a53a62777a5ac
- sha256sums = 3882927de5579dec922a9ff070d86a71ab62b96db53406ccf1e9e4e17e803a0b
- sha256sums = 125e70e50c3a38b66b56e750351c6a311c8710c7a8e154e07a55022e37428899
+ sha256sums = d98e85217d625399187d900f1fbeb9fcd574f1edeeafaf77100938fdc14a1607
+ sha256sums = 73527182ab476871fa816f7705b1926ca2d48290ae32c9a0f085aefee92be439
pkgname = vmware-workstation11
diff --git a/PKGBUILD b/PKGBUILD
index d97d5400ace4..59c393108c15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ pkgname=vmware-workstation11
pkgver=11.1.4
_buildver=3848939
_pkgver=${pkgver}_${_buildver}
-pkgrel=27
+pkgrel=28
pkgdesc='The industry standard for running multiple operating systems as virtual machines on a single Linux PC.'
arch=(x86_64)
url='https://www.vmware.com/products/workstation-for-linux.html'
@@ -121,8 +121,8 @@ sha256sums=(
'10562d11d50edab9abc2b29c8948714edcb9b084f99b3766d07ddd21259e372e'
'273d4357599a3e54259c78cc49054fef8ecfd2c2eda35cbcde3a53a62777a5ac'
- '3882927de5579dec922a9ff070d86a71ab62b96db53406ccf1e9e4e17e803a0b'
- '125e70e50c3a38b66b56e750351c6a311c8710c7a8e154e07a55022e37428899'
+ 'd98e85217d625399187d900f1fbeb9fcd574f1edeeafaf77100938fdc14a1607'
+ '73527182ab476871fa816f7705b1926ca2d48290ae32c9a0f085aefee92be439'
)
options=(!strip emptydirs)
@@ -450,7 +450,7 @@ if [ -n "$_enable_macOS_guests" ]; then
done
msg "Patching EFI firmwares to disable macOS server checking"
- _efi_arch=(32 64)
+ _efi_arch=("32" "64")
for arch in ${_efi_arch[@]}
do
objcopy "$pkgdir"/usr/lib/vmware/bin/vmware-vmx -O binary -j efi${arch} --set-section-flags efi${arch}=a efi${arch}.rom.Z
diff --git a/vmmon.patch b/vmmon.patch
index e913e82f5239..bc76665b5773 100644
--- a/vmmon.patch
+++ b/vmmon.patch
@@ -490,7 +490,7 @@
*
* Results:
* INVALID_MPN on failure
-@@ -47,230 +46,66 @@
+@@ -47,230 +46,70 @@
*/
static INLINE MPN64
@@ -679,7 +679,11 @@
+ } else {
+ pte_t *pte;
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(6,5,0)
++ pte = pte_offset_kernel(pmd, addr);
++#else
+ pte = pte_offset_map(pmd, addr);
++#endif
+ if (pte_present(*pte) == 0) {
+ pte_unmap(pte);
+ return INVALID_MPN;
@@ -1875,15 +1879,3 @@
break;
}
-Patch taken from https://raw.githubusercontent.com/jeffersonchua/linux-6.5.0/main/patch-17.0.2-6.5.0
---- a/vmmon/include/pgtbl.h
-+++ b/vmmon/include/pgtbl.h
-@@ -91,7 +91,7 @@
- } else {
- pte_t *pte;
-
-- pte = pte_offset_map(pmd, addr);
-+ pte = pte_offset_kernel(pmd, addr);
- if (pte_present(*pte) == 0) {
- pte_unmap(pte);
- return INVALID_MPN;
diff --git a/vmnet.patch b/vmnet.patch
index 86efb600f906..cfec7bad9d5b 100644
--- a/vmnet.patch
+++ b/vmnet.patch
@@ -37,6 +37,16 @@
MODULEBUILDDIR=$(MODULEBUILDDIR) postbuild
--- a/vmnet/bridge.c
+++ b/vmnet/bridge.c
+@@ -26,6 +26,9 @@
+ #include <linux/slab.h>
+ #include <linux/poll.h>
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(6, 4, 10)
++#include <net/gso.h>
++#endif
+ #include <linux/netdevice.h>
+ #include <linux/etherdevice.h>
+ #include <linux/mm.h>
@@ -65,7 +65,7 @@
#endif
@@ -128,6 +138,50 @@
+#endif
+
#endif /* __COMPAT_NETDEVICE_H__ */
+--- a/vmnet/driver.c
++++ b/vmnet/driver.c
+@@ -279,7 +279,7 @@ VNetRemovePortFromList(const VNetPort *port) // IN: port to remove from list
+ /*
+ *----------------------------------------------------------------------
+ *
+- * init_module --
++ * LinuxDriverInit --
+ *
+ * linux module entry point. Called by /sbin/insmod command.
+ * Initializes module and Registers this driver for a
+@@ -296,7 +296,7 @@ VNetRemovePortFromList(const VNetPort *port) // IN: port to remove from list
+ */
+
+ int
+-init_module(void)
++LinuxDriverInit(void)
+ {
+ int retval;
+
+@@ -358,7 +358,7 @@ init_module(void)
+ /*
+ *----------------------------------------------------------------------
+ *
+- * cleanup_module --
++ * LinuxDriverExit --
+ *
+ * Called by /sbin/rmmod. Unregisters this driver for a
+ * vnet major #, and deinitializes the modules. The 64-bit
+@@ -375,7 +375,7 @@ init_module(void)
+ */
+
+ void
+-cleanup_module(void)
++LinuxDriverExit(void)
+ {
+ unregister_chrdev(VNET_MAJOR_NUMBER, "vmnet");
+ VNetProtoUnregister();
+@@ -1705,3 +1705,5 @@ MODULE_LICENSE("GPL v2");
+ * by default (i.e., neither mkinitrd nor modprobe will accept it).
+ */
+ MODULE_INFO(supported, "external");
++module_init(LinuxDriverInit);
++module_exit(LinuxDriverExit);
--- a/vmnet/netif.c
+++ b/vmnet/netif.c
@@ -149,7 +149,7 @@ VNetNetIf_Create(char *devName, // IN:
@@ -540,82 +594,3 @@ Fixing VMWare Player on Linux when using DHCP addresses: https://www.nikhef.nl/~
if (count < n) {
n = count;
}
-From 0ca979d4bd06144204d720bb82f0a1e29024f9fa Mon Sep 17 00:00:00 2001
-From: Michal Kubecek <mkubecek@suse.cz>
-Date: Wed, 18 Jan 2023 00:19:52 +0100
-Subject: [PATCH] vmnet: use explicit module_init() and module_exit() (#187)
-
-While vmmon module already uses explicit module_init() and module_exit()
-for its init and cleanup function, vmnet relies on traditional magic names
-init_module() and cleanup_module(). Apparently this has an unfortunate side
-effect that the two functions are not identified as indirect call targets
-by objdump and they get "sealed" when the module is built against and
-loaded into an IBT enabled kernel.
-
-Starting with 6.3-rc1, objtool is going to warn about this issue,
-indicating that the legacy module initialization is deprecated and
-module_init() and module_exit() macros should be used instead so do that
-for vmnet as well.
----
- vmnet-only/driver.c | 10 ++++++----
- 1 file changed, 6 insertions(+), 4 deletions(-)
-
-diff --git a/vmnet-only/driver.c b/vmnet-only/driver.c
-index 197a213..b22cbfb 100644
---- a/vmnet-only/driver.c
-+++ b/vmnet-only/driver.c
-@@ -279,7 +279,7 @@ VNetRemovePortFromList(const VNetPort *port) // IN: port to remove from list
- /*
- *----------------------------------------------------------------------
- *
-- * init_module --
-+ * vmnet_init_module --
- *
- * linux module entry point. Called by /sbin/insmod command.
- * Initializes module and Registers this driver for a
-@@ -296,7 +296,7 @@ VNetRemovePortFromList(const VNetPort *port) // IN: port to remove from list
- */
-
- int
--init_module(void)
-+vmnet_init_module(void)
- {
- int retval;
-
-@@ -358,7 +358,7 @@ init_module(void)
- /*
- *----------------------------------------------------------------------
- *
-- * cleanup_module --
-+ * vmnet_cleanup_module --
- *
- * Called by /sbin/rmmod. Unregisters this driver for a
- * vnet major #, and deinitializes the modules. The 64-bit
-@@ -375,7 +375,7 @@ init_module(void)
- */
-
- void
--cleanup_module(void)
-+vmnet_cleanup_module(void)
- {
- unregister_chrdev(VNET_MAJOR_NUMBER, "vmnet");
- VNetProtoUnregister();
-@@ -1705,3 +1705,5 @@ MODULE_LICENSE("GPL v2");
- * by default (i.e., neither mkinitrd nor modprobe will accept it).
- */
- MODULE_INFO(supported, "external");
-+module_init(vmnet_init_module);
-+module_exit(vmnet_cleanup_module);
-Patch inspired from https://github.com/mkubecek/vmware-host-modules/commit/b75cd616cca0a4c9ff22124c4c91d218e64e6205.patch
---- a/vmnet/bridge.c
-+++ b/vmnet/bridge.c
-@@ -43,6 +43,9 @@
- #include <linux/tcp.h>
- #include <net/tcp.h>
- #include <net/ipv6.h>
-+#if !defined(SKB_GSO_CB)
-+#include <net/gso.h>
-+#endif
-
- #ifdef CONFIG_NET_RADIO
- # include <linux/wireless.h>