summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornezumisama2015-06-14 18:11:16 +0200
committernezumisama2015-06-14 18:11:16 +0200
commitc800dba419a85c7420c292975447fa813a40ab23 (patch)
tree10293beb4e320458a38fe74215f7ed1ddea6cfa6
downloadaur-c800dba419a85c7420c292975447fa813a40ab23.tar.gz
Initial commit.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD41
-rw-r--r--sip415_fix.patch30
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6292bad2c2d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pyqt3
+ pkgdesc = A set of Python bindings for the Qt3 toolkit
+ pkgver = 3.18.1
+ pkgrel = 14
+ url = http://www.riverbankcomputing.com/software/pyqt/intro
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2-sip
+ depends = qscintilla-qt3
+ source = http://downloads.sourceforge.net/project/pyqt/PyQt3/PyQt-x11-gpl-3.18.1.tar.gz
+ source = sip415_fix.patch
+ md5sums = f1d120495d1aaf393819e988c0a7bb7e
+ md5sums = d695dc23d2211a97d3631ec82d8afd67
+
+pkgname = pyqt3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e7b77e18733
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id: PKGBUILD 89515 2013-04-29 16:41:19Z spupykin $
+# Maintainer: AppleBloom <rat.o.drat@gmail.com>
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+# Contributor: riai <riai@bigfoot.com> Ben <ben@benmazer.net>
+
+pkgname=pyqt3
+pkgver=3.18.1
+pkgrel=14
+pkgdesc="A set of Python bindings for the Qt3 toolkit"
+arch=('i686' 'x86_64')
+url="http://www.riverbankcomputing.com/software/pyqt/intro"
+depends=('python2-sip' 'qscintilla-qt3')
+license=('GPL')
+source=("http://downloads.sourceforge.net/project/pyqt/PyQt3/PyQt-x11-gpl-${pkgver}.tar.gz"
+ "sip415_fix.patch")
+md5sums=('f1d120495d1aaf393819e988c0a7bb7e'
+ 'd695dc23d2211a97d3631ec82d8afd67')
+
+_dir="PyQt-x11-gpl-${pkgver}"
+
+prepare() {
+ cd "$_dir"
+ patch -p0 -i "../sip415_fix.patch"
+}
+
+build() {
+ cd "$_dir"
+ export QTDIR=/usr
+ export QMAKESPEC=/usr/share/qt3/mkspecs/linux-g++
+ echo yes | python2 configure.py -b /usr/bin \
+ -d /usr/lib/python2.7/site-packages \
+ -v /usr/share/sip \
+ INCDIR_QT=/usr/include/qt3
+ make CXX="g++ -DANY=void"
+}
+
+package() {
+ cd "$_dir"
+ make DESTDIR=${pkgdir} install
+}
diff --git a/sip415_fix.patch b/sip415_fix.patch
new file mode 100644
index 000000000000..205500a0163b
--- /dev/null
+++ b/sip415_fix.patch
@@ -0,0 +1,30 @@
+From: hpj@urpla.net
+
+This patch allows PyQt 3.18.1 to build with sip 4.15+.
+
+--- sip/qt/qlayout.sip~ 2009-06-16 10:47:31.000000000 +0200
++++ sip/qt/qlayout.sip 2013-11-19 23:34:01.451326665 +0100
+@@ -328,8 +328,8 @@ public:
+ QSizePolicy::ExpandData expanding() const;
+ QSize minimumSize() const;
+ QSize maximumSize() const;
+- void setGeometry(const QRect &) = 0;
+- QLayoutIterator iterator() = 0;
++ virtual void setGeometry(const QRect &) = 0;
++ virtual QLayoutIterator iterator() = 0;
+ bool isEmpty() const;
+
+ int totalHeightForWidth(int) const;
+
+--- sip/qtnetwork/qftp.sip~ 2009-06-16 10:47:31.000000000 +0200
++++ sip/qtnetwork/qftp.sip 2013-11-20 11:22:25.710338805 +0100
+@@ -177,6 +177,9 @@ protected:
+ virtual void operationRename(QNetworkOperation *);
+ virtual void operationGet(QNetworkOperation *);
+ virtual void operationPut(QNetworkOperation *);
++
++private:
++ virtual bool checkConnection(QNetworkOperation *);
+ };
+
+ %End