summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-07-11 05:33:47 -0400
committerChris Severance2015-07-11 05:33:47 -0400
commitc8556c27396d8d758b436ace153b17a1e8cce1d4 (patch)
treeb9040d092d9956ab1fb19819371fed3fd4e07703
downloadaur-c8556c27396d8d758b436ace153b17a1e8cce1d4.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD50
-rw-r--r--ghost.desktop14
-rw-r--r--ghost.polkit20
4 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7376ea3c219
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = symantec-ghost
+ pkgdesc = Symantec Ghost for Linux
+ pkgver = 11.5
+ pkgrel = 2
+ url = http://www.symantec.com/ghost-solution-suite
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = glibc
+ depends = lib32-gcc-libs
+ depends = lib32-libx11
+ optdepends = polkit: to run ghost directly from menu
+ options = !strip
+ source = ghost.desktop
+ source = http://upload.wikimedia.org/wikipedia/en/5/58/Norton_Ghost_icon.png
+ source = ghost.polkit
+ source = ftp://ftp.norton.com/public/english_us_canada/products/symantec_ghost_solution_suite/2.5/manuals/readme.txt
+ sha256sums = 7d0b4a0f3c15927d8b9c788f61ea05d6dd591fea0db99e8cb5cacaba5dab218c
+ sha256sums = 849459ed3ff52e76547eb1f90d2963226a4bd9d9875473785cbf3922ab3ca0ac
+ sha256sums = 852c2208a95080923e7534146e86d0b50ff790a254161fad900029c7e44181e3
+ sha256sums = 39b5bca2401df511364904039fb8f692be3095f57df434245cfc36893416b176
+
+pkgname = symantec-ghost
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29524c9c3aab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: N. Izumi izmntuk google email
+
+pkgname='symantec-ghost'
+pkgver='11.5'
+pkgrel='2'
+pkgdesc='Symantec Ghost for Linux'
+arch=('i686' 'x86_64')
+url='http://www.symantec.com/ghost-solution-suite'
+license=('custom')
+options=('!strip')
+depends=('lib32-gcc-libs' 'lib32-libx11')
+[[ "${CARCH}" == i686 ]] && depends=("${depends[@]/lib32-/}")
+optdepends=('polkit: to run ghost directly from menu')
+makedepends=('glibc')
+source=('ghost.desktop'
+ 'http://upload.wikimedia.org/wikipedia/en/5/58/Norton_Ghost_icon.png'
+ 'ghost.polkit'
+ 'ftp://ftp.norton.com/public/english_us_canada/products/symantec_ghost_solution_suite/2.5/manuals/readme.txt'
+ 'ghost'
+)
+
+sha256sums=('7d0b4a0f3c15927d8b9c788f61ea05d6dd591fea0db99e8cb5cacaba5dab218c'
+ '849459ed3ff52e76547eb1f90d2963226a4bd9d9875473785cbf3922ab3ca0ac'
+ '852c2208a95080923e7534146e86d0b50ff790a254161fad900029c7e44181e3'
+ '39b5bca2401df511364904039fb8f692be3095f57df434245cfc36893416b176'
+ '511cbfd3b362b02c5b5f2f0bdde1108bc44001bfa60ee6c5c3f48f80f4256d51')
+
+if ! :; then
+ ## fetch&extract the binary('ghost') from this file if you have a license of GSS2.5:
+ source[4]='ftp://ftp.norton.com/public/english_us_canada/products/symantec_ghost_solution_suite/2.5/updates/GSSB2174.zip'
+ sha256sums[4]='a477be351ba22d7f11bbeebfa2a40cad81d394e6c0c95657e3e4d2705876b228'
+else
+ sha256sums[4]='511cbfd3b362b02c5b5f2f0bdde1108bc44001bfa60ee6c5c3f48f80f4256d51'
+fi
+
+prepare() {
+ iconv -f cp1251 -t utf8 'readme.txt' -o 'README.txt'
+ cp --attributes-only --preserve=timestamps 'readme.txt' 'README.txt'
+}
+
+package() {
+ install -pDm744 'ghost' "${pkgdir}/usr/bin/ghost"
+ install -pDm644 'Norton_Ghost_icon.png' "${pkgdir}/usr/share/icons/ghost.png"
+ install -pDm644 'ghost.desktop' "${pkgdir}/usr/share/applications/ghost.desktop"
+ install -pDm644 'ghost.polkit' "${pkgdir}/usr/share/polkit-1/actions/org.archlinux.pkexec.ghost.policy"
+ install -pDm644 'README.txt' "${pkgdir}/usr/share/doc/${pkgname}/README"
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -rs "${pkgdir}/usr/share/doc/${pkgname}/README" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}
diff --git a/ghost.desktop b/ghost.desktop
new file mode 100644
index 000000000000..8476805d7c81
--- /dev/null
+++ b/ghost.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Name=Symantec Ghost
+Name[zh_CN]=赛门铁克Ghost克隆与备份实用工具
+Name[zh_HK]=賽門鐵克Ghost克隆與備份實用程式
+Name[zh_TW]=賽門鐵克魅影系统
+Comment=Backup or Restore your partition
+Comment[zh_CN]=備份或还原磁盘分区
+Comment[zh_HK]=備份還原磁盤分區
+Comment[zh_TW]=克隆或還原磁碟分割
+Exec=bash -c 'if [[ $(which pkexec) ]];then pkexec --disable-internal-agent "/usr/bin/ghost";else coproc /usr/bin/ghost;fi'
+Icon=ghost
+Type=Application
+Categories=System;Filesystem;
+StartupNotify=true
diff --git a/ghost.polkit b/ghost.polkit
new file mode 100644
index 000000000000..d12d586ded76
--- /dev/null
+++ b/ghost.polkit
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE policyconfig PUBLIC
+ "-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN"
+ "http://www.freedesktop.org/standards/PolicyKit/1/policyconfig.dtd">
+<policyconfig>
+
+ <action id="org.archlinux.pkexec.ghost">
+ <message>Authentication is required to run the Symantec Ghost</message>
+ <icon_name>ghost</icon_name>
+ <defaults>
+ <allow_any>auth_admin</allow_any>
+ <allow_inactive>auth_admin</allow_inactive>
+ <allow_active>auth_admin</allow_active>
+ </defaults>
+ <annotate key="org.freedesktop.policykit.exec.path">/usr/bin/ghost</annotate>
+ <annotate key="org.freedesktop.policykit.exec.allow_gui">true</annotate>
+ </action>
+
+</policyconfig>
+