summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-02-09 14:09:53 +0000
committerGrey Christoforo2019-02-09 14:09:53 +0000
commitc869f33ac982b9ecc9d37cfe21fbaeb32db1fcae (patch)
treefe29cb83327fc381cc912391a75cd76a215fd7bb
parent5a3690fcdc403be65cca5ff3bb861cafd3d22019 (diff)
downloadaur-c869f33ac982b9ecc9d37cfe21fbaeb32db1fcae.tar.gz
bump version
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 19 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9570a5a3eb55..23e6623b8968 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,12 +2,11 @@ pkgbase = r-bitops
pkgdesc = Bitwise Operations
pkgver = 1.0.6
pkgrel = 1
- url = https://cran.r-project.org/package=bitops
+ url = http://cran.r-project.org/web/packages/bitops/index.html
arch = x86_64
- license = GPL
+ license = GPL3
depends = r
- replaces = r-cran-bitops
- source = https://cran.r-project.org/src/contrib/bitops_1.0-6.tar.gz
+ source = http://cran.r-project.org/src/contrib/bitops_1.0-6.tar.gz
md5sums = fba16485a51b1ccd354abde5816b6bdd
pkgname = r-bitops
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6ae0b18a1f6c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index e2071868cdea..6f5473ee5e83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,20 @@
-# Maintainer: Alex Branham <branham@utexas.edu>
-_cranname=bitops
-_cranver=1.0-6
-_pkgtar=${_cranname}_${_cranver}.tar.gz
+# Contributor: Grey Christoforo <first name at last name dot net>
pkgname=r-bitops
-pkgver=${_cranver//[:-]/.}
+_cran_name=bitops
+_pkgver=1.0-6
+pkgver=${_pkgver//-/.}
pkgrel=1
pkgdesc="Bitwise Operations"
arch=('x86_64')
-url="https://cran.r-project.org/package=${_cranname}"
-license=('GPL')
-depends=('r' )
-
-
-
-source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+url="http://cran.r-project.org/web/packages/${_cran_name}/index.html"
+license=('GPL3')
+depends=('r')
+source=("http://cran.r-project.org/src/contrib/${_cran_name}_${_pkgver}.tar.gz")
md5sums=('fba16485a51b1ccd354abde5816b6bdd')
-replaces=('r-cran-bitops')
-build(){
- R CMD INSTALL ${_pkgtar} -l $srcdir
-}
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
-}
+ mkdir -p $pkgdir/usr/lib/R/library
+ cd $srcdir
+ R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_cran_name}
+}