summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaleb Klein2020-07-06 11:26:24 -0400
committerKaleb Klein2020-07-06 11:26:24 -0400
commitc86ec9cf22b30c3c87b214d47172da002cf8e1aa (patch)
treea63688b0773b3133e32c8530fc8b9460a4ff5a4b
parentd258812390853119175895aa47818d32c3ffc025 (diff)
downloadaur-c86ec9cf22b30c3c87b214d47172da002cf8e1aa.tar.gz
Update to use launchpad source code
Source code for Launchpad is obtained from Swgemu servers to get latest launchpad version. App is now built from source.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD49
-rw-r--r--launchpad.install4
-rw-r--r--removeicon.patch10
4 files changed, 56 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 976167106081..0c9894464fac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = swgemu
pkgdesc = Launcher for Star Wars Galaxies Emulator
- pkgver = 0.18
- pkgrel = 5
+ pkgver = 0.23
+ pkgrel = 6
url = http://www.swgemu.com
install = launchpad.install
arch = any
@@ -12,13 +12,17 @@ pkgbase = swgemu
source = launchpad.desktop
source = launchpad.install
source = icon.png
+ source = removeicon.patch
source = http://launchpad2.net/SWGEmuLaunchpad_ubuntu_x86_64.tar.gz
+ source = Launchpad::git+https://review.swgemu.com/p/Launchpad.git
validpgpkeys = 120206848BD3375043BF1B253209FA22E33FF70C
- md5sums = b7041ff9bef465687f6df5a6fb9053db
- md5sums = 3d5fff82e58d1a1ff548f72a0cb466ea
- md5sums = 4a855d869afa0fe7eb21bb1beb015b0a
- md5sums = 4df75531fbf01652c5ac53d4d7978187
- md5sums = c1fbbcef48ba61ea3c17692a19084c62
+ sha256sums = b25d19e4b20d41e640f4adef0d8cb54e7fdd713bb36b9c7adc0a9d8b03bd8bd9
+ sha256sums = 1f46fe25911879b3ead1349f0f66b85adaa4974542db6a1e268d4343278f2ce4
+ sha256sums = af45f7c63e2eb89c42355731db15ae92dbfbeb274283d4d57cd29e9a46a132aa
+ sha256sums = 1b7e5ef6fcd387f7b10ce88abb78dc89e6368b53aaf8a23acfef05652ea20e97
+ sha256sums = 0376bb4d77b13719177f166537ad105fcd01f0947ff96d1f9bde53d09ebd760c
+ sha256sums = ec30edbee4b3563f7d7a75c1e35e8b68792eb80c9b313d9982cedcf0e83d5455
+ sha256sums = SKIP
pkgname = swgemu
diff --git a/PKGBUILD b/PKGBUILD
index 258c17b42870..42a9c444dc98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,48 @@
# Maintainer: Kaleb Klein <klein.jae@gmail.com>
pkgname=swgemu
-pkgver=0.18
-pkgrel=5
+pkgver=0.23
+pkgrel=6
pkgdesc="Launcher for Star Wars Galaxies Emulator"
arch=(any)
license=('GPL')
url="http://www.swgemu.com"
+_srcurl=https://review.swgemu.com/p/Launchpad.git
_dlurl=http://launchpad2.net/SWGEmuLaunchpad_ubuntu_x86_64.tar.gz
depends=('qt5-base'
- 'qt5-webkit')
-source=(launchpad launchpad.desktop launchpad.install icon.png ${_dlurl})
+ 'qt5-webkit')
+source=(launchpad launchpad.desktop launchpad.install
+ icon.png removeicon.patch ${_dlurl} Launchpad::git+${_srcurl})
validpgpkeys=(120206848BD3375043BF1B253209FA22E33FF70C)
-md5sums=('b7041ff9bef465687f6df5a6fb9053db'
- '3d5fff82e58d1a1ff548f72a0cb466ea'
- '4a855d869afa0fe7eb21bb1beb015b0a'
- '4df75531fbf01652c5ac53d4d7978187'
- 'c1fbbcef48ba61ea3c17692a19084c62')
+sha256sums=('b25d19e4b20d41e640f4adef0d8cb54e7fdd713bb36b9c7adc0a9d8b03bd8bd9'
+ '1f46fe25911879b3ead1349f0f66b85adaa4974542db6a1e268d4343278f2ce4'
+ 'af45f7c63e2eb89c42355731db15ae92dbfbeb274283d4d57cd29e9a46a132aa'
+ '1b7e5ef6fcd387f7b10ce88abb78dc89e6368b53aaf8a23acfef05652ea20e97'
+ '0376bb4d77b13719177f166537ad105fcd01f0947ff96d1f9bde53d09ebd760c'
+ 'ec30edbee4b3563f7d7a75c1e35e8b68792eb80c9b313d9982cedcf0e83d5455'
+ 'SKIP')
install='launchpad.install'
+prepare() {
+ cd "$srcdir/Launchpad"
+ patch -Np1 -i ../removeicon.patch
+}
+
+build() {
+ cd "$srcdir/Launchpad"
+ qmake-qt5 SWGEmuLaunchpad.pro
+ make
+}
+
package() {
- cd "$srcdir"
+ echo "package"
- install -D -m755 "${srcdir}/launchpad" "${pkgdir}/usr/bin/swgemu"
- install -D -m644 "${srcdir}/ubuntu64/KSWGProfCalc.dat" "${pkgdir}/opt/SWGEMU/Launchpad/KSWGProfCalc.dat"
- install -D -m644 "${srcdir}/ubuntu64/KSWGProfCalcEditor.exe" "${pkgdir}/opt/SWGEMU/Launchpad/KSWGProfCalcEditor.exe"
- install -D -m644 "${srcdir}/ubuntu64/SWGEmuLaunchpad" "${pkgdir}/opt/SWGEMU/Launchpad/SWGEmuLaunchpad"
- chmod +x "${pkgdir}/opt/SWGEMU/Launchpad/SWGEmuLaunchpad"
+ install -D -m755 "${srcdir}/launchpad" "${pkgdir}/usr/bin/swgemu"
+ install -D -m644 "${srcdir}/ubuntu64/KSWGProfCalc.dat" "${pkgdir}/opt/SWGEMU/Launchpad/KSWGProfCalc.dat"
+ install -D -m644 "${srcdir}/ubuntu64/KSWGProfCalcEditor.exe" "${pkgdir}/opt/SWGEMU/Launchpad/KSWGProfCalcEditor.exe"
+ install -D -m644 "${srcdir}/Launchpad/SWGEmuLaunchpad" "${pkgdir}/opt/SWGEMU/Launchpad/SWGEmuLaunchpad"
+ chmod +x "${pkgdir}/opt/SWGEMU/Launchpad/SWGEmuLaunchpad"
- install -D -m644 "${srcdir}/icon.png" "${pkgdir}/usr/share/pixmaps/SWGEMU/icon.png"
- install -D -m644 "${srcdir}/launchpad.desktop" "${pkgdir}/usr/share/applications/launchpad.desktop"
+ install -D -m644 "${srcdir}/icon.png" "${pkgdir}/usr/share/pixmaps/SWGEMU/icon.png"
+ install -D -m644 "${srcdir}/launchpad.desktop" "${pkgdir}/usr/share/applications/launchpad.desktop"
}
diff --git a/launchpad.install b/launchpad.install
index bbfd611d3032..6115de795732 100644
--- a/launchpad.install
+++ b/launchpad.install
@@ -8,7 +8,9 @@ post_install() {
# Inform the user that their files still remain, and to
# remove them if they wish
post_remove() {
- echo ">>> Please note, that removing swgemu-launchpad"
+ rm -rf /usr/share/pixmaps/SWGEMU
+ rm -rf /usr/share/applications/launchpad.desktop
+ echo ">>> Please note, that removing swgemu"
echo ">>> Does not remove any files you've installed"
echo ">>> During the SWG install process or any files"
echo ">>> SWGEmuLaunchpad may have installed. Please"
diff --git a/removeicon.patch b/removeicon.patch
new file mode 100644
index 000000000000..dec06b10ae21
--- /dev/null
+++ b/removeicon.patch
@@ -0,0 +1,10 @@
+--- lp/rsources.qrc 2020-07-06 10:22:04.992477000 -0400
++++ lp2/rsources.qrc 2020-07-06 10:35:36.571786175 -0400
+@@ -6,7 +6,6 @@
+ <file>play.svg</file>
+ <file>logo-emu.svg</file>
+ <file>swgemu.svg</file>
+- <file>emu.ico</file>
+ <file>info.svg</file>
+ <file>cloud.svg</file>
+ <file>installfromswg.svg</file>