summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Sexton2019-11-01 10:15:08 -0400
committerMatthew Sexton2019-11-01 10:15:08 -0400
commitc87e24fbd0d9d9fd5103edbdb00566145fc2a656 (patch)
treeeb80954522276680b82fb2015eeb5b3e32ac5f01
downloadaur-c87e24fbd0d9d9fd5103edbdb00566145fc2a656.tar.gz
Initial Commit of Package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16aaf60ce32a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = spotify-tray-git
+ pkgdesc = Tray icon for the Spotify Linux client application
+ pkgver = r13.2793099
+ pkgrel = 1
+ url = https://github.com/tsmetana/spotify-tray
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = spotify
+ provides = spotify-tray
+ conflicts = spotify-tray
+ source = spotify-tray::git+https://github.com/tsmetana/spotify-tray.git
+ md5sums = SKIP
+
+pkgname = spotify-tray-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df7a8be870fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Matthew Sexton <wsdmatty@gmail.com>
+pkgname=spotify-tray-git
+pkgver=r13.2793099
+pkgrel=1
+pkgdesc="Tray icon for the Spotify Linux client application"
+arch=('x86_64')
+url="https://github.com/tsmetana/spotify-tray"
+license=('GPL3')
+depends=('spotify')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('spotify-tray::git+https://github.com/tsmetana/spotify-tray.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+}