summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKarol Babioch2019-05-30 14:36:27 +0200
committerKarol Babioch2019-05-30 16:10:04 +0200
commitc89f96c0989c5cabdeb5495e7e0ef0d00eebc345 (patch)
treec4e19c8b06ad7d0aafe3fe84db2b3562ce938929
parent7f290d93dcdce6bf895dbf71ac434eda64fbd100 (diff)
downloadaur-c89f96c0989c5cabdeb5495e7e0ef0d00eebc345.tar.gz
Bump version to 3.1.5-0
Upstream is packaging this differently now, so a massive rewrite of the PKGBUILD is required.
-rw-r--r--.SRCINFO13
-rw-r--r--LICENSE7
-rw-r--r--PKGBUILD99
-rw-r--r--brother-ql710w.install1
4 files changed, 52 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f90d9009446..ff8e12e4a0f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,15 @@
pkgbase = brother-ql710w
pkgdesc = LPR and CUPS driver for Brother QL-710W label printer
- pkgver = 1.1.4r0
+ pkgver = 3.1.5r0
pkgrel = 1
- url = http://solutions.brother.com/linux/en_us/
+ url = https://support.brother.com
install = brother-ql710w.install
arch = i686
arch = x86_64
license = custom
depends = cups
- depends = lib32-glibc
- source = http://download.brother.com/welcome/dlfp002197/ql710wlpr-1.1.4-0.i386.rpm
- source = http://download.brother.com/welcome/dlfp002199/ql710wcupswrapper-1.1.4-0.i386.rpm
- source = LICENSE
- sha256sums = 0aa58fcc86464977d5133fdb19af484dbf1beb2e12a6d5e22d98dc8da2bfede7
- sha256sums = 0adf16a61ec94c62a001469ec70e23616ec49878ee0091b064a62022438ed30d
- sha256sums = cdd1955a9996bc246ba54e84f0a5ccbfdf6623962b668188762389aa79ef9811
+ source = https://download.brother.com/welcome/dlfp002197/ql710wpdrv-3.1.5-0.i386.rpm
+ sha256sums = 00b881cea1668553fe40887375d72188f42e03893b73619e231893564b609721
pkgname = brother-ql710w
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 8c61cbac9784..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,7 +0,0 @@
-This Agreement provides terms and conditions for license grant from Brother Industries, Ltd ("Broher"). Brother, who owns all copyrights to the software that is distributed with this Agreement ("Software") to recipients thereof ("User"), for use of the Software. User shall have the right to use the Software only in accordance with the terms and conditions of this Agreement. Any use by User of the Software shall be deemed as its agreement hereto.
-
-Brother retains any and all copyrights to the Software. In no case this Agreement shall be construed to assign or otherwise transfer from Brother to User any copyrights or other intellectual property rights to whole or any part of the Software.
-
-Brother grants User a non-exclusive license: to reproduce and/or distribute (via Internet or in any other manner) the Software. Further, Brother grants User a non-exclusive license to modify, alter, translate or otherwise prepare derivative works of the Software and to reproduce and distribute (via Internet or in any other manner) such modification, alteration, translation or other derivative works for any purpose.
-
-The license of the Software from Brother hereunder is granted "AS IS." BROTHER HEREBY DISCLAIMS ANY WARRANTIES WITH RESPECT TO THE SOFTWARE, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO WARRANTY FOR THE QUALITY, MERCHANTABILITY, FITNESS FOR PARTICULAR PURPOSE OR NON-INFRINGEMENT. Brother shall have no liability in contract, tort (including negligence or breach of statutory duty) or otherwise for any interruption of use, loss of data, or for any indirect, incidental, punitive or consequential loss or damage, or for any loss of profit, revenue, data, goodwill or anticipated savings that arises under, out of, or in contemplation of this Agreement or otherwise arises due to any error, inaccuracy or defect in the Software even if Brother has been advised of the possibility of such loss or damage. Further, Brother shall have no liability to disclose and/or distribute the source cord of the Software to User under any circumstances. In no case shall the above license by Brother to modify, alter, translate or otherwise prepare derivative works of the Software be construed as Brother's implied agreement or undertakings to disclose and/or distribute the source cord of the Software.
diff --git a/PKGBUILD b/PKGBUILD
index abb3e818813e..bbbfac1bd9f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,68 +1,65 @@
# Maintainer: Karol Babioch <karol@babioch.de>
-# Inspired by package brother-dcp130c
-pkgname='brother-ql710w'
-pkgver=1.1.4r0
+pkgname=brother-ql710w
+pkgver=3.1.5r0
pkgrel=1
pkgdesc='LPR and CUPS driver for Brother QL-710W label printer'
-url='http://solutions.brother.com/linux/en_us/'
+url='https://support.brother.com'
arch=('i686' 'x86_64')
license=('custom')
-depends='cups'
-if [ "$CARCH" = 'x86_64' ]; then
- depends+=('lib32-glibc')
-fi
-install="$pkgname.install"
-source=("http://download.brother.com/welcome/dlfp002197/ql710wlpr-${pkgver/r/-}.i386.rpm"
- "http://download.brother.com/welcome/dlfp002199/ql710wcupswrapper-${pkgver/r/-}.i386.rpm"
- 'LICENSE')
-sha256sums=('0aa58fcc86464977d5133fdb19af484dbf1beb2e12a6d5e22d98dc8da2bfede7'
- '0adf16a61ec94c62a001469ec70e23616ec49878ee0091b064a62022438ed30d'
- 'cdd1955a9996bc246ba54e84f0a5ccbfdf6623962b668188762389aa79ef9811')
+depends=('cups')
+install="${pkgname}.install"
+source=("https://download.brother.com/welcome/dlfp002197/ql710wpdrv-${pkgver/r/-}.i386.rpm")
+sha256sums=('00b881cea1668553fe40887375d72188f42e03893b73619e231893564b609721')
prepare()
{
- # do not install in '/usr/local'
- if [ -d $srcdir/usr/local/Brother ]; then
- install -d $srcdir/usr/share
- mv $srcdir/usr/local/Brother/ $srcdir/usr/share/brother
- rm -rf $srcdir/usr/local
- sed -i 's|/usr/local/Brother|/usr/share/brother|g' `grep -lr '/usr/local/Brother' ./`
- fi
+ # Create CUPS directories
+ install -d "${srcdir}/usr/share/cups/model"
+ install -d "${srcdir}/usr/share/ppd"
+ install -d "${srcdir}/usr/lib/cups/filter"
- # setup cups directories
- install -d "$srcdir/usr/share/cups/model"
- install -d "$srcdir/usr/lib/cups/filter"
+ # Locate cupswrapper script
+ cd $(find -type d -name 'cupswrapper')
+ _cupswrapper=$(ls cupswrapper*)
- # go to the cupswrapper directory and find the source file from wich to generate a ppd- and wrapper-file
- cd `find . -type d -name 'cupswrapper'`
- if [ -f cupswrapper* ]; then
- _wrapper_source=`ls cupswrapper*`
- sed -i '/^\/etc\/init.d\/cups/d' $_wrapper_source
- sed -i '/^sleep/d' $_wrapper_source
- sed -i '/^echo lpadmin/d' $_wrapper_source
- sed -i '/^lpadmin/d' $_wrapper_source
- sed -i 's|/usr|$srcdir/usr|g' $_wrapper_source
- sed -i 's|/opt|$srcdir/opt|g' $_wrapper_source
- sed -i 's|/model/Brother|/model|g' $_wrapper_source
- sed -i 's|lpinfo|echo|g' $_wrapper_source
- export srcdir=$srcdir
- ./$_wrapper_source
- sed -i 's|$srcdir||' $srcdir/usr/lib/cups/filter/*lpdwrapper*
- sed -i "s|$srcdir||" $srcdir/usr/lib/cups/filter/*lpdwrapper*
- rm $_wrapper_source
- fi
+ # Patch cupswrapper script
+ sed -i '/^sleep/d' ${_cupswrapper}
+ sed -i '/^echo lpadmin/d' ${_cupswrapper}
+ sed -i '/^lpadmin/d' ${_cupswrapper}
+ sed -i "s|/usr|${srcdir}/usr|g" ${_cupswrapper}
+ sed -i "s|/opt|${srcdir}/opt|g" ${_cupswrapper}
+ sed -i "s|/model/Brother|/model|g" ${_cupswrapper}
+ sed -i 's|lpinfo|echo|g' ${_cupswrapper}
- # /etc/printcap is managed by cups
- rm `find $srcdir -type f -name 'setupPrintcap*'`
-}
+ # Invoke cupswrapper script
+ export srcdir=${srcdir}
+ ./${_cupswrapper}
+
+ # Patch resulting filter
+ sed -i "s|${srcdir}||" ${srcdir}/usr/lib/cups/filter/*lpdwrapper*
-package() {
- cd "$srcdir"
+ # Remove cupswrapper script and templates
+ find "${srcdir}" -type d -name 'cupswrapper' -exec rm -rf {} +
- cp -R usr $pkgdir
- if [ -d opt ]; then cp -R opt $pkgdir; fi
+ # Remove unneeded script (i.e. /etc/printcap is managed by CUPS)
+ rm $(find "${srcdir}" -type f -name 'setupPrintcap*')
- install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ # Remove binaries for different architectures
+ if [ "${CARCH}" = 'x86_64' ]; then
+ find "${srcdir}" -type d -name 'i686' -exec rm -rf {} +
+ elif [ "${CARCH}" = 'i686' ]; then
+ find "${srcdir}" -type d -name 'x86_64' -exec rm -rf {} +
+ fi
}
+package()
+{
+ # Install actual content
+ cp -R "${srcdir}/usr" "${pkgdir}"
+ cp -R "${srcdir}/opt" "${pkgdir}"
+
+ # Handle license
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ find "${pkgdir}" -type f -name 'LICENSE*.txt' -exec mv -t "${pkgdir}/usr/share/licenses/${pkgname}" {} +
+}
diff --git a/brother-ql710w.install b/brother-ql710w.install
index b9b2a86e2eb0..af2d36467e8b 100644
--- a/brother-ql710w.install
+++ b/brother-ql710w.install
@@ -6,4 +6,3 @@ post_upgrade() {
echo "Restart CUPS to load the new files"
echo "You can then register your printer, e.g. using the web interface at"
}
-