summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2020-03-19 14:45:45 +0200
committerStelios Tsampas2020-03-19 14:45:45 +0200
commitc8a4a24e45451a41574316bb98f6a02097adac8d (patch)
tree484ee4f685da9bc35b69e03fe2957ffdd6ffcbf8
parent6f961ed234251749d60002f6b48fc37d5036e8bf (diff)
downloadaur-c8a4a24e45451a41574316bb98f6a02097adac8d.tar.gz
Version 3.0.2
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD41
-rw-r--r--vitables.desktop15
-rw-r--r--vitables.svg160
4 files changed, 217 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9213d3e90b0d..0a6a60f8da5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,20 @@
pkgbase = vitables
pkgdesc = A GUI browser and editor for PyTables/HDF5 files
- pkgver = 2.1
+ pkgver = 3.0.2
pkgrel = 1
url = http://vitables.org
arch = any
license = GPL3
- makedepends = python2-sphinx
- depends = python2-pyqt4
- depends = python2-pytables
- source = https://downloads.sourceforge.net/vitables/ViTables-2.1.tar.gz
- sha256sums = f0413fa725617fbb3f0be03cb1f41b5b841c6946098a629f3fcb8a99fb9be14a
+ makedepends = python-sphinx
+ depends = python-pyqt5
+ depends = python-qtpy
+ depends = python-pytables
+ source = vitables-3.0.2.tar.gz::https://github.com/uvemas/ViTables/archive/v3.0.2.tar.gz
+ source = vitables.desktop
+ source = vitables.svg
+ sha256sums = 43a965a08124fe0e1974aed27a7149cdeaf75e8ae833e95a18a94d7d5bd506c8
+ sha256sums = dd793f85d81591edd837a5fb94642dbf3ba488c69c605cbc2c87f74baea8676c
+ sha256sums = 0be6fdeb2c1f40fe2c478b0a6b9f99bad170d69f1210300d736bb98a5b9edcd8
pkgname = vitables
diff --git a/PKGBUILD b/PKGBUILD
index 21aa040f80b2..078dcd087d3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,44 @@
-# Maintainer: archlinux.info:tdy
+# Maintainer: loathingkernel <username ta gmail tod com>
+# Contributor: MikoĊ‚aj Chwalisz <m.chwalisz@gmail.com>
+# Contributor: archlinux.info:tdy
pkgname=vitables
-pkgver=2.1
+pkgver=3.0.2
pkgrel=1
pkgdesc="A GUI browser and editor for PyTables/HDF5 files"
arch=(any)
url=http://vitables.org
license=(GPL3)
-depends=(python2-pyqt4 python2-pytables)
-makedepends=(python2-sphinx)
-source=(https://downloads.sourceforge.net/$pkgname/ViTables-$pkgver.tar.gz)
-sha256sums=(f0413fa725617fbb3f0be03cb1f41b5b841c6946098a629f3fcb8a99fb9be14a)
+depends=(
+ 'python-pyqt5'
+ 'python-qtpy'
+ 'python-pytables'
+)
+makedepends=(
+ 'python-sphinx'
+)
+source=(
+ "$pkgname-$pkgver.tar.gz::https://github.com/uvemas/ViTables/archive/v$pkgver.tar.gz"
+ "vitables.desktop"
+ "vitables.svg"
+)
+sha256sums=(
+ '43a965a08124fe0e1974aed27a7149cdeaf75e8ae833e95a18a94d7d5bd506c8'
+ 'dd793f85d81591edd837a5fb94642dbf3ba488c69c605cbc2c87f74baea8676c'
+ '0be6fdeb2c1f40fe2c478b0a6b9f99bad170d69f1210300d736bb98a5b9edcd8'
+)
build() {
- cd ViTables-$pkgver
- python2 setup.py build
+ cd ViTables-"$pkgver"
+ sed -e "s/'PyQt5 (>=5.5.1)'//g" -i setup.py
+ sed '/PyQt5/d' requirements.txt
+ python setup.py build
}
package() {
- cd ViTables-$pkgver
- python2 setup.py install --root="$pkgdir" --optimize=1
+ cd ViTables-"$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -d "$pkgdir"/usr/share/{applications,pixmaps}
+ install -m644 "$srcdir"/vitables.desktop "$pkgdir"/usr/share/applications/
+ install -m644 "$srcdir"/vitables.svg "$pkgdir"/usr/share/pixmaps/
}
diff --git a/vitables.desktop b/vitables.desktop
new file mode 100644
index 000000000000..bc6ee43462f7
--- /dev/null
+++ b/vitables.desktop
@@ -0,0 +1,15 @@
+[Desktop Entry]
+Type=Application
+Version=3.0.0
+Name=ViTables
+GenericName=PyTables & HDF5 Files Visualizer
+GenericName[ca]=Visualitzador de fitxers PyTables i HDF5
+GenericName[es]=Visualizador de ficheros PyTables y HDF5
+Exec=vitables %U
+Icon=vitables
+#There is not mime-type yet for HDF5
+#MimeType=application/x-hdf5
+#Set this to the vitables documentation files
+#DocPath=vitables/index.html
+Terminal=false
+Categories=Qt;Database;DataVisualization;Science;Education
diff --git a/vitables.svg b/vitables.svg
new file mode 100644
index 000000000000..c2811180abe3
--- /dev/null
+++ b/vitables.svg
@@ -0,0 +1,160 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<!-- Created with Inkscape (http://www.inkscape.org/) -->
+<svg
+ xmlns:i="http://ns.adobe.com/AdobeIllustrator/10.0/"
+ xmlns:dc="http://purl.org/dc/elements/1.1/"
+ xmlns:cc="http://web.resource.org/cc/"
+ xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
+ xmlns:svg="http://www.w3.org/2000/svg"
+ xmlns="http://www.w3.org/2000/svg"
+ xmlns:xlink="http://www.w3.org/1999/xlink"
+ xmlns:sodipodi="http://inkscape.sourceforge.net/DTD/sodipodi-0.dtd"
+ xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
+ width="5.0000000cm"
+ height="5.0000000cm"
+ id="svg1504"
+ sodipodi:version="0.32"
+ inkscape:version="0.41"
+ sodipodi:docbase="/home/faltet/carabos/dissenys/trunk/vitables/icons"
+ sodipodi:docname="vitables1.svg">
+ <defs
+ id="defs3" />
+ <sodipodi:namedview
+ id="base"
+ pagecolor="#ffffff"
+ bordercolor="#666666"
+ borderopacity="1.0"
+ inkscape:pageopacity="0.0"
+ inkscape:pageshadow="2"
+ inkscape:zoom="0.35000000"
+ inkscape:cx="375.00000"
+ inkscape:cy="101.18513"
+ inkscape:document-units="px"
+ inkscape:current-layer="layer1"
+ inkscape:window-width="858"
+ inkscape:window-height="549"
+ inkscape:window-x="94"
+ inkscape:window-y="0" />
+ <metadata
+ id="metadata4">
+ <rdf:RDF
+ id="RDF5">
+ <cc:Work
+ rdf:about=""
+ id="Work6">
+ <dc:format
+ id="format7">image/svg+xml</dc:format>
+ <dc:type
+ id="type9"
+ rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
+ <dc:title
+ id="title1307">ViTables icon</dc:title>
+ <dc:date
+ id="date1309">2006-02-21</dc:date>
+ <dc:creator
+ id="creator1311">
+ <cc:Agent
+ id="Agent1313">
+ <dc:title
+ id="title1315">Domenec Morera</dc:title>
+ </cc:Agent>
+ </dc:creator>
+ <dc:rights
+ id="rights1317">
+ <cc:Agent
+ id="Agent1319">
+ <dc:title
+ id="title1321">Carabos Coop. V.</dc:title>
+ </cc:Agent>
+ </dc:rights>
+ <cc:license
+ rdf:resource="http://www.carabos.com"
+ id="license1323" />
+ </cc:Work>
+ </rdf:RDF>
+ </metadata>
+ <g
+ inkscape:label="Layer 1"
+ inkscape:groupmode="layer"
+ id="layer1">
+ <polygon
+ i:knockout="Off"
+ points="226.30300,206.63200 61.791000,231.02600 13.490000,35.459000 181.80700,0.0000000 226.30300,206.63200 "
+ id="polygon69"
+ style="fill:#acadd3"
+ transform="matrix(0.747925,0.000000,0.000000,0.766863,1.408708e-5,6.805907e-5)" />
+ <polygon
+ i:knockout="Off"
+ points="35.578000,36.387000 171.06100,18.874000 210.52100,190.49100 66.152000,218.43800 35.578000,36.387000 "
+ id="polygon71"
+ style="fill:#ffffff"
+ transform="matrix(0.747925,0.000000,0.000000,0.766863,1.408708e-5,6.805907e-5)" />
+ <g
+ id="g73"
+ transform="matrix(0.747925,0.000000,0.000000,0.766863,1.408708e-5,6.805907e-5)">
+ <defs
+ id="defs75">
+ <polygon
+ id="XMLID_1_"
+ points="35.578000,36.387000 171.06100,18.874000 210.52100,190.49100 66.152000,218.43800 35.578000,36.387000 " />
+ </defs>
+ <clipPath
+ id="XMLID_3_">
+ <use
+ xlink:href="#XMLID_1_"
+ id="use79"
+ x="0.0000000"
+ y="0.0000000"
+ width="744.09448"
+ height="1052.3622" />
+ </clipPath>
+ <path
+ i:knockout="Off"
+ clip-path="url(#XMLID_3_)"
+ d="M 126.80300,122.81000 L 157.35600,112.91900 L 148.46000,68.195000 L 112.20400,73.728000 L 126.80300,122.81000 L 126.80300,122.81000 z M 84.731000,136.42900 L 118.11200,125.62200 L 103.09000,75.118000 L 75.613000,79.311000 L 84.731000,136.42900 L 84.731000,136.42900 z M 188.29100,113.04600 L 167.89600,119.10400 L 181.82000,189.10400 L 172.86500,190.88500 L 159.15000,121.93600 L 129.40600,131.56300 L 141.87700,173.49100 L 133.12500,176.09500 L 120.71700,134.37600 L 86.188000,145.55400 L 92.910000,187.66500 L 150.47700,174.44600 L 152.52000,183.34400 L 94.353000,196.70100 L 96.632000,207.83400 L 87.615000,209.27200 L 85.433000,198.74900 L 70.884000,203.27000 L 68.841000,194.37000 L 83.991000,189.71200 L 77.396000,148.40100 L 70.328000,150.68800 L 67.516000,142.00000 L 75.939000,139.27300 L 66.588000,80.688000 L 46.492000,83.418000 L 45.115000,74.391000 L 65.149000,71.671000 L 61.904000,56.708000 L 70.921000,55.269000 L 74.176000,70.294000 L 100.46400,66.282000 L 92.220000,41.544000 L 100.97200,38.940000 L 109.57400,64.892000 L 146.67600,59.230000 L 142.52200,38.342000 L 151.47700,36.561000 L 155.71100,57.852000 L 166.74600,56.168000 L 168.12500,65.195000 L 157.49400,66.817000 L 166.10300,110.08900 L 185.48000,104.36000 L 188.29100,113.04600 L 188.29100,113.04600 z "
+ id="path81"
+ style="fill:#acadd3" />
+ </g>
+ <path
+ i:knockout="Off"
+ d="M 8.7081659e-08,97.473028 C -0.00074791292,90.825858 4.8173871,85.438638 10.764141,85.439408 C 16.710147,85.439408 21.531274,90.828918 21.532022,97.474558 C 21.533517,104.12173 16.714635,109.50895 10.767881,109.50895 C 4.8226231,109.50818 0.0014960871,104.12020 8.7081659e-08,97.473028 L 8.7081659e-08,97.473028 z "
+ id="path83" />
+ <path
+ i:knockout="Off"
+ d="M 9.0843011,89.169428 C 3.8667741,96.179328 4.5586051,105.04734 16.249425,108.21065 C 27.940245,111.37242 106.87179,131.98034 106.87179,131.98034 L 129.51000,76.733978 C 86.886484,79.602038 9.0843011,89.169428 9.0843011,89.169428 L 9.0843011,89.169428 z "
+ id="path85"
+ style="fill:#ff9600" />
+ <path
+ i:knockout="Off"
+ d="M 145.62330,79.175668 C 133.89732,96.663218 127.37392,110.64467 128.19888,127.75876 C 129.02384,144.87285 141.54935,145.00091 141.54935,145.00091 C 148.68231,142.84833 156.77112,136.97875 162.64458,125.72580 C 168.51804,114.47285 165.25035,96.228408 160.61995,89.217738 C 155.98805,82.205548 145.62330,79.175668 145.62330,79.175668 L 145.62330,79.175668 z "
+ id="path87"
+ style="fill:#ffdb00" />
+ <path
+ i:knockout="Off"
+ d="M 156.92669,65.213388 L 145.04141,80.653408 C 157.68434,87.816678 160.95651,101.84875 161.51447,109.60174 C 162.65655,125.47657 147.73619,141.79772 139.38037,143.38590 C 137.95332,146.57758 137.38640,147.79996 137.38640,147.79996 C 153.13247,145.06226 162.74705,136.63827 170.67356,123.34086 C 179.33753,108.80803 179.90894,88.017598 168.85012,74.654238 C 164.89135,69.868248 156.92669,65.213388 156.92669,65.213388 L 156.92669,65.213388 z "
+ id="path89"
+ style="fill:#0c479d" />
+ <path
+ i:knockout="Off"
+ d="M 118.61945,71.270838 C 108.90241,84.088198 103.86139,93.960788 101.66997,110.56645 C 100.28107,121.09165 101.56152,132.94045 102.80383,137.77399 C 114.15135,141.10678 134.36104,148.15349 137.87330,148.07987 C 140.04976,144.92576 140.40951,142.93498 140.40951,142.93498 C 134.99154,141.15586 132.65577,138.02552 130.44116,132.64061 C 128.22805,127.25723 129.59675,111.25816 136.66091,96.550488 C 143.72506,81.841288 157.15855,65.194218 157.15855,65.194218 L 118.61945,71.270838 L 118.61945,71.270838 z "
+ id="path91" />
+ <path
+ i:knockout="Off"
+ d="M 93.931944,77.115108 C 85.932134,92.695468 79.662274,121.68904 79.639834,127.25493 C 77.647364,126.94512 72.093264,125.18056 72.093264,125.18056 C 74.740174,106.31573 81.852944,89.337368 87.634414,78.760798 C 87.881974,78.795298 93.931944,77.115108 93.931944,77.115108 L 93.931944,77.115108 z "
+ id="path93" />
+ <path
+ i:knockout="Off"
+ d="M 53.355494,80.404948 C 47.221759,91.691638 44.005681,109.20987 43.173988,116.93985 C 41.653456,116.88004 37.223494,116.10244 37.223494,116.10244 C 38.930260,103.94075 43.247284,87.589688 46.279373,82.194808 C 47.823839,81.796808 53.355494,80.404948 53.355494,80.404948 L 53.355494,80.404948 z "
+ id="path95" />
+ <path
+ i:knockout="Off"
+ d="M 153.41070,101.91316 C 153.41070,101.91316 153.19006,115.20751 151.79069,117.89920 C 153.47352,119.23967 155.69561,119.85393 155.69561,119.85393 C 157.74343,114.43374 157.47043,105.63092 157.28944,104.36559 C 157.53924,104.37786 153.41070,101.91316 153.41070,101.91316 L 153.41070,101.91316 z "
+ id="path97"
+ style="fill:#ffffff" />
+ <path
+ i:knockout="Off"
+ d="M 149.26943,122.79332 C 147.35699,125.70970 146.53951,126.92441 145.77662,127.13683 C 146.93067,128.95200 149.62545,130.09232 149.62545,130.09232 L 153.45108,124.26033 L 149.26943,122.79332 L 149.26943,122.79332 z "
+ id="path99"
+ style="fill:#ffffff" />
+ </g>
+</svg>