summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBouke Sybren Haarsma2024-02-02 20:32:21 +0100
committerBouke Sybren Haarsma2024-02-02 20:32:21 +0100
commitc8a9c08151283f785179c51d855c126a4a2a6aec (patch)
treea5aa002d33b283979846401df2af07fcdac281b4
parent11aaf7b1198f7acf045d29864de992ca6d90b57a (diff)
downloadaur-c8a9c08151283f785179c51d855c126a4a2a6aec.tar.gz
use arch libdisplay-info, use stb fallback as arch upstream does
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD22
2 files changed, 10 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fde4f50c2291..1628d1d95d72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -21,6 +21,7 @@ pkgbase = gamescope-git
depends = libcap.so
depends = libdisplay-info.so
depends = libdrm
+ depends = libliftoff.so
depends = libinput
depends = libpipewire-0.3.so
depends = libvulkan.so
@@ -46,8 +47,6 @@ pkgbase = gamescope-git
provides = gamescope
conflicts = gamescope
source = git+https://github.com/ValveSoftware/gamescope.git
- source = git+https://github.com/nothings/stb.git#commit=af1a5bc352164740c1cc1354942b1c6b72eacb8a
- b2sums = SKIP
b2sums = SKIP
pkgname = gamescope-git
diff --git a/PKGBUILD b/PKGBUILD
index 1dc003430beb..7243c9f3811f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,6 +25,7 @@ depends=(
libcap.so
libdisplay-info.so
libdrm
+ libliftoff.so
libinput
libpipewire-0.3.so
libvulkan.so
@@ -58,12 +59,8 @@ makedepends=(
vulkan-headers
wayland-protocols
)
-source=(
- "git+https://github.com/ValveSoftware/gamescope.git"
- "git+https://github.com/nothings/stb.git#commit=af1a5bc352164740c1cc1354942b1c6b72eacb8a"
-)
-b2sums=('SKIP'
- 'SKIP')
+source=('git+https://github.com/ValveSoftware/gamescope.git')
+b2sums=('SKIP')
provides=("$_pkgname")
conflicts=("$_pkgname")
@@ -78,13 +75,12 @@ prepare() {
echo "Applying patch $src..."
git apply "../$src"
done
-
- git submodule update --init --recursive --depth=1
+ meson subprojects download
+ git submodule init
git -c protocol.file.allow=always submodule update
- # make stb.wrap use our local clone
- rm -rf subprojects/stb
- git clone "$srcdir/stb" subprojects/stb
- cp -av subprojects/packagefiles/stb/* subprojects/stb/ # patch from the .wrap we elided
+
+ # Use Arch provided libdisplay-info, do use other subprojects as is
+ rm -rf subprojects/libdisplay-info
}
pkgver() {
@@ -93,8 +89,8 @@ pkgver() {
}
build() {
- export LDFLAGS="$LDFLAGS -lrt"
arch-meson "${_pkgname}" build \
+ -Dforce_fallback_for=stb \
-Dpipewire=enabled
meson compile -C build
}