summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArnaud Berthomier2020-02-05 10:34:42 -0600
committerArnaud Berthomier2020-02-05 10:34:42 -0600
commitc8b310c38f827a57bb363f68e3e566a4fc7168b9 (patch)
tree5f581439369b30419e67131b92a063eb16422b30
parent39fb7f399d2818ffe17330f4b7d1c8dcda45ae72 (diff)
downloadaur-c8b310c38f827a57bb363f68e3e566a4fc7168b9.tar.gz
Upstream release: 3.0.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2571b932c6ae..a7fdcd3138a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = monocypher
pkgdesc = Monocypher is an easy to use crypto library inspired by libsodium and TweetNaCl
- pkgver = 2.0.5
+ pkgver = 3.0.0
pkgrel = 1
- url = http://loup-vaillant.fr/projects/monocypher/
+ url = https://monocypher.org/
arch = i686
arch = x86_64
license = custom:BSD
depends = glibc
- source = https://monocypher.org/download/monocypher-2.0.5.tar.gz
- sha256sums = 4fc0496ee89c5a1f00e9fd4a87051137561cdbb6f1aeafd1cbf11a87288bca5b
- sha512sums = 634dfaa981decb48043161f733702f7b55c1057bbb4cd8c202c8d8c1dd6fadcfbce881328f5df95213931eeea160d74330d18992d83fd60c76390e53023078f9
+ source = https://monocypher.org/download/monocypher-3.0.0.tar.gz
+ sha256sums = 6604b837b99bc68c6c18ee5d8960ad24f404707a09418bf4c5dc8d493cb71afd
+ sha512sums = dfb260d080a3f710ab70b108b2e69d2fc0d18f9427584bb44c2009e87cb4c1a942df980a5f2ddfcf5b3f1e0c074ddde764da22b3516acc41ac812dbf22aae50d
pkgname = monocypher
diff --git a/PKGBUILD b/PKGBUILD
index d413119a60a2..c797006beaab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
-# Maintainer: Kamalavelan aka demonshreder <sskamalavelan@gmail.com>
+# Maintainer: Arnaud Berthomier <oz@cypr.io>
pkgname=monocypher
_pkgname=monocypher
-pkgver=2.0.5
+pkgver=3.0.0
pkgrel=1
pkgdesc="Monocypher is an easy to use crypto library inspired by libsodium and TweetNaCl"
arch=('i686' 'x86_64')
-url="http://loup-vaillant.fr/projects/monocypher/"
+url="https://monocypher.org/"
license=('custom:BSD')
depends=('glibc')
source=("https://monocypher.org/download/monocypher-${pkgver}.tar.gz")
-sha256sums=('4fc0496ee89c5a1f00e9fd4a87051137561cdbb6f1aeafd1cbf11a87288bca5b')
-sha512sums=('634dfaa981decb48043161f733702f7b55c1057bbb4cd8c202c8d8c1dd6fadcfbce881328f5df95213931eeea160d74330d18992d83fd60c76390e53023078f9')
+sha256sums=('6604b837b99bc68c6c18ee5d8960ad24f404707a09418bf4c5dc8d493cb71afd')
+sha512sums=('dfb260d080a3f710ab70b108b2e69d2fc0d18f9427584bb44c2009e87cb4c1a942df980a5f2ddfcf5b3f1e0c074ddde764da22b3516acc41ac812dbf22aae50d')
package() {
cd "$_pkgname-$pkgver"
install -d -m 755 "$pkgdir/usr/include/$pkgname"
install -m 644 src/monocypher.c "$pkgdir/usr/include/$pkgname/monocypher.c"
install -m 644 src/monocypher.h "$pkgdir/usr/include/$pkgname/monocypher.h"
- install -m 644 src/optional/sha512.h "$pkgdir/usr/include/$pkgname/sha512.h"
- install -m 644 src/optional/sha512.c "$pkgdir/usr/include/$pkgname/sha512.c"
+ install -m 644 src/optional/monocypher-ed25519.h "$pkgdir/usr/include/$pkgname/monocypher-ed25519.h"
+ install -m 644 src/optional/monocypher-ed25519.c "$pkgdir/usr/include/$pkgname/monocypher-ed25519.c"
install -d -m 755 "$pkgdir/usr/share/licenses/$pkgname"
install -m 644 LICENCE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -d -m 755 "$pkgdir/usr/share/man/man3"
- install -m 644 doc/man/man3/* "$pkgdir/usr/share/man/man3/"
- }
+ install -m 644 doc/man/man3/*.3monocypher "$pkgdir/usr/share/man/man3/"
+ install -m 644 doc/man/man3/optional/* "$pkgdir/usr/share/man/man3/"
+}