summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake2021-10-21 22:25:30 +0200
committerJake2021-10-21 22:27:35 +0200
commitc8bbc2fb42bfb7a6bb496fe267190370123a0146 (patch)
tree31fb0e9554bf172fffb9f4bb9be21ecc0ddaf0c1
parentf0243d3e7621ef7813b15f63509a9ec3fc2ae79a (diff)
downloadaur-c8bbc2fb42bfb7a6bb496fe267190370123a0146.tar.gz
Switch to opera ffmpeg codecs
because the nwjs prebuilt project did not receive update and is broken
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
-rwxr-xr-xblackbox-explorer.sh2
3 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4830463eb46..02c911e5cf40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = blackbox-explorer
pkgdesc = Cleanflight and Betaflight Blackbox Explorer (NW.js build)
pkgver = 3.5.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/betaflight/blackbox-log-viewer
arch = x86_64
license = GPL3
makedepends = yarn
makedepends = npm
depends = nwjs-bin>=0.31.0
- depends = nwjs-ffmpeg-codecs-bin
+ depends = opera-ffmpeg-codecs
options = !strip
source = https://github.com/betaflight/blackbox-log-viewer/archive/3.5.0.tar.gz
source = blackbox-explorer.sh
source = blackbox-explorer.desktop
sha512sums = 6b6afc88e2e4e2509d2895729a4f126eb54af978f5b27b3ec335df00e3f7f29ded9cc2f25a681dc6d94eca2540efaa2250d8638c6cb80d273a254a20a15787c2
- sha512sums = d5e10ddba597043b75e7a5e02bf23d4bf1c6c64907c9b187e2e48bed045e001abaaec062b39bd9040222d1693758a54112d56d92538cb8b717d2b60d41175fa4
+ sha512sums = 2edc208a2d3901b2908303a7eee4abb48fb87cdc283cb4f40ed69f92317c71b7fcc6aa992364cfe14eecbf37096897329b959893906688db00a6051e44e9ca44
sha512sums = c06b498dfa438002ee9f5f4e90276b051762a936057b6b513e207106f727978fd301d8c131ab320cedc50eb86e46f1f8905b867caf1e6d550fda54985a2529ae
pkgname = blackbox-explorer
-
diff --git a/PKGBUILD b/PKGBUILD
index 1b7dd490951b..ed6f9192f632 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
pkgname=blackbox-explorer
_reponame=blackbox-log-viewer
pkgver=3.5.0
-pkgrel=2
+pkgrel=3
pkgdesc="Cleanflight and Betaflight Blackbox Explorer (NW.js build)"
arch=("x86_64")
url="https://github.com/betaflight/${_reponame}"
license=('GPL3')
-depends=('nwjs-bin>=0.31.0' 'nwjs-ffmpeg-codecs-bin')
+depends=('nwjs-bin>=0.31.0' 'opera-ffmpeg-codecs')
makedepends=('yarn' 'npm')
source=("https://github.com/betaflight/${_reponame}/archive/$pkgver.tar.gz"
"$pkgname.sh"
"$pkgname.desktop")
sha512sums=('6b6afc88e2e4e2509d2895729a4f126eb54af978f5b27b3ec335df00e3f7f29ded9cc2f25a681dc6d94eca2540efaa2250d8638c6cb80d273a254a20a15787c2'
- 'd5e10ddba597043b75e7a5e02bf23d4bf1c6c64907c9b187e2e48bed045e001abaaec062b39bd9040222d1693758a54112d56d92538cb8b717d2b60d41175fa4'
+ '2edc208a2d3901b2908303a7eee4abb48fb87cdc283cb4f40ed69f92317c71b7fcc6aa992364cfe14eecbf37096897329b959893906688db00a6051e44e9ca44'
'c06b498dfa438002ee9f5f4e90276b051762a936057b6b513e207106f727978fd301d8c131ab320cedc50eb86e46f1f8905b867caf1e6d550fda54985a2529ae')
options=(!strip)
diff --git a/blackbox-explorer.sh b/blackbox-explorer.sh
index 2302d6eb97af..d3fc7d01d953 100755
--- a/blackbox-explorer.sh
+++ b/blackbox-explorer.sh
@@ -1,3 +1,3 @@
#!/bin/sh
-env LD_PRELOAD=/opt/nwjs/libffmpeg.so nw /usr/share/blackbox-explorer/
+env LD_PRELOAD=/usr/lib/opera/lib_extra/libffmpeg.so nw /usr/share/blackbox-explorer/