aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo Carolino2023-02-15 01:49:02 -0300
committerDanilo Carolino2023-02-15 01:49:02 -0300
commitc8c2bed8c544cc09b1f7f56184c2b1d8ebb72b65 (patch)
treebd038f0796d4d5fa355644b5c977097e7d70de19
parent2fd1e5eac3aa7f8d213d6634ea3c348aa7d00a0b (diff)
downloadaur-c8c2bed8c544cc09b1f7f56184c2b1d8ebb72b65.tar.gz
refac: trying to make build work
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 55d039cf2693..3e89750c3c4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _gitbranch=main
_gitauthor=devemio
pkgname=docker-color-output-git
pkgver=2.2.0
-pkgrel=10
+pkgrel=11
pkgdesc="Colors for Docker CLI"
arch=('x86_64')
license=('MIT')
@@ -12,9 +12,10 @@ url="https://github.com/${_gitauthor}/${pkgname%-git}"
source=("${pkgname%-git}.tar.gz::https://github.com/${_gitauthor}/${pkgname%-git}/archive/refs/tags/v${pkgver}.tar.gz")
sha512sums=('SKIP')
depends=('go')
-makedepends=(git)
+makedepends=("go" "git")
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
+options=("!lto")
prepare() {
cd "$srcdir/${pkgname%-git}-${pkgver}"
@@ -31,7 +32,7 @@ build() {
export CGO_CPPFLAGS="$CPPFLAGS"
export GOCACHE=/tmp/
make EXT_LDFLAGS="-linkmode external" GOFLAGS="-buildmode=pie -trimpath"
- cp bin/docker-color-output dco
+ mv bin/docker-color-output dco
}
package() {