summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2023-12-26 07:55:30 +0100
committerMartin Diehl2023-12-26 07:55:30 +0100
commitc8d283c0205d9069cd8c3729e3cf24788a414480 (patch)
tree5f400c1d269a586700979debf0df90a8f745378d
parent60d38e221b124283609da6b9e8a489d4ab0e7d59 (diff)
downloadaur-c8d283c0205d9069cd8c3729e3cf24788a414480.tar.gz
use make to let user control number of jobs
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e56b52e2acb..f51b1ef2a1e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = trilinos
pkgdesc = algorithms for the solution of large-scale scientific problems
pkgver = 15.0.0
- pkgrel = 1
+ pkgrel = 2
url = http://trilinos.org
arch = x86_64
license = LGPL3
diff --git a/PKGBUILD b/PKGBUILD
index 1d1e8481bbc2..e158c4afe630 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=trilinos
pkgver=15.0.0
_pkgver=${pkgver//./-}
-pkgrel=1
+pkgrel=2
pkgdesc="algorithms for the solution of large-scale scientific problems"
arch=('x86_64')
url="http://trilinos.org"
@@ -41,7 +41,7 @@ build() {
-D TPL_ENABLE_MPI:BOOL=ON \
-D TPL_ENABLE_HDF5:BOOL=ON \
-D CMAKE_Fortran_FLAGS="$FCFLAGS -fallow-argument-mismatch"
- cmake --build build --parallel 4
+ make -C build
}
check() {