summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVaporeon2020-02-20 20:35:24 +1300
committerVaporeon2020-02-20 20:35:24 +1300
commitc8eaae9979b30ab909c06d79e126e56e965fe0d9 (patch)
treecbf94f0a09166d953897529057365ccfb58c2c21
parent5164503c55355473e0ffbce27229b795fb336f97 (diff)
downloadaur-c8eaae9979b30ab909c06d79e126e56e965fe0d9.tar.gz
v114 update
-rw-r--r--.SRCINFO10
-rwxr-xr-xPKGBUILD11
-rw-r--r--package.patch22
3 files changed, 19 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09173abd05ec..f8341d27ca76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Oct 1 07:40:23 UTC 2019
+# Thu Feb 20 07:35:21 UTC 2020
pkgbase = bsnes-qt5
pkgdesc = Super Nintendo emulator focusing on performance, features, and ease of use.
- pkgver = 110
+ pkgver = 114
pkgrel = 1
url = https://byuu.org/emulation/bsnes/
arch = x86_64
@@ -16,10 +16,10 @@ pkgbase = bsnes-qt5
conflicts = bsnes-classic
conflicts = bsnes-plus
conflicts = bsnes
- source = https://download.byuu.org/bsnes_v110-source.zip
+ source = https://download.byuu.org/bsnes_v114-source.zip
source = package.patch
- sha256sums = 16dfd733e9bd717547a7ebdc6af5b06ac15597fddff90df64e9115e685887dbd
- sha256sums = e800849a4e6c9b431578c2c55bfaab7b0619629ba34bd97f38bae64d5f2412d6
+ sha256sums = b6868e4bf63d912be94b66546cf5470831aceb3fc1b2bd0564b7f6d9b084ac0e
+ sha256sums = f391b8ce83ed1dfe93d83484464613de1fa1c454d69b02c5234efc9ef69fd3bb
pkgname = bsnes-qt5
diff --git a/PKGBUILD b/PKGBUILD
index a1e7a148e0e5..da57a493032b 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Elaina Martineau <elainamartineau@gmail.com>
pkgname=bsnes-qt5
-pkgver=110
+pkgver=114
pkgrel=1
pkgdesc='Super Nintendo emulator focusing on performance, features, and ease of use.'
arch=('x86_64')
@@ -11,23 +11,20 @@ license=('GPL3')
depends=('qt5-base' 'libpulse' 'libxv' 'libao' 'openal' 'sdl2')
conflicts=('bsnes-classic' 'bsnes-plus' 'bsnes')
source=("https://download.byuu.org/bsnes_v${pkgver//./r}-source.zip" 'package.patch')
-sha256sums=('16dfd733e9bd717547a7ebdc6af5b06ac15597fddff90df64e9115e685887dbd'
- 'e800849a4e6c9b431578c2c55bfaab7b0619629ba34bd97f38bae64d5f2412d6')
+sha256sums=('b6868e4bf63d912be94b66546cf5470831aceb3fc1b2bd0564b7f6d9b084ac0e'
+ 'f391b8ce83ed1dfe93d83484464613de1fa1c454d69b02c5234efc9ef69fd3bb')
prepare() {
cd "bsnes_v${pkgver//./r}-source"
-
- patch --forward --strip=1 --input="${srcdir}/package.patch"
+ patch --forward --strip=1 --input="${srcdir}/package.patch" --ignore-whitespace
}
build() {
cd "bsnes_v${pkgver//./r}-source"
-
make -C bsnes hiro=qt5 moc=/usr/bin/moc
}
package() {
cd "bsnes_v${pkgver//./r}-source"
-
make -C bsnes hiro=qt5 moc=/usr/bin/moc prefix="${pkgdir}/usr" install
}
diff --git a/package.patch b/package.patch
index 8512d3fd1f22..e1215507a360 100644
--- a/package.patch
+++ b/package.patch
@@ -13,17 +13,15 @@ diff --unified --recursive bsnes_v108-source.orig/bsnes/GNUmakefile bsnes_v108-s
flags += -I. -I..
-diff --unified --recursive bsnes_v108-source.orig/bsnes/target-bsnes/GNUmakefile bsnes_v108-source.new/bsnes/target-bsnes/GNUmakefile
---- bsnes_v108-source.orig/bsnes/target-bsnes/GNUmakefile 2019-03-10 01:51:07.601683406 -0700
-+++ bsnes_v108-source.new/bsnes/target-bsnes/GNUmakefile 2019-03-10 01:52:00.013706440 -0700
-@@ -34,9 +34,7 @@
- verbose: hiro.verbose ruby.verbose nall.verbose all;
-
+diff --unified --recursive bsnes_v113-source.orig/bsnes/target-bsnes/GNUmakefile bsnes_v113-source.new/bsnes/target-bsnes/GNUmakefile
+--- bsnes_v113-source.orig/bsnes/target-bsnes/GNUmakefile 2019-12-11 12:19:18.782618740 -0700
++++ bsnes_v113-source.new/bsnes/target-bsnes/GNUmakefile 2019-12-11 12:20:36.969034855 -0700
+@@ -40,8 +40,6 @@
+
install: all
--ifeq ($(shell id -un),root)
-- $(error "make install should not be run as root")
--else ifeq ($(platform),windows)
-+ifeq ($(platform),windows)
+ ifeq ($(platform),windows)
+-else ifeq ($(shell id -un),root)
+- $(error "make install should not be run as root")
else ifeq ($(platform),macos)
- mkdir -p ~/Library/Application\ Support/$(name)/
- cp -R out/$(name).app /Applications/$(name).app
+ mkdir -p ~/Library/Application\ Support/$(name)/
+ mkdir -p ~/Library/Application\ Support/$(name)/Database/