summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2017-10-09 07:09:10 +0100
committerWill Handley2017-10-09 07:09:10 +0100
commitc8f2a5b04468cb04f1c0491cc760114100e763b1 (patch)
tree2d804eb91c14fe57de0b9cfc4614acf4bb6eee63
parentf08efa5a95733a09a12e0126e9e7655a4feef589 (diff)
downloadaur-c8f2a5b04468cb04f1c0491cc760114100e763b1.tar.gz
Added checks
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
2 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d396826873d0..773928025090 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lalstochastic
pkgdesc = The LIGO Scientific Consortium Algorithm Library Suite. lalstochastic
pkgver = 1.1.20
- pkgrel = 2
+ pkgrel = 3
url = https://wiki.ligo.org/DASWG/LALSuiteInstall
arch = any
groups = lalsuite
diff --git a/PKGBUILD b/PKGBUILD
index 1e1144d028d0..1581be30e6be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
pkgname=lalstochastic
+_pkgname=${pkgname}
pkgver=1.1.20
-pkgrel=2
-pkgdesc="The LIGO Scientific Consortium Algorithm Library Suite. lalstochastic"
+pkgrel=3
+pkgdesc="The LIGO Scientific Consortium Algorithm Library Suite. ${_pkgname}"
arch=(any)
url="https://wiki.ligo.org/DASWG/LALSuiteInstall"
license=('unknown')
@@ -15,12 +16,19 @@ replaces=()
backup=()
options=(!emptydirs)
install=
-source=("http://software.ligo.org/lscsoft/source/lalsuite/${pkgname}-${pkgver}.tar.xz")
+source=("http://software.ligo.org/lscsoft/source/lalsuite/${_pkgname}-${pkgver}.tar.xz")
sha256sums=('e384f21f788c8c0521e3f9d50cc40e9e7d333f63cebbdac73b206658c45ffffe')
-package() {
- cd "$srcdir/${pkgname}-${pkgver}"
+build() {
+ cd "$srcdir/${_pkgname}-${pkgver}"
sed -i 's/\-Werror//g' configure
- ./configure --prefix=$pkgdir/usr
+ ./configure --prefix=$pkgdir/usr CFLAGS=-O3
make -j
+}
+package() {
+ cd "$srcdir/${_pkgname}-${pkgver}"
make install
}
+check() {
+ cd "$srcdir/${_pkgname}-${pkgver}"
+ make -j check
+}