summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112016-08-21 08:26:57 +0200
committerjose17112016-08-21 08:26:57 +0200
commitc92568d4f69a31359a3338e3cdf4f2d6771bea30 (patch)
tree75ff28305a3dd7f63df9e92001b1be3a3a603d9b
downloadaur-c92568d4f69a31359a3338e3cdf4f2d6771bea30.tar.gz
Adopt from aur3 and update source (now hosted on github)
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1a6c108baa5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Aug 21 06:26:40 UTC 2016
+pkgbase = perl-file-slurp-unicode
+ pkgdesc = Reading/Writing of Complete Files with Unicode Support (obsolete)
+ pkgver = 0.7.1
+ pkgrel = 1
+ url = https://github.com/caldwell/File-Slurp-Unicode
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ depends = perl-file-slurp
+ options = !emptydirs
+ source = https://github.com/caldwell/File-Slurp-Unicode/archive/master.zip
+ md5sums = 5a5b25f700c928d93e7445be12ed79fb
+
+pkgname = perl-file-slurp-unicode
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b68f9dcafb0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Andreas dot Wagner at em dot uni-frankfurt dot de
+# Maintainer: Jose Riha <jose1711 gmail com>
+
+pkgname=perl-file-slurp-unicode
+_cpanname=File-Slurp-Unicode-master
+pkgver=0.7.1
+pkgrel=1
+pkgdesc="Reading/Writing of Complete Files with Unicode Support (obsolete)"
+arch=('any')
+url="https://github.com/caldwell/File-Slurp-Unicode"
+license=('GPL' 'PerlArtistic')
+depends=('perl' 'perl-file-slurp')
+options=('!emptydirs')
+source=(https://github.com/caldwell/File-Slurp-Unicode/archive/master.zip)
+
+build() {
+ cd $srcdir/${_cpanname}
+ perl Build.PL installdirs=vendor destdir=$pkgdir || return 1
+ perl Build
+}
+
+package() {
+ cd $srcdir/${_cpanname}
+ perl Build install
+ find $pkgdir -name '.packlist' -delete
+ find $pkgdir -name '*.pod' -delete
+}
+
+md5sums=('5a5b25f700c928d93e7445be12ed79fb')