summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2019-05-29 23:54:06 +0300
committerStelios Tsampas2019-05-29 23:54:06 +0300
commitc9654d10319bf660b94d6e7c66de9211f493f60c (patch)
tree3aaab3235dc1451c3d7165e2bebc8bb5aa5df44a
parent8284deb3b82651707881e916dbf22c419d6a6a10 (diff)
downloadaur-c9654d10319bf660b94d6e7c66de9211f493f60c.tar.gz
version 0.12
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD25
-rw-r--r--dxvk-async.patch2
-rw-r--r--setup_dxvk.patch109
4 files changed, 19 insertions, 127 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 922ba761bb06..e4e9f0a3d2ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = d9vk-mingw
pkgdesc = A d3d9 to vk layer based off DXVK's codebase, mingw version
- pkgver = 0.11
- pkgrel = 2
+ pkgver = 0.12
+ pkgrel = 1
url = https://github.com/Joshua-Ashton/d9vk
arch = x86_64
license = zlib/libpng
@@ -17,14 +17,12 @@ pkgbase = d9vk-mingw
depends = bash
provides = d9vk
conflicts = d9vk
- source = git+https://github.com/Joshua-Ashton/d9vk.git#tag=0.11
+ source = git+https://github.com/Joshua-Ashton/d9vk.git#tag=0.12
source = setup_d9vk
- source = setup_dxvk.patch
source = dxvk-async.patch
sha256sums = SKIP
sha256sums = 7147644664ef33d04f7b18683c47be95b5664c57cf6d63fdc019d915deebd37a
- sha256sums = 4e74b2d921c38ca0f9c5a6069501e9d15c7c076dcd6d41ae243830375115b8f9
- sha256sums = 1f9e060fe059c0333bbe361f6278716757a853ab7b289186f58f3ddd2466bb8e
+ sha256sums = 32780432c2159d57ca0fb1863309cdb141fbfc506c6b9003acfa05896af90140
pkgname = d9vk-mingw
diff --git a/PKGBUILD b/PKGBUILD
index 61107fcb2c12..63a4dd445fb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: loathingkernel <loathingkernel @at gmail .dot com>
pkgname=d9vk-mingw
-pkgver=0.11
-pkgrel=2
+pkgver=0.12
+pkgrel=1
pkgdesc="A d3d9 to vk layer based off DXVK's codebase, mingw version"
arch=('x86_64')
url="https://github.com/Joshua-Ashton/d9vk"
@@ -14,23 +14,20 @@ conflicts=("d9vk")
source=(
"git+https://github.com/Joshua-Ashton/d9vk.git#tag=$pkgver"
"setup_d9vk"
- "setup_dxvk.patch"
"dxvk-async.patch"
)
sha256sums=(
"SKIP"
"7147644664ef33d04f7b18683c47be95b5664c57cf6d63fdc019d915deebd37a"
- "4e74b2d921c38ca0f9c5a6069501e9d15c7c076dcd6d41ae243830375115b8f9"
- "1f9e060fe059c0333bbe361f6278716757a853ab7b289186f58f3ddd2466bb8e"
+ "32780432c2159d57ca0fb1863309cdb141fbfc506c6b9003acfa05896af90140"
)
prepare() {
cd d9vk
- patch -p1 -i ../setup_dxvk.patch
-
# Uncomment to enable dxvk async patch.
- # Enable at your own risk, if you don't know what it is,
- # leave it as is. You have been warned.
+ # Enable at your own risk. If you don't know what it is,
+ # and its implications, leave it as is. You have been warned.
+ # I am not liable if anything happens to you by using it.
#patch -p1 -i ../dxvk-async.patch
}
@@ -41,7 +38,10 @@ build() {
--bindir "" --libdir "" \
--buildtype "release" \
--strip \
- -Denable_tests=false
+ -Denable_tests=false \
+ -Denable_d3d10=false \
+ -Denable_d3d11=false \
+ -Denable_dxgi=false
ninja -C "build/x64" -v
meson d9vk "build/x32" \
@@ -50,7 +50,10 @@ build() {
--bindir "" --libdir "" \
--buildtype "release" \
--strip \
- -Denable_tests=false
+ -Denable_tests=false \
+ -Denable_d3d10=false \
+ -Denable_d3d11=false \
+ -Denable_dxgi=false
ninja -C "build/x32" -v
}
diff --git a/dxvk-async.patch b/dxvk-async.patch
index 7455dfd2dbd4..ec8ac9c1aac3 100644
--- a/dxvk-async.patch
+++ b/dxvk-async.patch
@@ -18,7 +18,7 @@ index 9f9a4c25..b9e34316 100644
@@ -590,7 +590,7 @@ namespace dxvk {
const Rc<DxvkImageView>& imageView,
VkImageAspectFlags clearAspects,
- const VkClearValue& clearValue) {
+ VkClearValue clearValue) {
- this->updateFramebuffer();
+ this->updateFramebuffer(false);
diff --git a/setup_dxvk.patch b/setup_dxvk.patch
deleted file mode 100644
index 80d69f1a84d9..000000000000
--- a/setup_dxvk.patch
+++ /dev/null
@@ -1,109 +0,0 @@
-diff --git a/setup_dxvk.sh b/setup_dxvk.sh
-index f6bb5b7d..01cebf7f 100644
---- a/setup_dxvk.sh
-+++ b/setup_dxvk.sh
-@@ -50,6 +50,7 @@ if [ -z "$wine" ]; then
- fi
-
- wine64="${wine}64"
-+wineboot="${wine}boot"
-
- # resolve 32-bit and 64-bit system32 path
- winever=`$wine --version | grep wine`
-@@ -58,6 +59,10 @@ if [ -z "$winever" ]; then
- exit 1
- fi
-
-+# ensure wine placeholder dlls are recreated
-+# if they are missing
-+$wineboot -u
-+
- win32_sys_path=$($wine winepath -u 'C:\windows\system32' 2> /dev/null)
- win64_sys_path=$($wine64 winepath -u 'C:\windows\system32' 2> /dev/null)
-
-@@ -91,14 +96,14 @@ installFile() {
- if [ -f "${srcfile}.so" ]; then
- srcfile="${srcfile}.so"
- fi
--
-+
- if ! [ -f "${srcfile}" ]; then
-- echo "${srcfile}: File not found" >&2
-- exit 1
-+ echo "${srcfile}: File not found. Skipping." >&2
-+ return 1
- fi
--
-+
- if [ -n "$1" ]; then
-- if [ -f "${dstfile}" ]; then
-+ if [ -f "${dstfile}" ] || [ -h "${dstfile}" ]; then
- if ! [ -f "${dstfile}.old" ]; then
- mv "${dstfile}" "${dstfile}.old"
- else
-@@ -107,31 +112,58 @@ installFile() {
- $file_cmd "${srcfile}" "${dstfile}"
- else
- echo "${dstfile}: File not found in wine prefix" >&2
-- exit 1
-+ return 1
- fi
- fi
-+ return 0
- }
-
- # remove dxvk dll, restore original file
- uninstallFile() {
-- dstfile="${1}/${2}.dll"
--
-+ dstfile="${1}/${3}.dll"
-+ srcfile="${basedir}/${2}/${3}.dll"
-+
-+ if [ -f "${srcfile}.so" ]; then
-+ srcfile="${srcfile}.so"
-+ fi
-+
-+ if ! [ -f "${srcfile}" ]; then
-+ echo "${srcfile}: File not found. Skipping." >&2
-+ return 1
-+ fi
-+
-+ if ! [ -f "${dstfile}" ] && ! [ -h "${dstfile}" ]; then
-+ echo "${dstfile}: File not found. Skipping." >&2
-+ return 1
-+ fi
-+
- if [ -f "${dstfile}.old" ]; then
- rm "${dstfile}"
- mv "${dstfile}.old" "${dstfile}"
-+ return 0
-+ else
-+ return 1
- fi
- }
-
- install() {
- installFile "$win32_sys_path" "x32" "$1"
-+ inst32_ret="$?"
- installFile "$win64_sys_path" "x64" "$1"
-- overrideDll "$1"
-+ inst64_ret="$?"
-+ if [ "$inst32_ret" -eq 0 ] || [ "$inst64_ret" -eq 0 ]; then
-+ overrideDll "$1"
-+ fi
- }
-
- uninstall() {
-- uninstallFile "$win32_sys_path" "$1"
-- uninstallFile "$win64_sys_path" "$1"
-- restoreDll "$1"
-+ uninstallFile "$win32_sys_path" "x32" "$1"
-+ uninst32_ret="$?"
-+ uninstallFile "$win64_sys_path" "x64" "$1"
-+ uninst64_ret="$?"
-+ if [ "$uninst32_ret" -eq 0 ] || [ "$uninst64_ret" -eq 0 ]; then
-+ restoreDll "$1"
-+ fi
- }
-
- # skip dxgi during install if not explicitly