summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-06-25 14:52:45 +0300
committerPekka Ristola2023-06-25 14:52:45 +0300
commitc9688e48a446ee4ff749fdca923f35ba44e05346 (patch)
tree22bbdb63fed6a8a0cc44811270142e20ea706284
parent7f70d610efd2d64741cd0562ac8565dd15661907 (diff)
downloadaur-c9688e48a446ee4ff749fdca923f35ba44e05346.tar.gz
Update to 4.0.5
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD23
2 files changed, 26 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ff9574a132c..becb675725b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = r-bit
pkgdesc = Classes and Methods for Fast Memory-Efficient Boolean Selections
- pkgver = 4.0.4
+ pkgver = 4.0.5
pkgrel = 1
url = https://cran.r-project.org/package=bit
arch = i686
arch = x86_64
- license = GPL2
- license = GPL3
- depends = r>=2.9.2
- optdepends = r-testthat
- optdepends = r-roxygen2
- optdepends = r-knitr
- optdepends = r-rmarkdown
- optdepends = r-microbenchmark
+ license = GPL
+ depends = r
optdepends = r-bit64
optdepends = r-ff
- source = https://cran.r-project.org/src/contrib/bit_4.0.4.tar.gz
- sha256sums = e404841fbe4ebefe4ecd4392effe673a8c9fa05f97952c4ce6e2f6159bd2f168
+ optdepends = r-knitr
+ optdepends = r-microbenchmark
+ optdepends = r-rmarkdown
+ optdepends = r-roxygen2
+ optdepends = r-testthat
+ source = https://cran.r-project.org/src/contrib/bit_4.0.5.tar.gz
+ sha256sums = f0f2536a8874b6a30b80baefbc68cb21f0ffbf51f3877bda8038c3f9f354bfbc
pkgname = r-bit
diff --git a/PKGBUILD b/PKGBUILD
index 9203f8c882b2..061a4eaf71d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,28 @@
-# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Alex Branham <branham@utexas.edu>
_cranname=bit
-_cranver=4.0.4
+_cranver=4.0.5
pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
+pkgver=${_cranver//-/.}
pkgrel=1
pkgdesc="Classes and Methods for Fast Memory-Efficient Boolean Selections"
arch=(i686 x86_64)
url="https://cran.r-project.org/package=${_cranname}"
-license=(GPL2 GPL3)
-depends=('r>=2.9.2')
-optdepends=(r-testthat r-roxygen2 r-knitr r-rmarkdown r-microbenchmark r-bit64 r-ff)
+license=(GPL)
+depends=(r)
+optdepends=(
+ r-bit64
+ r-ff
+ r-knitr
+ r-microbenchmark
+ r-rmarkdown
+ r-roxygen2
+ r-testthat
+)
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha256sums=('e404841fbe4ebefe4ecd4392effe673a8c9fa05f97952c4ce6e2f6159bd2f168')
+sha256sums=('f0f2536a8874b6a30b80baefbc68cb21f0ffbf51f3877bda8038c3f9f354bfbc')
build() {
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"