summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Aranguren2019-12-19 12:14:53 +1100
committerLuis Aranguren2019-12-19 12:14:53 +1100
commitc96f984e4505030adcf6ddb076aef16d9c2b76bd (patch)
tree3ddad66c1e55fabe820d15f734cd21bb8d6834e8
parent8fcce9a919eccd7cef4a0b203939f3684237340a (diff)
downloadaur-c96f984e4505030adcf6ddb076aef16d9c2b76bd.tar.gz
pkrel=3, corrected dependency python-scikit-learn, fixed secrets.ini, fixed zm_train_faces.py
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd8a01ea72cc..b0fc640ab2c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zmeventnotification-git
pkgdesc = Event Notification Server sits along with ZoneMinder and offers real time notifications, support for push notifications as well as Machine Learning powered recognition + hooks
pkgver = v4.6.1.r20.gf70308a
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/pliablepixels/zmeventnotification
arch = x86_64
license = GPL
@@ -29,7 +29,7 @@ pkgbase = zmeventnotification-git
depends = python-future
depends = python-shapely
depends = python-mysql-connector
- depends = python-sklearn-bayes
+ depends = python-scikit-learn
depends = python-face_recognition
backup = etc/zoneminder/objectconfig.ini
backup = etc/zoneminder/secrets.ini
diff --git a/PKGBUILD b/PKGBUILD
index 485425a0b547..67b582a557a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=zmeventnotification-git
_pkgname=zmeventnotification
pkgver=v4.6.1.r20.gf70308a
-pkgrel=2
+pkgrel=3
pkgdesc='Event Notification Server sits along with ZoneMinder and offers real time notifications, support for push notifications as well as Machine Learning powered recognition + hooks'
arch=('x86_64')
url='https://github.com/pliablepixels/zmeventnotification'
@@ -12,7 +12,7 @@ depends=('perl-crypt-mysql' 'perl-config-inifiles' 'perl-crypt-eksblowfish' 'per
'perl-io-socket-ssl' 'perl-net-mqtt-simple' 'perl-config-inifiles' 'opencv'
#hooks
'geos' 'hdf5' 'python-numpy' 'python-imutils' 'python-pyzm-git' 'python-sqlalchemy' 'python-psutil' 'python-future' 'python-shapely' 'python-mysql-connector'
- 'python-sklearn-bayes' 'python-face_recognition'
+ 'python-scikit-learn' 'python-face_recognition'
)
makedepends=('cmake' 'wget' 'git')
optdepends=()
@@ -49,8 +49,8 @@ prepare () {
sed -i "s|/etc/apache2/ssl/yourportal|/etc/ssl/private|" zmeventnotification.ini
#secrets.ini
- sed -i "s|URL=https://portal/zm|ZM_PORTAL=http://your_website|" secrets.ini
sed -i "s|ZM_PORTAL=https://portal/zm|ZM_PORTAL=http://127.0.0.1:8095|" secrets.ini
+ sed -i "s|URL=https://portal/zm|ZM_PORTAL=http://your_website|" secrets.ini
#zm_detect_wrapper.sh
sed -i "s|/etc/zm|/etc/zoneminder|" hook/zm_detect_wrapper.sh
@@ -58,6 +58,9 @@ prepare () {
#zmeventnotification.pl
sed -i "s|/etc/zm/zmeventnotification.ini|/etc/zoneminder/zmeventnotification.ini|" zmeventnotification.pl
+
+ #zm_train_faces.py
+ sed -i "s|/etc/zm/objectconfig.ini|/etc/zoneminder/objectconfig.ini|" hook/zm_train_faces.py
}
build() {