summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2023-11-09 09:49:53 +0800
committerUniversebenzene2023-11-09 09:49:53 +0800
commitc97162ba6bee9810b4606e9c9ee65e20244121dd (patch)
tree291775689439516b84edc3389906771a4447e1aa
parent7f74f08f6afc5a298ba29e24ff13058ab1b54b25 (diff)
downloadaur-c97162ba6bee9810b4606e9c9ee65e20244121dd.tar.gz
Update to version 1.0.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de606bc6ca0c..ba1dc696efc6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-jupyter-cache
pkgdesc = A defined interface for working with a cache of jupyter notebooks
- pkgver = 0.6.1
+ pkgver = 1.0.0
pkgrel = 1
url = https://jupyter-cache.readthedocs.io
arch = any
@@ -18,8 +18,8 @@ pkgbase = python-jupyter-cache
makedepends = python-flit-core
makedepends = python-build
makedepends = python-installer
- source = https://github.com/executablebooks/jupyter-cache/archive/refs/tags/v0.6.1.tar.gz
- md5sums = 18376504e5882af3b74801f55fe77546
+ source = https://github.com/executablebooks/jupyter-cache/archive/refs/tags/v1.0.0.tar.gz
+ md5sums = f09de465ec4aacaecab782d054263de6
pkgname = python-jupyter-cache
depends = python-attrs
@@ -28,7 +28,7 @@ pkgname = python-jupyter-cache
depends = python-tabulate
depends = python-yaml
depends = jupyter-nbformat
- depends = jupyter-nbclient
+ depends = jupyter-nbclient>=0.2
depends = python-sqlalchemy<3
optdepends = python-click-log: cli
optdepends = python-jupytext: rtd
diff --git a/PKGBUILD b/PKGBUILD
index 24ba358a5d63..e7d1b3a6c991 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,11 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python-jupyter-cache
+#_pname=${pkgbase#python-}
+#_pyname=${_pname//-/_}
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
#"python-${_pyname}-doc")
-pkgver=0.6.1
+pkgver=1.0.0
pkgrel=1
pkgdesc="A defined interface for working with a cache of jupyter notebooks"
arch=('any')
@@ -15,7 +17,7 @@ makedepends=('python-flit-core'
# 'python-sphinx-copybutton'
# 'python-sphinx-book-theme'
# 'python-myst-nb'
-# 'python-myst-parser<0.19'
+## 'python-myst-parser<0.19'
# 'python-jupytext'
# 'python-nbdime') # myst-nb: circular dep
checkdepends=('python-pytest'
@@ -30,7 +32,7 @@ checkdepends=('python-pytest'
'python-yaml')
#source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
source=("https://github.com/executablebooks/jupyter-cache/archive/refs/tags/v${pkgver}.tar.gz")
-md5sums=('18376504e5882af3b74801f55fe77546')
+md5sums=('f09de465ec4aacaecab782d054263de6')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -45,12 +47,12 @@ check() {
mkdir -p dist/lib
bsdtar -xpf dist/${_pyname/-/_}-${pkgver}-py3-none-any.whl -C dist/lib
- PYTHONPATH="dist/lib" pytest || warning "Tests failed" # -vv --color=yes
+ PYTHONPATH="dist/lib" pytest || warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count
# --deselect=tests/test_cache.py::test_execution_jupytext
}
package_python-jupyter-cache() {
- depends=('python-attrs' 'python-click' 'python-importlib-metadata' 'python-tabulate' 'python-yaml' 'jupyter-nbformat' 'jupyter-nbclient' 'python-sqlalchemy<3')
+ depends=('python-attrs' 'python-click' 'python-importlib-metadata' 'python-tabulate' 'python-yaml' 'jupyter-nbformat' 'jupyter-nbclient>=0.2' 'python-sqlalchemy<3')
optdepends=('python-click-log: cli'
'python-jupytext: rtd'
'python-myst-nb: rtd'