summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2016-06-26 15:22:12 -0400
committerTed Alff2016-06-26 15:22:12 -0400
commitc980ef244b4e6f49e388f496491daa4c446a2979 (patch)
treef514e51379f34d356fcb48959aba04d3d684050d
parentaae84b98f344a3beeca32ff845b0d70e6d28659c (diff)
downloadaur-c980ef244b4e6f49e388f496491daa4c446a2979.tar.gz
Adopted. Version bump: 1.14.1. Change _gtk_ver to 3 to easily switch build to GTK3
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD41
-rw-r--r--engrampa.install13
-rw-r--r--[-rwxr-xr-x]engrampa.tap0
4 files changed, 34 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9bd6ca576a0..2d6e39e96776 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Tue Dec 8 22:44:34 UTC 2015
+# Sun Jun 26 19:21:05 UTC 2016
pkgbase = engrampa-thunar
- pkgdesc = Archive manipulator for MATE without Caja dependency (GTK2 version)
- pkgver = 1.12.0
+ pkgdesc = Archive manipulator for MATE without Caja dependency (GTK2 by default, change _gtk_ver to build against GTK3)
+ pkgver = 1.14.1
pkgrel = 1
url = http://mate-desktop.org
- install = engrampa.install
arch = i686
arch = x86_64
license = GPL
@@ -13,10 +12,10 @@ pkgbase = engrampa-thunar
makedepends = yelp-tools
depends = bzip2
depends = desktop-file-utils
- depends = gtk2
depends = gzip
depends = libarchive
depends = tar
+ depends = gtk2
optdepends = unrar: for RAR uncompression
optdepends = zip: for ZIP archives
optdepends = unzip: for ZIP archives
@@ -27,12 +26,12 @@ pkgbase = engrampa-thunar
optdepends = thunar-archive-plugin: create and extract archives in Thunar
provides = engrampa
conflicts = engrampa
- replaces = engrampa
+ conflicts = engrampa-gtk3
options = !emptydirs
- source = http://pub.mate-desktop.org/releases/1.12/engrampa-1.12.0.tar.xz
+ source = http://pub.mate-desktop.org/releases/1.14/engrampa-1.14.1.tar.xz
source = fr-rpm-bsdtar.patch
source = engrampa.tap
- sha1sums = 76e2ac2806c6dcf6744766df6f9d0c056df5e301
+ sha1sums = 1245f5203b37b842cfaf818781b17cd22f1234b1
sha1sums = 219b05a979bf6f249aaae27964f02345fd81168d
sha1sums = 84f023a660c77cf046cff71d1d890f7de5af4110
diff --git a/PKGBUILD b/PKGBUILD
index 37b0415de202..6cdb4fbe57d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: 0strodamus <0strodamus at cox dot net>
+# Maintainer: twa022 <twa022 at gmail dot com>
+# Contributor: 0strodamus <0strodamus at cox dot net>
# Contributor: Rob McCathie <korrode AT gmail>
# Contributor: n00b <dannyurvt (at) gmail.com>
#
@@ -6,17 +7,19 @@
#
# note: if you get "No suitable archive manager found" errors, you need
# to adjust Xfce Settings > MIME Type Editor associations for Engrampa
+#
+# Set _gtk_ver to 3 to compile against GTK3
-pkgname=engrampa-thunar
+_gtk_ver=2
_pkgname=engrampa
-pkgver=1.12.0
-_pkgver=1.12
+pkgname=${_pkgname}-thunar
+pkgver=1.14.1
pkgrel=1
-pkgdesc="Archive manipulator for MATE without Caja dependency (GTK2 version)"
+pkgdesc="Archive manipulator for MATE without Caja dependency (GTK2 by default, change _gtk_ver to build against GTK3)"
url="http://mate-desktop.org"
arch=('i686' 'x86_64')
license=('GPL')
-depends=('bzip2' 'desktop-file-utils' 'gtk2' 'gzip' 'libarchive' 'tar')
+depends=('bzip2' 'desktop-file-utils' 'gzip' 'libarchive' 'tar')
makedepends=('mate-common' 'yelp-tools')
optdepends=('unrar: for RAR uncompression'
'zip: for ZIP archives' 'unzip: for ZIP archives'
@@ -24,17 +27,24 @@ optdepends=('unrar: for RAR uncompression'
'unace: extraction tool for the proprietary ace archive format'
'yelp: for reading MATE help documents'
'thunar-archive-plugin: create and extract archives in Thunar')
-provides=($_pkgname)
-conflicts=($_pkgname)
-replaces=($_pkgname)
+provides=()
+conflicts=("${_pkgname}" "${_pkgname}-gtk3")
+
+if [ "${_gtk_ver}" == '3' ] ; then
+ depends+=('gtk3')
+ provides+=("${_pkgname}-gtk3")
+else
+ depends+=('gtk2')
+ provides+=("${_pkgname}")
+fi
+
options=( '!emptydirs')
-source=("http://pub.mate-desktop.org/releases/${_pkgver}/${_pkgname}-${pkgver}.tar.xz"
+source=("http://pub.mate-desktop.org/releases/${pkgver%.*}/${_pkgname}-${pkgver}.tar.xz"
'fr-rpm-bsdtar.patch'
'engrampa.tap')
-sha1sums=('76e2ac2806c6dcf6744766df6f9d0c056df5e301'
+sha1sums=('1245f5203b37b842cfaf818781b17cd22f1234b1'
'219b05a979bf6f249aaae27964f02345fd81168d'
'84f023a660c77cf046cff71d1d890f7de5af4110')
-install=engrampa.install
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
@@ -47,10 +57,13 @@ build() {
./configure \
--prefix=/usr \
--libexecdir=/usr/lib/${_pkgname} \
- --with-gtk=2.0 \
+ --with-gtk=${_gtk_ver}.0 \
--disable-static \
--disable-packagekit \
- --disable-caja-actions -without-cajadir
+ --disable-caja-actions \
+ --without-cajadir \
+ --enable-magic \
+ --disable-schemas-compile
make
}
diff --git a/engrampa.install b/engrampa.install
deleted file mode 100644
index bf6781f93005..000000000000
--- a/engrampa.install
+++ /dev/null
@@ -1,13 +0,0 @@
-post_install() {
- glib-compile-schemas /usr/share/glib-2.0/schemas/
- gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}
diff --git a/engrampa.tap b/engrampa.tap
index 628f2de6140f..628f2de6140f 100755..100644
--- a/engrampa.tap
+++ b/engrampa.tap