summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Giovannetti2015-06-14 11:48:35 +0800
committerDario Giovannetti2015-06-14 11:48:35 +0800
commitc9d2ec088c5f2d8cdb496de8f27e2a4e83f3b77e (patch)
treed53dadefcde95c73bf18f62b1700b2171e407cc0
downloadaur-c9d2ec088c5f2d8cdb496de8f27e2a4e83f3b77e.tar.gz
Init commit
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD27
-rw-r--r--outspline.install11
4 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f4657779533
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = outspline
+ pkgdesc = Outliner and personal time organizer to manage todo lists, schedule tasks, remind events.
+ pkgver = 0.8.2
+ pkgrel = 1
+ url = https://kynikos.github.io/outspline/
+ install = outspline.install
+ arch = any
+ license = GPL3
+ depends = wxpython<3.1
+ optdepends = python2-dbus: prevent opening multiple instances with the same configuration file
+ optdepends = dbus-glib: prevent opening multiple instances with the same configuration file
+ optdepends = libnotify: for desktop notifications (notify plugin)
+ optdepends = python2-gobject: for desktop notifications (notify plugin)
+ optdepends = outspline-extra: extra addons
+ optdepends = outspline-experimental: experimental addons
+ optdepends = outspline-development: development tools for beta testers
+ conflicts = organism
+ conflicts = organism-organizer
+ replaces = organism
+ replaces = organism-organizer
+ source = http://downloads.sourceforge.net/project/outspline/main/outspline-0.8.2.tar.bz2
+ sha256sums = 525613e0f8a36831c9af03714d4124ebcc1462f574fa498d5e28b533d4bfe71b
+
+pkgname = outspline
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..70b001fd049c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/outspline
+/*.pkg.tar.xz
+/*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7fc03aaa9f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Dario Giovannetti <dev at dariogiovannetti dot net>
+
+pkgname='outspline'
+pkgver='0.8.2'
+pkgrel=1
+pkgdesc="Outliner and personal time organizer to manage todo lists, schedule tasks, remind events."
+arch=('any')
+url="https://kynikos.github.io/outspline/"
+license=('GPL3')
+depends=('wxpython<3.1')
+optdepends=('python2-dbus: prevent opening multiple instances with the same configuration file'
+ 'dbus-glib: prevent opening multiple instances with the same configuration file'
+ 'libnotify: for desktop notifications (notify plugin)'
+ 'python2-gobject: for desktop notifications (notify plugin)'
+ 'outspline-extra: extra addons'
+ 'outspline-experimental: experimental addons'
+ 'outspline-development: development tools for beta testers')
+conflicts=('organism' 'organism-organizer')
+replaces=('organism' 'organism-organizer')
+install=outspline.install
+source=("http://downloads.sourceforge.net/project/outspline/main/$pkgname-$pkgver.tar.bz2")
+sha256sums=('525613e0f8a36831c9af03714d4124ebcc1462f574fa498d5e28b533d4bfe71b')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}
diff --git a/outspline.install b/outspline.install
new file mode 100644
index 000000000000..1a05f573e594
--- /dev/null
+++ b/outspline.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}