summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Pointhuber2019-06-08 12:31:51 +0200
committerThomas Pointhuber2019-06-08 12:31:51 +0200
commitc9d5893aeae323e6eda77881ff0cf1b7b475c314 (patch)
tree89a6c161eb5f00f25cdcb25d4cc87cd1c6cab36d
downloadaur-c9d5893aeae323e6eda77881ff0cf1b7b475c314.tar.gz
Initial Version (1.0.5-0)
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
-rw-r--r--brother-dcpj572dw.install27
-rw-r--r--fix_lp.patch11
4 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc06a20641ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = brother-dcpj572dw
+ pkgdesc = Driver for the Brother DCP-J762DW wifi multifunctional printer
+ pkgver = 1.0.5
+ pkgrel = 1
+ url = https://support.brother.com/g/b/downloadlist.aspx?c=ch&lang=de&prod=dcpj572dw_eu_as&os=127
+ install = brother-dcpj572dw.install
+ arch = i686
+ arch = x86_64
+ license = custom:brother
+ makedepends = bash
+ optdepends = brscan4: scanner support
+ optdepends = brscan-skey: remote scan support
+ source = fix_lp.patch
+ source = https://download.brother.com/welcome/dlf103778/dcpj572dwpdrv-1.0.5-0.i386.rpm
+ sha256sums = 190b9b9a0f53db624db06e433acbee99876f49dc0da40478a3af6afefedf51c4
+ sha256sums = cae9133aed983ffb64f8cd98bc13e93036e7d5fe78d2514b8c74845ca3be3882
+
+pkgname = brother-dcpj572dw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd9a101a4b1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Thomas Pointhuber <thomas.pointhuber@@gmx..at>
+# Based on the DCP-J552DW PKGBUILD -> Marius Rejdak <mariuswol at gmail dot com>
+pkgname=brother-dcpj572dw
+pkgver=1.0.5
+pkgrel=1
+pkgdesc="Driver for the Brother DCP-J762DW wifi multifunctional printer"
+url="https://support.brother.com/g/b/downloadlist.aspx?c=ch&lang=de&prod=dcpj572dw_eu_as&os=127"
+license=('custom:brother')
+optdepends=('brscan4: scanner support'
+ 'brscan-skey: remote scan support')
+makedepends=('bash')
+install='brother-dcpj572dw.install'
+arch=('i686' 'x86_64')
+
+sha256sums=('190b9b9a0f53db624db06e433acbee99876f49dc0da40478a3af6afefedf51c4'
+ 'cae9133aed983ffb64f8cd98bc13e93036e7d5fe78d2514b8c74845ca3be3882')
+
+source=(
+ "fix_lp.patch" \
+ "https://download.brother.com/welcome/dlf103778/dcpj572dwpdrv-$pkgver-0.i386.rpm"
+)
+
+build() {
+ cd "$srcdir"
+ patch -Np0 < fix_lp.patch
+}
+
+package()
+{
+ install -d "$pkgdir"/usr/bin
+ install -Dm755 "$srcdir"/usr/bin/brprintconf_dcpj572dw "$pkgdir"/usr/bin/
+ cp -R "$srcdir"/opt "$pkgdir"/opt
+}
+
diff --git a/brother-dcpj572dw.install b/brother-dcpj572dw.install
new file mode 100644
index 000000000000..3769c864f528
--- /dev/null
+++ b/brother-dcpj572dw.install
@@ -0,0 +1,27 @@
+post_install() {
+ # lpr
+ /opt/brother/Printers/dcpj572dw/inf/setupPrintcapij dcpj572dw -i
+
+ # cupswrapper
+ /opt/brother/Printers/dcpj572dw/cupswrapper/cupswrapperdcpj572dw
+
+ systemctl restart org.cups.cupsd
+}
+
+post_upgrade() {
+ /bin/true
+}
+
+pre_remove() {
+ # lpr
+ /opt/brother/Printers/dcpj572dw/inf/setupPrintcapij dcpj572dw -e
+
+ # cupswrapper
+ /opt/brother/Printers/dcpj572dw/cupswrapper/cupswrapperdcpj572dw -e
+}
+
+op=$1
+shift
+
+$op "$@"
+
diff --git a/fix_lp.patch b/fix_lp.patch
new file mode 100644
index 000000000000..532e24be0dfa
--- /dev/null
+++ b/fix_lp.patch
@@ -0,0 +1,11 @@
+--- opt/brother/Printers/dcpj572dw/inf/setupPrintcapij.old 2008-09-15 22:01:07.000000000 +0200
++++ opt/brother/Printers/dcpj572dw/inf/setupPrintcapij 2008-09-15 22:01:26.000000000 +0200
+@@ -34,7 +34,7 @@
+ if [ ! -d $SPOOLER_NAME ]; then
+ mkdir $SPOOLER_NAME
+ fi
+- chown lp $SPOOLER_NAME
++ chown root $SPOOLER_NAME
+ chgrp lp $SPOOLER_NAME
+ chmod 700 $SPOOLER_NAME
+