summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoel Maersk2016-03-31 13:16:10 +0300
committerNoel Maersk2016-03-31 13:16:10 +0300
commitc9dc58b5bc5655eb85e0050e3a295a1d8f4f88f1 (patch)
treed2c84dcc0f038e8b646f9d08ff67bb453791853f
downloadaur-c9dc58b5bc5655eb85e0050e3a295a1d8f4f88f1.tar.gz
emacs-markdown-mode-git
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
-rw-r--r--emacs-markdown-mode-git.install16
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2fc61bc8f2fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Thu Mar 31 10:13:41 UTC 2016
+pkgbase = emacs-markdown-mode-git
+ pkgdesc = Emacs markdown-mode
+ pkgver = 2.1.r110.g57d9daf
+ pkgrel = 1
+ url = http://jblevins.org/projects/markdown-mode/
+ install = emacs-markdown-mode-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = emacs
+ provides = emacs-markdown-mode
+ conflicts = emacs-markdown-mode
+ source = emacs-markdown-mode-git::git://jblevins.org/git/markdown-mode.git
+ md5sums = SKIP
+
+pkgname = emacs-markdown-mode-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a239bfa37c46
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Noel Maersk <veox wemakethings net>
+# Contributor: emhs <emhs08 gmail com>
+# Contributor: Nils <mail n-sch de>
+
+pkgname=emacs-markdown-mode-git
+pkgver=2.1.r110.g57d9daf
+pkgrel=1
+pkgdesc='Emacs markdown-mode'
+arch=('i686' 'x86_64')
+url='http://jblevins.org/projects/markdown-mode/'
+license=('GPL')
+makedepends=('git')
+depends=('emacs')
+install=${pkgname}.install
+provides=('emacs-markdown-mode')
+conflicts=('emacs-markdown-mode')
+source=("$pkgname"::'git://jblevins.org/git/markdown-mode.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ # cutting off 'v' prefix that presents in the git tag
+ git describe --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ mkdir -p $pkgdir/usr/share/emacs/site-lisp/markdown-mode
+ install -Dm644 *.el $pkgdir/usr/share/emacs/site-lisp/markdown-mode
+}
diff --git a/emacs-markdown-mode-git.install b/emacs-markdown-mode-git.install
new file mode 100644
index 000000000000..fe9dcf0bca63
--- /dev/null
+++ b/emacs-markdown-mode-git.install
@@ -0,0 +1,16 @@
+post_install() {
+ cat <<EOF
+==> Add this code to your Emacs init to use markdown-mode:
+
+(autoload 'markdown-mode "markdown-mode.el"
+ "Major mode for editing Markdown files" t)
+(setq auto-mode-alist
+ (cons '("\.md" . markdown-mode) auto-mode-alist))
+
+EOF
+}
+
+
+post_upgrade() {
+ post_install $1
+}