summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2021-07-09 23:39:39 +0000
committerGeorge Rawlinson2021-07-09 23:39:39 +0000
commitc9f4788b152513cdf4fc9cb80ff7fc4b79a298a6 (patch)
treed6fc00047460eb33343eb41f9ea7588fc160a154
downloadaur-c9f4788b152513cdf4fc9cb80ff7fc4b79a298a6.tar.gz
addpkg: python-flake8-plugin-utils 1.3.2-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD42
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94724c4f7001
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-flake8-plugin-utils
+ pkgdesc = Provides base classes and utils for flake8 plugin writing
+ pkgver = 1.3.2
+ pkgrel = 1
+ url = https://github.com/afonasev/flake8-plugin-utils
+ arch = any
+ license = MIT
+ checkdepends = python-pytest-deadfixtures
+ checkdepends = python-pytest-mock
+ makedepends = python-pip
+ makedepends = python-poetry
+ depends = python
+ depends = flake8
+ source = python-flake8-plugin-utils-1.3.2.tar.gz::https://github.com/afonasev/flake8-plugin-utils/archive/v1.3.2.tar.gz
+ b2sums = 344fbdad54078b911408c2b76c69adcef4182408ad1de8d8b46e92d0e50f8a72fd7f46161326bb6da101c9f51a2223b05af3d200666655a5d9258c3fa7c23180
+
+pkgname = python-flake8-plugin-utils
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d60f7f555a29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: George Rawlinson <grawlinson@archlinux.org>
+
+pkgname=python-flake8-plugin-utils
+_pkgname="${pkgname#python-}"
+pkgver=1.3.2
+pkgrel=1
+pkgdesc="Provides base classes and utils for flake8 plugin writing"
+arch=('any')
+url="https://github.com/afonasev/flake8-plugin-utils"
+license=('MIT')
+depends=('python' 'flake8')
+makedepends=('python-pip' 'python-poetry')
+checkdepends=('python-pytest-deadfixtures' 'python-pytest-mock')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+b2sums=('344fbdad54078b911408c2b76c69adcef4182408ad1de8d8b46e92d0e50f8a72fd7f46161326bb6da101c9f51a2223b05af3d200666655a5d9258c3fa7c23180')
+
+prepare() {
+ cd "$_pkgname-$pkgver"
+}
+
+build() {
+ cd "$_pkgname-$pkgver"
+ poetry build --format wheel
+}
+
+check() {
+ cd "$_pkgname-$pkgver"
+ pytest
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ PIP_CONFIG_FILE=/dev/null pip \
+ install \
+ --isolated \
+ --root="$pkgdir" \
+ --ignore-installed \
+ --no-deps \
+ dist/*.whl
+
+ install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+}